Joomla 2.5.4 Contact Form Not Sending Mail

For Joomla! 2.5 Coding related discussions, please use: http://groups.google.com/group/joomla-dev-general
Note: All 1.6, 1.7 and 3.5 releases have reached end of life and should be updated to 3.x.

Moderator: ooffick

Forum rules
Please use the mailing list here: http://groups.google.com/group/joomla-dev-general rather than this forum.
fatechand
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Apr 09, 2013 4:22 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by fatechand » Tue Apr 09, 2013 4:33 pm

After hours of googling and going crazy,
this worked for me:

Set components/contact/contact-form/check-session to NO!

now it works, don't ask me why...

xeont
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 205
Joined: Tue Sep 28, 2010 7:04 am
Location: Melbourne, Australia

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by xeont » Wed Apr 10, 2013 8:00 am

Fatechand,

Could you please let me know sessions on your works correctly?

Regards,
Xeont
http://www.xeont.com.au - Computer Parts | Forum
http://www.chicshop.com.au - ChicShop

zonhal
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Sat May 30, 2009 12:42 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by zonhal » Sat May 18, 2013 2:33 pm


jodofin
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Fri Jul 24, 2009 11:06 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by jodofin » Tue May 21, 2013 10:40 am

GreekChat wrote:Hello Joomla Forum ,

i have found the solution for this error.

The problem is with joomla 2.5.* and the php 5.3.*

you have to check in the joomla administrator Site > System Information > Php Settings

after check the Safe Mode in my joomla 2.5 was ON so the email function is not working for me.

i have to go in the php.ini settings to set the safe_mode = off ( DISABLE )

and now my email form works great.

Thank you

Seems like this may be an issue with other version of PHP 5.*

http://code.google.com/a/apache-extras. ... tail?id=68

Is there any way of accessing PHP.ini from within Joomla?

User avatar
emanipur
Joomla! Explorer
Joomla! Explorer
Posts: 387
Joined: Sat Jun 09, 2012 10:58 am
Location: Imphal
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by emanipur » Mon Jun 10, 2013 3:35 am

rickeeh wrote:
1. Select "Components" from the top level menu in the Joomla administrator backend, then "Contacts"
2. Click on whatever contact entry you are using for your contact form page, mine was named "Contact Us" (big surprise)
3. Select "Contact Details" on the right side and put in the email you want the contents of the form sent to
This is how it works for me
http://emanipur.org
Top Web designing team in Imphal,Manipur(India).

antitribus
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Aug 26, 2013 2:12 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by antitribus » Mon Aug 26, 2013 2:17 pm

Sorry for the english google translate, but I hope to help!
I solved the problem by downloading the new joomla 2.5.14 and putting the folder template/html folder of the component com_mailto

deddyand0666
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jul 25, 2013 1:04 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by deddyand0666 » Wed Sep 04, 2013 1:38 am

Hi,

I use Joomla 3.1.5. I fix it on my site with the following settings:

Mailer: SMTP
From Email: your@gmail.com
From Name: your name
SMTP Authentication: Yes
SMTP Security: SSL
SMTP Port: 465
SMTP Username: your@gmail.com
SMTP Password: *********
SMTP Host: smtp.gmaiL.com

WorldwideTimber
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Sep 04, 2013 2:51 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by WorldwideTimber » Wed Sep 04, 2013 3:57 am

Super basic beginner.

I recently upgraded to 2.5.14 from 2.5. Contact form with ReCaptcha was working fine until then.

With enabling Captcha, I get these errors:

1) Contact not found
Empty solution not allowed.

2) Contact not found

When I disable Captcha, I don't get the errors, the e-mail will send, e-mail will be received. BUT once the contact form is sent, the screen goes solid white. It doesn't redirect to where it should.

I do not have K2 running. I have "checked the session to no". I have tried playing with my SMTP Port #. My safemode is off.

Can someone please offer me some advice? I'd greatly appreciate it. Thanks.

http://www.timbertraders.com.au/Joomla2 ... contact-us

mishi
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Tue Mar 09, 2010 2:14 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by mishi » Fri Dec 27, 2013 6:59 am

I am running 2.5.17 and had this same issue. I went through every solution on here and the only one that fixed it was turning off URL Rewriting. It fixed the issue but I need the rewriting on...this is not a permanent solution. Does anyone have any idea how to fix this another way, so both are operative?

Thank you for your help,
Mishi

ramraobhuktar
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Dec 27, 2013 8:32 am
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by ramraobhuktar » Fri Dec 27, 2013 8:50 am

For my situation it still does not work. It appears to be this is a genuine issue that a large portion of us are encountering however no cement result has been found yet.

mishi
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Tue Mar 09, 2010 2:14 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by mishi » Fri Dec 27, 2013 9:42 pm

Ramrao....have you tried all of the solutions on here? It seems like it is a glitch and can be solved with lots of work arounds but I, like you, don't think this is the proper way to handle it. I am hoping someone can give a more permanent update soon.

Hopefully one of these will work for you.

dannykk
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Feb 07, 2014 1:31 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by dannykk » Fri Feb 07, 2014 1:36 am

I also spent many hours solving that problem. I did receive only copy email but there was no email to "my contact".

On my few sites problem was in linking contact to user. Try to separate your user account from contact and enter email address to appropriate field in your contact details.

Maybe this would be helpful to some...

mici
I've been banned!
Posts: 17
Joined: Thu Apr 11, 2013 7:08 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by mici » Sun Mar 16, 2014 8:57 am

matt_nz wrote:I tried installing a fresh 2.5.4 into a sub folder on the server and the email sent ok, so it seemed like an issue with that one Joomla install that had been upgraded.
Is there email limits?

tonybaino
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Feb 22, 2014 8:16 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by tonybaino » Fri Mar 21, 2014 3:22 pm

I had the same problem
it was solved by:
setting the email on the same server where joomla is hosted, with same php default setting
give it some time (1hr), it will work.

Tony

webtoonz
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Apr 22, 2014 9:23 am
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by webtoonz » Tue Apr 22, 2014 9:43 am

Hi Guys,

I had the same issue with one of my client's website with Joomla 3.2.3 contact form.

I was getting "thank You" message but emails were not sent to admin and user as well.

I spent time to find the solution for this problem and found lots of users are facing this almost same issue.

After research I found the solution that worked for me.

Change these to setting in Contact component and the menu item for the contact page and it works for my.

Here the setting you need to change on both places:
session check: yes
custom reply: no

Components > Contacts > Your Contact Form > Form tab > session check: yes / custom reply: no

AND

Menu > Your Menu> Your Contact Menu > Mail options > session check: yes / custom reply: no

This solution works for me in Joomla 3.2.3 version I hope this will also work in Joomla 2.5.4 as well.

mutant
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Feb 12, 2010 1:11 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by mutant » Tue Apr 22, 2014 8:43 pm

My contact form failed after a recent joomla update. After a bit of trial and error I found
SITE - GLOBAL CONFIG - SERVER - MAIL SETTINGS - MAILER had been altered from PHP to SMTP, changed it back to PHP and all fine

pembrokewcorgi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Jan 02, 2012 9:25 pm

Re: Joomla 2.5.22 Contact Form Not Sending Mail

Post by pembrokewcorgi » Thu Jul 17, 2014 7:41 pm

Using a different contact form, up until 2 days ago--messages were coming through. Now no emails will come through. Been working with my host support. They got two messages through but none of mine or the website owner's go through. I'm so confused as to what is causing the issue.

I changed the email type in global config to each one and tried it and nothing works. Well on the SMTP one, I get delivery failure messages.

So frustrated,
Colleen M

pembrokewcorgi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Jan 02, 2012 9:25 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by pembrokewcorgi » Thu Jul 31, 2014 2:29 am

Don't know if this will be of any help to anyone here, but wanted to share what I figured out. I have shared this at the site of the component I use in their forum.
Here is what I can tell you about what I think is happening. I worked with our hosting company and did some testing as the problem was intermittent. It seems to be only a problem with people using AOL or Yahoo emails. I found an article online which explains what is happening and I believe this is the root cause of missing messages. Here is the http://www.latimes.com/business/technol ... story.html.

As I don't understand the coding and if anything could be implemented to change how it see the actual email addresses, I don't know if there is any kind of fix for this issue. But AOL/Yahoo emails will not go through unless it is a direct email to email message.

For now, I have a large message up letting those users who have AOL or Yahoo emails know their messages will not go through and to get a different email account not of AOL/Yahoo or use a dummy email address I set up and tell them to put their actual contact email in their message.

Hope this makes sense,
Colleen M

kardinol
I've been banned!
Posts: 29
Joined: Sun Aug 18, 2013 11:23 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by kardinol » Sat Aug 16, 2014 2:17 pm

I made sure the email-addresses for the contacts to which I am trying to set the form have email addresses that are not running some background spam blocking.

Arezoo
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Sep 16, 2014 7:24 am

Re: Joomla 3.0.3 Contact Form Not Sending Mail

Post by Arezoo » Fri Nov 07, 2014 1:59 pm

I'm using joomla contact form . i can not receive any mail SMTP and PHP . I tried all ways but have no idea of where to check for the source of the problem.

Can someone give me some direction here?

Here are some settings from the Control Panel > Configuration File

Mailer *: SMTP
From email: xxxx@xx.com
From Name : a name
Sendmail Path: /usr/sbin/sendmail
SMTP Authentication : Yes
SMTP Security: None
SMTP Port *:587
SMTP Username: xxxx@xx.com
SMTP Password: xxxxxxxxxx
SMTP Host: mail.xx.com

and i have not problem with this email adress.

is there any other places that i need to set email setting too except here?

PabloSEO
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Nov 27, 2015 10:58 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by PabloSEO » Wed Dec 02, 2015 12:37 pm

Yo pude arreglar lo del modulo WS-RAPID-CONTACT activando la casilla de fixed url .

La web de Posicionamiento seo que no funcionaba es esta http://www.posicionamiento-seo-malaga.es

lonytang
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Feb 10, 2016 11:11 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by lonytang » Wed Feb 10, 2016 11:14 am

I set the parameter in Global Configuration/MailSettings mailer* to "SendMail" and it works fine ;)

karimnasr25
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Aug 24, 2016 4:46 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by karimnasr25 » Wed Aug 24, 2016 4:51 pm

Try That,

Under Global Configuration ----> Server.


From email : anyname@SameDomain.com

From Name: Anyname

Mailer: SMTP

SMTP Host : For Godaddy smtpout.secureserver.net
SMTP Port *: 80 or Try any port but not 25
SMTP Security: None

SMTP Authentication: Yes
SMTP Username: try to use same email as above (From one)
SMTP Password: password for that email

User avatar
ladydevil
Joomla! Intern
Joomla! Intern
Posts: 51
Joined: Sun Sep 14, 2014 5:56 am
Location: Singapore
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by ladydevil » Wed Sep 07, 2016 4:07 am

SMTP = localhost
SMTP port = 25
I think that is true.
Quạt trần: http://quatdentrangtri.vn/
Giấy dán tường: http://giaydantuonggiare.biz/

jamiehennings
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Apr 06, 2017 8:21 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by jamiehennings » Tue Apr 18, 2017 8:19 am

Hi,

I'm using Joomla 2.5.8 stable, and I can't receive the mail sent from the contact form I have on the website, I only receive the copy. There are no error messages, and it says the mail was successfully sent. I've tested many configurations, contacted the host provider, and he says the problem must be from joomla. I've searched the Joomla forums, tested many possibilities, like overwriting the mail folders on the libraries (phpmailer) with the folders from a previous version of joomla (2.5 and 2.5.4), but nothing worked. There's a possibility of the cause being the Joomla Safe Mode is ON, but I don't know how to turn the safe mode off. I tried to find solution on https://www.joomla.org/

Hope you can help me with this issue because I'm a bit desperate,

thanks,


Locked

Return to “Joomla! 2.5 Coding”