css problem bei aktiven link

Moderator: Sisko1990

Forum rules
Forumregeln
Locked
fine pixer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 23, 2013 9:10 am

css problem bei aktiven link

Post by fine pixer » Mon Sep 23, 2013 9:20 am

guten tag,
im joomla 1.5 gab es für die einen link der mich auf eine seite gebracht hat die class="current" und die einflussnahme zur gestaltung verlief problemlos.jetzt im joomla 2.5 gibt es diese class nicht dafür aber die class="item-xxx current active". nur kann ich hier keinen einfluss auf das aussehen nehmen. Oder doch. wenn das geht sagt mir bitte wie durch mein css-script habe ich versucht die class anzusprechen aber sie erscheint nicht so wie ich es ausgezeichnet habe. beispiel der link ist schwarz und soll wenn ich auf der entsprechenden seite bin rot sein.

danke für eure reaktionen schon mal im vorraus

User avatar
Slowrider
Joomla! Ace
Joomla! Ace
Posts: 1055
Joined: Wed Apr 21, 2010 7:36 am

Re: css problem bei aktiven link

Post by Slowrider » Mon Sep 23, 2013 4:25 pm

Moin Fine Pixer, versuchs bitte mal mit Satzzeichen und Groß- und Kleinschreibung. Ist echt schwer zu lesen.
BTW: Die verwendeten Klassen kannst du mit Firebug und Firefox bzw. Chrome und dem Kontextmenüpunkt "Element untersuchen" herausfinden und lokal anpassen, bis alles so ist, wie du möchtest.

fine pixer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 23, 2013 9:10 am

Re: css problem bei aktiven link

Post by fine pixer » Tue Sep 24, 2013 5:04 pm

moin slowrider,
also der rat war leider nicht hilfreich, die classe kenn ich ja [class="item-xxx current active" (xxx steht für eine zahl)] nur lässt sie sich leider nicht ansprechen. das heisst, der css befehl den ich für diese classe schreibe wird nicht ausgeführt. aber, ACHTUNG, wenn ich anstelle der zwischenräume unterstriche setze also:[class="item-xxx_current_active"] dann klappt das auch mit der dartsellung, nur leider liefert Jooomla nicht diese form, sondern die mit den zwischenräumen.

User avatar
Slowrider
Joomla! Ace
Joomla! Ace
Posts: 1055
Joined: Wed Apr 21, 2010 7:36 am

Re: css problem bei aktiven link

Post by Slowrider » Tue Sep 24, 2013 5:51 pm

Das muss mit den Leerzeichen nicht unbedingt zu tun haben, deshalb der Tipp mit dem Firebug. Durch die Kaskadierung ist es möglich, dass deine Anweisungen an anderer Stelle überschrieben werden. Mit Firebug siehst du, welche Anweisungen aktiv sind und welche ersetzt werden. Wenn du eine Klasse falsch benennst, wird sie nicht gefunden und in deinem Fall kommt dadurch wahrscheinlich (!) zufällig die richtige zum Einsatz. Link zur Seite?

fine pixer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 23, 2013 9:10 am

Re: css problem bei aktiven link

Post by fine pixer » Tue Sep 24, 2013 8:09 pm

verfluchte axt, danke slowrider, ich habs raus also die auszeichnung der classe im quelltext hat mich dabei verwirrt dabei ist es doch eigendlich eindeutig, ohne unterstrich bezeichnet es die moeglichkeiten,also ich kann itemxxx im css beschreiben, dann kann ich als classe current beschreiben u.s.w logisch oder :-) und ich hab es als ganzes verstanden also als eine classe di im css beschrieben werden muss. vielen dank nochmal.


Locked

Return to “Template, CSS und Designfragen”