[résolu] Joomla 1.6: j'ai installé au lieu de migrer)

Support et assistance pour installer, mettre à jour ou migrer vers Joomla! 1.6, 1.7 et 2.5

Moderators: Aidan38, sarki

Forum rules
Règles du forum
Locked
User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

[résolu] Joomla 1.6: j'ai installé au lieu de migrer)

Post by hansonhanson » Thu Jul 07, 2011 10:46 pm

EDIT: problème n°1 réglé mais lire ci-dessous!
Last edited by hansonhanson on Sun Jul 10, 2011 12:44 pm, edited 2 times in total.

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Problème après l'installation de Joomla 1.6

Post by hansonhanson » Fri Jul 08, 2011 6:31 pm

J'étais sous Joomla 1.5. J'ai installé Joomla 1.6.4, apparemment avec succès.

Sauf que:

-Sur la page d'administration Joomla, j'ai le formulaire de connexion habituel à l'administration Joomla, mais une fois connecté, j'ai juste une page blanche avec le message d'erreur suivant:
"Fatal error: Call to a member function login() on a non-object in /home/httpd/vhosts/nomdemonsite.com/httpdocs/administrator/components/com_login/admin.login.php on line 64"

-Sur mon site, on voit une page Joomla (Joomla! Open Source Content Management - Vous êtes ici : Home -Main Menu -Login Form) comme si mon site était tout nouveau et à créer. Il n'y a plus mes pages. Je peux cependant me connecter et suis reconnu comme "Super utilisateur". Mais c'est tout.

Quelqu'un peut-il m'aider?

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Problème après l'installation de Joomla 1.6

Post by hansonhanson » Sun Jul 10, 2011 10:53 am

Pas de support pour Joomla 1.6?

On se débrouille tout seul?

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by hansonhanson » Sun Jul 10, 2011 11:57 am

Je réalise (toute seule, faute d'aide...) (je décris mon aventure, ça servira peut-être à quelqu'un d'autre dans mon cas), que j'ai suivi le tutoriel d'installation de Joomla 1.6.4 (création d'une nouvelle base de données sur l'hébergeur, copie des fichiers dans Fillezilla, etc.) au lieu de suivre le tutoriel de migration (j'étais auparavant sous Joomla 1.5).

Maintenant, trop tard pour utiliser Jupgrade etc. selon le tuto de migration: je n'ai plus accès à l'administration du site ("fatal error", donc).

J'ai essayé de ré-installer Joomla 1.6 avec mon ancienne base de données: pas marché non plus (même message d'erreur). En fait, l'installation me crée de nouveaux fichiers jos_ . Les anciens jos_ sont certes sauvegardés (je le vois sur l'hébergeur dans ma base de données) mais ne sont pas utilisés au moment de l'installation.

Du coup, j'ai un site vide (juste une page joomla quand je vais dessus), ce qui est déjà embêtant en soi; mais surtout une administration inaccessible.

J'imagine que maintenant, pour régler le problème, ça doit passer par Filezilla (mais copier quoi sur quoi? J'ai peur d'effacer mes données!).

Ou bien sur la page d'hébergement, essayer de supprimer les nouveaux fichiers jos_ (comment?) pour que les anciens prennent le relais, peut-être en les renommant. Mais il risque d'y avoir des conflits au niveau du mot de passe d'utilisateur, non?

D'ailleurs, n'est-ce pas ce qui se passe? Peut-être le panneau d'administration du site réclame-t'il l'ancien mot de passe d'utilisateur de mon ancienne base de données? J'ai modifié ce mot de passe juste avant ma tentative de ré-installation avec l'ancienne base, justement pour pouvoir ré-installer. Je ne connais pas cet ancien mot de passe (qui était masqué sous des étoiles dans la page d'hébergement), attribué par l'ancien webmaster.

Peut-être faut-il que je fasse une modification du fichier admin.login.php à la ligne 64? Mais quelle modif?

Help !!!

User avatar
mejean
Joomla! Hero
Joomla! Hero
Posts: 2716
Joined: Thu Aug 18, 2005 12:28 pm
Location: viewforum.php?f=19
Contact:

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by mejean » Tue Jul 12, 2011 10:33 am

Il vous faut réinstaller la sauvegarde de votre site sous Joomla! 1.5

N'envisagez la migration que si vous avez vraiment besoin des nouvelles fonctionnalités qu'offre la version 1.6. (en effet la version 1.5 est une version de support à long terme (LTS) alors que la version 1.6, bientôt la 1.7, ne sont que des versions de support à court terme).

Si vous n'avez pas de sauvegarde (mais que vous disposez encore de la base de donnée), sauvegardez le tout (les fichiers et la base de données).
Réinstallez un site Joomla!1.5 avec les composants nécessaires (sur une nouvelle base de donnée !). Importez dans la nouvelle base la sauvegarde de l'ancienne ! Replacez les éventuels fichiers propres à votre site (images, documents à télécharger...) (et au bon endroit !).
Jérôme Bussière - simple utilisateur
www.cardabelle.net

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by hansonhanson » Thu Jul 14, 2011 10:28 am

J'ai vraiment besoin des nouvelles fonctionnalités 1.6.

Avant de toucher à quoi que ce soit, j'avais copié tous les dossiers/fichiers de Filezilla vers mon ordinateur... du moins tous ceux qui ont bien voulu se copier. Est-ce une sauvegarde suffisante?

Comment fait-on pour sauvegarder la base de données complète à partir de la page d'hébergement?

Comment fait-on pour importer dans la nouvelle base de données (j'en ai créé une vide) la sauvegarde de l'ancienne?

D'avance merci pour vos réponses.

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by hansonhanson » Thu Jul 14, 2011 7:18 pm

Donc, j'avais déjà sauvé les fichiers vers mon ordi.
J'ai aussi exporté sous forme sql l'ancienne base de données de la page d'hébergement vers mon ordi.

Puis, j'ai supprimé les dossiers et fichiers dans Filezilla. J'ai tout ré-installé avec la nouvelle base de données vide.

Joomla 1.6 est maintenant correctement installé; j'ai accès à l'administration.

Quelle est la meilleure méthode, maintenant, pour réinstaller mes données?

Copier les dossiers (tous? lesquels?) dans Fillezilla? Importer le fichier sql de mon ordi vers la nouvelle base de données sur la page d'hébergement? Passer par la page d'administration et faire les choses une à une?

User avatar
mejean
Joomla! Hero
Joomla! Hero
Posts: 2716
Joined: Thu Aug 18, 2005 12:28 pm
Location: viewforum.php?f=19
Contact:

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by mejean » Wed Jul 20, 2011 10:33 am

Non, vous devez
1. réinstaller Joomla!1.5 avec une nouvelle base de donnée (vide),
2. par FTP, remettre les fichiers spécifiques si vous en avez (images, documents, etc.),
3. installer les éventuels extensions que vous aviez auparavant notamment les composants et les templates...,
4. écraser la nouvelle base de données en important la nouvelle (vous devez avoir coché DROPTABLE lors de l'export de l'ancienne BD).

Pour passer à Joomla! 1.6, et non, maintenant la version 1.7 depuis hier, vous devez installer le composant Jupgrade et suivre les instructions de la documentation (Pour ma part, je n'ai pas fait cette manip).
Jérôme Bussière - simple utilisateur
www.cardabelle.net

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by hansonhanson » Wed Jul 20, 2011 5:04 pm

Merci. 1.5 est réinstallé avec les anciennes données, tout est ok.

Maintenant, 1.7 est-elle stable?

Conseillez-vous à ce stade de passer plutôt à 1.6 ou à 1.7?

User avatar
GrandSchtroumpf
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Jun 09, 2011 11:11 pm
Location: Cailloux-sur-Fontaines
Contact:

Re: Joomla 1.6: fatal error (j'ai installé au lieu de migrer

Post by GrandSchtroumpf » Thu Jul 21, 2011 9:23 pm

Bonjour,
Conseillez-vous à ce stade de passer plutôt à 1.6 ou à 1.7?
La 1.6, la 1.7 est encore au stade bêta. Le passage ultérieur de 1.6 à 1.7 se fera sans douleur.

User avatar
hansonhanson
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Thu Jul 07, 2011 10:19 pm

Re: Joomla 1.6: fatal error [résolu]

Post by hansonhanson » Fri Jul 22, 2011 5:08 am

Merci.

(Je ne peux plus éditer le premier message de ce sujet pour ajouter l'icone et marquer "résolu", un admin peut-il le faire pour moi? Merci).


Locked

Return to “2.5 - Installation, migration et mise à jour”