Page 1 of 1

مشكلة في رفع القوالب

Posted: Fri Nov 25, 2011 8:08 am
by ghadh

السلام عليكم ورحمة الله وبركاته

ترددت في اي قسم اطرح الموضوع ولعلي وفقت في طرحه هنا.. قمت بتركيب مجلة جملة الاصدار 1.6 ولكن واجهت مشكلة في رفع قالب وقمت بتجربة آداة الفحص وساعرض عليكم النتيجة امال منك في ايجاد الحل علما بأني قمت بتغيير صلاحيات المجلدات وكذلك قمت بطريقة رفع المجلد مره من لوحة التحكم ومرة من ال اف تي بي ولا يتيغر شي


معلومات الفحص
Joomla! Version: Joomla! 1.6.1 Stable [ Onward ] 07-Mar-2011 23:00 GMT
configuration.php: Writable (Mode: 666 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-238.9.1.el5PAE ( i686) | Web Server: SecuRed By Ahmed Helal ( My Website.com ) | PHP Version: 5.2.17
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Enabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Not Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: ( )

معلومات تفصيلية أكثر:
SEF: Enabled (without ReWrite) | FTP Layer: Enabled | htaccess: Implemented
PHP/suExec: User and Web Server accounts are not the same. (PHP/suExec probably not installed)
PHP Environment: API: apache2handler | MySQLi: Yes | Max. Memory: 64M | Max. Upload Size: 20M | Max. Post Size: 8M | Max. Input Time: 60 | Zend Version: 2.2.0
Disabled Functions: gzinflate,copy,dl,exec,shell_exec,pclose,pfsockopen,leak, apache_child_terminate,posix_kill,posix_mkfifo, posix_setpgid,posix_setsid,posix_setuid,escapeshellcmd, escapeshellarg,hell-exec, fpassthru,crack_check, crack_closedict,crack_getlastmessage,crack_opendict, psockopen,php_ini_scanned_files,system,passthru,exec,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,error_log,php_ini_loaded_file,getservbyport,getservbyname,get_cfg_var,ini_get_all
MySQL Client: 5.0.92 ( )
[/right]

Re: مشكلة في رفع القوالب

Posted: Fri Nov 25, 2011 10:31 pm
by fares5shm

أهلاً بك:

لماذا تستخدمين جوملا! 1.6 فهي غير مستقرة وتحتوي على ثغرات وأخطاء
إن كنت لم تبدأي بالموقع بعد فيفضل أن تنصبي جوملا! 1.7.3 أو التحديث إليها...

----

بخصوص مشكلة التنصيب، فيبدو من نتيجة الفحص أن لديك سببين شائعين لذلك:
safe_mode: Enabled السيف مود يفضل أن يكون معطل مع أن تفعيله ليس بالضرورة أن يسبب المشاكل
save.session_path: Not Writable هذا المسار من الضروري أن يكون قابلاً للكتابة، ولذلك يجب عليك الاتصال بالاستضافة وطلب جعل هذا المسار قابلاً للكتابة

كما اطلبي من الاستضافة أن تقرأ سجل الأخطاء بحثاً عن الدوال المعطلة والتي يمكن أن تسبب مشاكل في الرفع

بالتوفيق
[/right]

Re: مشكلة في رفع القوالب

Posted: Mon Nov 28, 2011 9:52 am
by ghadh
Joomla! 1.7.3 شكرا لردك استاذي الفاضل قمت بتركيب جملة الاصدار
وتظهر لي علامة التحميل الصورة مرفقه لا اعلم اين الخلل علما ان اصدار جملة قمت بتحملة من الموقع الاساسي؟؟

Re: مشكلة في رفع القوالب

Posted: Mon Nov 28, 2011 10:47 pm
by fares5shm

هل تم حل المشاكل المشار إليها في الرد السابق؟!

save.session_path: Not Writable قد تكون هذه هي السبب
الرجاء الاتصال بالاستضافة لحل هذه المشكلة
[/right]

Re: مشكلة في رفع القوالب

Posted: Tue Nov 29, 2011 7:41 am
by ghadh
لم تحل المشكلة الى الان قمت بمراسلة الاستضافة وانتظر الرد

شكراً لك استاذي على حرصك وماتبذله من مجهود في هذا المنتدى :)

Re: مشكلة في رفع القوالب

Posted: Wed Nov 30, 2011 12:54 pm
by ghadh
تم حل المشكلة ولله الحمد من قبل شركة الاستضافة وتم تركيب المجلة قمت بتحميل القالب الموجود في هذا الرابط

http://forum.joomla.org/viewtopic.php?f=671&t=647943

ولكن تظهر لي هذه المشكلة JInstaller: :Install: Cannot find XML setup file
مع العلم ان الاصدار الذي استخدمة 1.7.3
قمت بالبحث عن حل لها
وجدته هنا على هذا الرابط
http://www.phoca.cz/documents/2-phoca-g ... setup-file
عند تطبيقة تظهر لي هذه المشكلة قمت بأنشاء مجلد بداخل مجلد التيمب وغيرت المسار من لوحة التحكم عند الضغط على زر الانستول تظهر لي هذه الرساله
Please enter a package directory

لا اعلم اين الخلل مني او من شركة الاستضافة ارجو التكرم بمساعدتي لايجاد حل لها واكون شاكرة ومقدرة

Re: مشكلة في رفع القوالب

Posted: Wed Nov 30, 2011 5:57 pm
by fares5shm

يرجى ملاحظة أن ملف القالب الموجود في الموضوع الذي أشرته إليه اسمه:
jm-business-marketing-J16-UNPACK-FIRST.zip

أي أنه يجب أن تفكي الضغط عنه قبل الرفع، فهو يحتوي عدة ملفات مضغوطة وبداخلها ملف القالب
تأكدي من تنصيب ملف القالب فقط، وليس كامل الحزمة

تحياتي
[/right]

Re: مشكلة في رفع القوالب

Posted: Fri Dec 02, 2011 8:31 am
by ghadh
السلام عليكم استاذ فارس قمت بفك الضغط ورفع الملف ةتظهر لي هذه الرساله
Failed loading XML file
/home/My Website/public_html/tmp/install_4ed88ab69d868/jm-business-marketing/templateDetails.xml
XML: Document is empty
XML: Start tag expected, '<' not found
JInstaller: :Install: Cannot find Joomla XML setup file
وغيرت من صلاحيات المجلة لعلها تعمل ولم تظهر لي النتيجه المطلوبة وقمت بتجربة آداة الفحص مرة اخرى لهذا الاصدار 1.7.3 وتظهر لي
Server error
اتمنى منك الاطلاع على الموقع اذا كان وقتك يسمح لك وسارسل البيانات برسالة خاصة

شاكرة لك استاذ فارس

Re: مشكلة في رفع القوالب

Posted: Fri Dec 02, 2011 10:02 pm
by fares5shm

جربي تنزيل القالب من هذا الرابط:

Code: Select all

http://www.joomla-monster.com/free_templates/jm-business-marketing-J17-UNPACK-FIRST.zip
ومن ثم حاولي تنصيبه مجدداً.... طبعا بعد فك الضغط عن الحزمة
بالتوفيق
[/right]

Re: مشكلة في رفع القوالب

Posted: Sat Dec 03, 2011 5:56 am
by ghadh
السلام عليكم مرحبا استاذ فارس قمت بتنزيل القالب وفك الضغط وقمت بتحميله ظهرت لي هذه الرسالة
Failed loading XML file
/home/My Website/public_html/tmp/install_4ed9b8a81f150/jm-business-marketing/templateDetails.xml
XML: Document is empty
XML: Start tag expected, '<' not found
JInstaller: :Install: Cannot find Joomla XML setup file

لك كل الشكر على مجهودك ومتابعتك سأقوم أيضا بمراسلة شركة الاستضافة

Re: مشكلة في رفع القوالب

Posted: Sat Dec 03, 2011 9:30 am
by fares5shm

لا داع للاتصال بالاستضافة حالياً...

هل بإمكانك وضع محتوى ملف xml الخاص بالقالب هنا؟
[/right]

Re: مشكلة في رفع القوالب

Posted: Sat Dec 03, 2011 12:32 pm
by ghadh
عذراً فلم افهم سؤالك؟
اين اضع محتوى الملف؟

Re: مشكلة في رفع القوالب

Posted: Sun Dec 04, 2011 9:07 pm
by fares5shm

ghadh wrote:عذراً فلم افهم سؤالك؟
اين اضع محتوى الملف؟
انسخي محتوى ملف xml الخاص القالب، وألصقيه في مشاركتك
[/right]

Re: مشكلة في رفع القوالب

Posted: Mon Dec 05, 2011 6:09 am
by ghadh
قمت بوضع المحتوى وارفاق الملف

لك كل الشكر للمتابعة

Code: Select all



<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE install PUBLIC "-//Joomla! 1.6//DTD template 1.0//EN" "http://www.joomla.org/xml/dtd/1.6/template-install.dtd">
<extension version="1.7" type="template" client="site">
	<name>jm-business-marketing</name>
	<creationDate>10/10/2011</creationDate>
	<author>joomla-monster.com</author>
	<authorEmail>joomla-monster@design-joomla.eu</authorEmail>
	<authorUrl>joomla-monster.com</authorUrl>
	<copyright>Copyright (C) 2005 - 2011 Open Source Matters, Inc. All rights reserved.</copyright>
	<license>GNU General Public License version 2 or later; see LICENSE.txt</license>
	<version>1.7.0</version>
	<description><![CDATA[
	<head>
		<style>
			body {
				font-family:Arial, Helvetica, sans-serif;
				font-size:11px;
			}
			a:link,
			a:visited {
				color:#4991c1;
				font-weight:bold;
			}
			a:hover {
				text-decoration:underline;
			}
			h2 {
				color:#fa9539;
				text-transform:uppercase;
				font-size:16px;
				padding:0;
				margin:2px 0;
			}
			p {
				padding:0;
				margin:4px 0;
			}
			#left-logo {
				float:left;
				width: 320px;
				height:100px;
				display:block;
				padding-top:50px;
			}
			#right-text {
				float:left;
				width:400px;
			}
			#info {
				border:1px solid #efefef;
				padding:10px;
				background:#ffffff;
			}
			#info p {
				font-size:10px;
			}
		</style>
	</head>
	<body>
		<div id="left-logo">
			<img src="http://joomla-monster.com/images/jm-logo.png" />
		</div>
		<div id="right-text">
			<h2>Template jm-business-marketing</h2>
			<p><b>Templates for Joomla! CMS</b></p>
			<div id="info">
				<p><b>Version:</b> 1.7</p>
				<p><b>Date:</b> October 2011</p>
				<p><b>Client:</b> Random</p>
			</div>
			<p>
			Unique and oryginal templates for <b>Joomla! CMS</b> <br />
			Graphic design & template code: <b>design-joomla.eu</b> <br /><a href="http://www.design-joomla.eu">http://www.design-joomla.eu</a><br /><br />
			</p>
		</div>
	</body>
	]]></description>
	<files>
		<filename>component.php</filename>
		<filename>favicon.ico</filename>
		<filename>index.php</filename>
		<filename>template_preview.png</filename>
		<filename>template_thumbnail.png</filename>
		<folder>css</folder>
		<folder>html</folder>
		<folder>images</folder>
		<folder>lib</folder>
		<folder>language</folder>
	</files>
	<positions>
		<position>bottom</position>
		<position>breadcrumbsload</position>
		<position>copyrights</position>
		<position>dj-menu-top</position>
		<position>header</position>
		<position>position-0</position>
		<position>position-7</position>
		<position>rightload</position>
	</positions>
	<!-- 	For core templates, we also install/uninstall the language files in the core language folders.
	-->
	<languages folder="language">
		<language tag="en-GB">en-GB/en-GB.tpl_jm-business-marketing.ini</language>
		<language tag="en-GB">en-GB/en-GB.tpl_jm-business-marketing.sys.ini</language>
	</languages>
	<config>
		<fields name="params">
			<fieldset name="advanced">
				<field name="logo" type="media" hide_default="1" label="TPL_JM-BUSINESS-MARKETING_FIELD_LOGO_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_LOGO_DESC" />
				<field name="sitetitle"  type="text" default="" label="TPL_JM-BUSINESS-MARKETING_FIELD_SITETITLE_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_SITETITLE_DESC" filter="string" />
				<field name="sitedescription"  type="text" default="" label="TPL_JM-BUSINESS-MARKETING_FIELD_DESCRIPTION_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_DESCRIPTION_DESC" filter="string" />
				<field name="stylearea" type="list" default="1" label="TPL_JM-BUSINESS-MARKETING_FIELD_STYLEAREA_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_STYLEAREA_DESC">
				    <option value="1">Enabled</option>
				    <option value="0">Disabled</option>
			    </field>   
			    <field name="template_color" type="list" default="1" label="TPL_JM-BUSINESS-MARKETING_FIELD_TEMPLATECOLOR_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_TEMPLATECOLOR_DESC">
		            <option value="1">Orange</option>
		            <option value="2">Red</option>
		            <option value="3">Blue</option>
					<option value="4">Green</option>
			     </field>
				<field name="page_width" type="text" default="900px" label="TPL_JM-BUSINESS-MARKETING_FIELD_PAGEWIDTH_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_PAGEWIDTH_DESC" />
    			<field name="left_width" type="text" default="200px" label="TPL_JM-BUSINESS-MARKETING_FIELD_LEFTWIDTH_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_LEFTWIDTH_DESC" />
				<field name="right_width" type="text" default="200px" label="TPL_JM-BUSINESS-MARKETING_FIELD_RIGHTWIDTH_LABEL" description="TPL_JM-BUSINESS-MARKETING_FIELD_RIGHTWIDTH_DESC" />
			</fieldset>
		</fields>
	</config>
</extension>




Re: مشكلة في رفع القوالب

Posted: Mon Dec 05, 2011 5:08 pm
by fares5shm
لقد قمت بتعديل ملف xml
الرجاء تجربته وموافاتنا بالنتيجة

بالتوفيق

Re: مشكلة في رفع القوالب

Posted: Tue Dec 06, 2011 8:13 pm
by fares5shm

ما زلت بانتظار النتيجة!
[/right]

Re: مشكلة في رفع القوالب

Posted: Tue Dec 06, 2011 10:25 pm
by ghadh
اعتذر عن تأخري بالرد بسبب ظرف قاهر ... قمت بلصق الملف على الملف الموجود في التمبلت وضغطته وقمت بتحميله مرة اخرى وظهرت لي هذه الرسالة
Failed loading XML file
/home/My Website/public_html/tmp/install_4ede964917ece/jm-business-marketing/templateDetails.xml
XML: Document is empty
XML: Start tag expected, '<' not found
JInstaller: :Install: Cannot find Joomla XML setup file
:(

وحاولت ايضاً تحميل مجلد الموديول الصفحة تصبح في وضع التحميل لمدة دقيقتين تقريبا بعدها تظهر لي هذه الصفحة

Server error
The website encountered an error while retrieving http://My Website/administrator/index.php?option=com_installer&view=install. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this webpage later.

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

افكر في تغيير الاستضافه فعلا لاني قمت بتجربة مجلة اخرى غير جملة وخطوات التحميل لا تكتمل معي يطلب الاذونات من ملفات وقمت بتغيير صلاحياتها ولم تحل المشكلة؟؟

هل لديك حل آخر استاذ فارس

شاكرة لك حسن معاملتك وحرصك

Re: مشكلة في رفع القوالب

Posted: Sat Dec 10, 2011 4:54 pm
by fares5shm

إن كنتِ تستطيعين تغيير الاستضافة فربما هذا هو الحل الأنسب!
لأنها بالتأكيد ليست الاستضافة المثالية لجوملا!

أما إن أردتِ المتابعة في حل مشكلتك، فيمكننا أن نجد طريقة لذلك

تحياتي
[/right]

Re: مشكلة في رفع القوالب

Posted: Sat Dec 10, 2011 5:18 pm
by ghadh
فعلاً هذا ماقمت به مراسلة الشركة المستضيفه لتغييرها لشركة أخرى بأنتظار الرد لا أدري ماهي الإجراءات اللازمة والتي تتخذ في هذه الحالات بالنسبه لنقل الموقع وهل تنصحني بشركة معينة أفضل وتدعم اللغة العربية..

لك كل الشكر على حسن تعاونك ومتابعتك للموضوع استاذ فارس