Page 1 of 1

مشكلة ما بعد التنصيب

Posted: Mon Jun 20, 2011 8:09 am
by miran60
السلام عليكم و رحمة الله
الأخوة في الدعم
واجهتني مشكلة بعد تنصيب كافة اصدارات جوملا
لا أعلم إن كان هناك خطأ في الموقع و ربما في مكان آخر
تتم تنصيب كافة إصدارات جوملا معي بالكامل
لكن المشكلة هي عدم تنفيذ أي أمر :
- مثلاً : الموقع مغلق ....... عندما اختار نعم - لا يتغير شيء
- عندما اغير صفحة الترحيب لا يتغير شيء
- عندما احذف مقلاً ... لا ينحذف
- عندما اوقف موديلاً ... لا يتوقف
أي بمعنى أصح ... تتم تنصيب جوملا بشكل جيد
لكن لا يتغير أي أمر اعطيه
و شكراً لكم

Re: مشكلة ما بعد التنصيب

Posted: Mon Jun 20, 2011 5:02 pm
by fares5shm

انت شاركت عنا، وبنفس الموضوع
http://forum.joomla.org/viewtopic.php?f ... 9#p2532689

أرجو منك وضع معلومات الفحص!
هل تظهر لك رسائل ما عندما تقوم بتعديل شيء، أي رسائل أخطاء أو ما شابه

وأيضاً تأكد من سجل الأخطاء error_log بحثاً عن مشكل محتمل
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Mon Jun 20, 2011 6:22 pm
by miran60
أولاً شكرا على ردك

معلومات الفحص



معلومات الفحص
Joomla! Version: Joomla! 1.6.3 Stable [ Onward ] 18-Apr-2011 23:00 GMT
configuration.php: Writable (Mode: 777 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-238.1.1.el5PAE ( i686) | Web Server: Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_python/3.3.1 Python/2.4.3 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.4 Perl/v5.8.8 ( www.al-asly.com ) | PHP Version: 5.2.17
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: ( )

معلومات تفصيلية أكثر:
SEF: Enabled (without ReWrite) | FTP Layer: Enabled | htaccess: Not Implemented
PHP/suExec: User and Web Server accounts are the same. (PHP/suExec probably installed)
PHP Environment: API: cgi | MySQLi: Yes | Max. Memory: 256M | Max. Upload Size: 64M | Max. Post Size: 64M | Max. Input Time: 60 | Zend Version: 2.2.0
Disabled Functions: passthru,escapteshellarg,popen
MySQL Client: 5.0.92 ( )



الرسالة التي تظهر عند أي تعديل : مثلاً تغيير عنوان الصفحة الرئيسية أو تفعيل الموقع مغلق هو : invalid token

ولك مني جزيل الشكر

Re: مشكلة ما بعد التنصيب

Posted: Mon Jun 20, 2011 7:19 pm
by fares5shm

نتيجة الفحص الخاص بك ممتازة، ولكن عليك أن تعدل تصاريح الملف configuration.php إلى 444 حرصاً على أمان موقعك!

بخصوص رسالة الخطأ، هل جربت متصفح آخر؟ هل جربت تنظيف الكوكيز الخاص بالمتصفح، وكذلك كاش الموقع؟
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Tue Jun 21, 2011 9:20 am
by miran60
شكراُ أخي فارس ... بخصوص الكوكيز تم تنظيفه
ولكن كيف نظف كاش الموقع ؟

Re: مشكلة ما بعد التنصيب

Posted: Tue Jun 21, 2011 10:54 am
by miran60
تتخلص المشاكل في مايلي :
- عدم تغير الإعدادت العامة للموقع ... مثلا : لو غيرت رسالة الموقع مغلق الى عبارة اخرى ... بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
لو غيرت عنوان الصفحة الرئيسة ................. بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
تفعيل خدمة الموقع خارج الخدمة ...................بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
لا اقدر ان احذف المقالات
لكن منثلا لو غيرنا القالب .. يتغير ... لو غيرنا مكان موديل يتغير





شكرا سلفا ........... تحياتي لك

Re: مشكلة ما بعد التنصيب

Posted: Tue Jun 21, 2011 6:04 pm
by fares5shm

تنظيف الكاش:
site >>> maintenance >>> Clear Cache

------------------------

في حال لم تصل إلى نتيجة، هل لك أن تجرب تغيير قالب الأدمن لو سمحت؟
غيره، وجرب من جديد

بالتوفيق
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Tue Jun 21, 2011 6:07 pm
by fares5shm

miran60 wrote:تتخلص المشاكل في مايلي :
- عدم تغير الإعدادت العامة للموقع ... مثلا : لو غيرت رسالة الموقع مغلق الى عبارة اخرى ... بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
لو غيرت عنوان الصفحة الرئيسة ................. بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
تفعيل خدمة الموقع خارج الخدمة ...................بعد النقر على حفظ - تعود الصفحة على ماكانت عليها
لا اقدر ان احذف المقالات
لكن منثلا لو غيرنا القالب .. يتغير ... لو غيرنا مكان موديل يتغير
هل تقصد هنا أن رسالة invalid token لا تزال تظهر لك؟

عندما تحاول حفظ الإعدادات، هل تظهر لك: invalid token؟ أو يظهر خطأ آخر؟
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Wed Jun 22, 2011 12:10 pm
by miran60
اخي فارس
حاولت كثراً ... و شكيت أنه من اصدار جوملا
تم تنزيل جوملا من موقع عيون جوملا الاصدار 1.5
و مازالت المشكلة ذاتها و لا توجد رسائل خطاً
سوى انه لم تحفظ الإعدادت في لوحة التحكم --- الاعدادات العامة
و هذا فحص اخر بعد تنصيب جوملا 1.5


معلومات الفحص
Joomla! Version: Joomla! 1.5.23 Stable [ senu takaa ama baji ] 04-March-2011 18:00 GMT
configuration.php: Writable (Mode: 644 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-238.1.1.el5PAE ( i686) | Web Server: Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_python/3.3.1 Python/2.4.3 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.4 Perl/v5.8.8 ( www.al-asly.com ) | PHP Version: 5.2.17
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.92-community ( Localhost via UNIX socket )

معلومات تفصيلية أكثر:
SEF: Disabled (without ReWrite) | FTP Layer: Enabled | htaccess: Not Implemented
PHP/suExec: User and Web Server accounts are the same. (PHP/suExec probably installed)
PHP Environment: API: cgi | MySQLi: Yes | Max. Memory: 256M | Max. Upload Size: 64M | Max. Post Size: 64M | Max. Input Time: 60 | Zend Version: 2.2.0
Disabled Functions: passthru,escapteshellarg,popen
MySQL Client: 5.0.92 ( latin1 )



بالمناسبة : قريت اكتر من منتدى يقال يجب حذف الملف configuration.php-dist بعد التنصيب ؟؟؟ !!!
شكرا سلفا

Re: مشكلة ما بعد التنصيب

Posted: Wed Jun 22, 2011 2:50 pm
by fares5shm

لا المشكلة ليست من إصدار جوملا، فالنسخة الرئيسية هنا، وليس في عيون جوملا!

أرجو منك قراءة سجل أخطاء النظام error_log لمعرفة موضع الخلل...
اطلب من الاستضافة قراءة السجل لك، أو ضع الأخطاء هنا في حال كنت قادراً على الوصول إليه
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Sat Jun 25, 2011 9:32 pm
by miran60
لا توجد اي اخطاء في سجل النظام

Re: مشكلة ما بعد التنصيب

Posted: Sun Jun 26, 2011 2:19 pm
by miran60
أخي لكي أوضح لك المشكلة أكثر :
في حال تغيير في تسميات القوائم أو اضافة بعد الروابط ... لا يتغير شي و تظهر صفحة بيضاء مكتوب فيها Invalid Token
في حال محاولة تغيير الإعدادات العامة ......... لا يتغير شي و تظهر صفحة بيضاء مكتوب فيها Invalid Token
و أحياناًُ تعود للصفحة العامة للإعدادت مع عدم التغيير
بالنسبة لأخطاء النظام
[Sun Jun 26 20:14:06 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml
[Sun Jun 26 20:14:06 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/favicon.ico
[Sun Jun 26 20:13:55 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml
[Sun Jun 26 20:13:55 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/favicon.ico
[Sun Jun 26 20:13:37 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml
[Sun Jun 26 20:13:37 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/favicon.ico
[Sun Jun 26 20:13:31 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml
[Sun Jun 26 20:13:31 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/favicon.ico
[Sun Jun 26 20:12:22 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml
[Sun Jun 26 20:12:22 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/favicon.ico
[Sun Jun 26 20:03:05 2011] [error] [client 82.137.200.51] File does not exist: /home/alaslyco/public_html/404.shtml

Re: مشكلة ما بعد التنصيب

Posted: Wed Jun 29, 2011 7:14 pm
by fares5shm

هل تواجهك هذه المشكلة بعد تنصيب جوملا فوراً؟ أم بعد أن تنصب قوالب أو إضافات ما؟

وهل تحدث معك المشكلة إن نصبت جوملا على السيرفر المحلي؟
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Thu Jun 30, 2011 10:06 am
by miran60
بعد تنصيب الجوملا مباشرة .... بدون ايه اضافات
و بصراحة لا اعلم كيفية التنصيب على السيرفر المحلي

Re: مشكلة ما بعد التنصيب

Posted: Thu Jun 30, 2011 12:48 pm
by fares5shm

أعتقد أنيه في هذه الحالة أن لديك بعض الملفات التي لم يتم رفعهل إلى نسخة جوملا، وبشكل خاص في مجلد الأدمن

لذا أرجو منك محاولة رفع الملفات الموجودة في ملف Administrator من نسخة جوملا الأساسية إلى السيرفر، وتتأكد من أن كافة الملفات موجودة (بالمقارنة مع حزمة جوملا التي على جهازك)، أو بطريقة أخرى، ارفع حزمة جوملا كاملة إلى السيرفر كملف مضغوط، ومن ثم فك الضغط عنها هناك عن طريق السي بانل

بالتوفيق
[/right]

Re: مشكلة ما بعد التنصيب

Posted: Thu Jun 30, 2011 5:02 pm
by miran60
اخي انا اصلاً رفعت الملجد مضغوط و من ثم قمت بفك الضغط عن طريق سي بانل
و جربت اصدارات عديدة من جوملا ... الغة الانكليزية و العربية و اصدارات 1.5 1.6
بصراحة كنت اعمل على جوملا ... وقمت بتصميم عدة مواقع و عدة ستايلات
و هذه أول مرة تحصل معي المشكلة
على حد علمي اعتقد ان المشكلة من الاستضافة ... الرجاء إعلامي بالمشكلة لكي اطرحها عليهم
و تقبل تحياتي اخي فارس

Re: مشكلة ما بعد التنصيب

Posted: Thu Jun 30, 2011 5:09 pm
by fares5shm

المشكلة يا أخي أن نتيجة الفحص الخاصة بالاستضافة جيدة، أو بالأصح مثالية!
وأنا في حيرة أمام هذه المشكلة..

هل لك أن تتأكد من أذونات الأدلة ضمن مساعدة >>> معلومات النظام؟

وهناك أداة صغيرة تساعدك على التأكد من ترميز الملفات والمجلدات بضغطة زر، وضعها الأخ meto
http://forum.joomla.org/viewtopic.php?p ... 0#p2269440

أرجو أن تحل هذه مشكلتك أخي
بانتظار ردك
[/right]