Registered user only menu item showing to the public.

Moderators: mandville, PhilD, General Support Moderators

Locked
Cremaster
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 12, 2013 9:59 am

Registered user only menu item showing to the public.

Post by Cremaster » Thu Aug 15, 2013 2:01 am

Hi,

Bit of a weird issue, possibly with a simple fix but one that is eluding me at the moment.

I have a menu item that I had showing only for registered users which for some reason is now showing to the public as well. While the most recent change to the site was the 2.5 upgrade I am not definite this was the cause.

I have tried deleting the menu item and recreating it from scratch but to no avail.

A search of this forum took me here;

http://forum.joomla.org/viewtopic.php?f=719&t=809277

But the problem seems to have a different cause.

I did do a debug to check out the access IN line as suggested by the post which reads "access IN (1,1,2,3,4)".

Am a little stumped as to where to go now.

Cheers,

Cre

Cremaster
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 12, 2013 9:59 am

Re: Registered user only menu item showing to the public.

Post by Cremaster » Fri Aug 16, 2013 3:36 am

Really strange.

Set both menu items to Special instead of Registered and now neither are showing to the Public as desired but only one shows up when I log in to the front end as an Administrator. Very random.

User avatar
ChasL
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Apr 30, 2013 5:40 am
Location: Oxford UK
Contact:

Re: Registered user only menu item showing to the public.

Post by ChasL » Fri Aug 16, 2013 11:22 am

Try rebuilding the menu after any edits, that fixes most things for me.

Cremaster
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 12, 2013 9:59 am

Re: Registered user only menu item showing to the public.

Post by Cremaster » Wed Aug 21, 2013 2:40 am

Thanks ChasL,

Went to do just that but the problem appears to have resolved itself. Had cleared the cache to no avail and tried numerous other tweeks but all of a sudden it seems to now work as expected. Would love to have a more definitive answer on what did the trick but the main thing is that it functions.

Homayra
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Dec 28, 2008 8:56 pm

Re: Registered user only menu item showing to the public.

Post by Homayra » Tue Apr 21, 2015 4:10 pm

Hi Dear,
I run into a problem,
I assigned registered to my menu item and it still shows to public.
I changed it to special it is still showing.
Can someone help please


Locked

Return to “Access Control List (ACL) in Joomla! 2.5”