Articles not showing up despite 'public' setting.

Moderators: mandville, PhilD, General Support Moderators

Locked
amruth92
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jan 16, 2016 2:34 am

Articles not showing up despite 'public' setting.

Post by amruth92 » Sat Jan 16, 2016 2:44 am

Hello! Apologies if I'm asking a very silly question. I have set the 'access' settings on all my menus and articles to 'public'. However, it appears that all articles can only be seen after logging in in the front end.

The 'guest user group' is also set to public, and all the language is set to "all".

The articles that have been created so far were written by superuser, and [if I'm getting the gist of this correctly], 'public' individuals do have viewing access for items written by 'special' individuals.

Is there anything I'm missing, and does anyone know how I could rectify this to make sure that posts show up without users having to log in?

Apologies, again, if this is a silly question :)

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 9811
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Articles not showing up despite 'public' setting.

Post by toivo » Sat Jan 16, 2016 10:11 am

Have you checked the viewing access level of the category those articles belong to?
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
troubleshooting smtp and other articles https://talikka.com/joomla

amruth92
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jan 16, 2016 2:34 am

Re: Articles not showing up despite 'public' setting.

Post by amruth92 » Sat Jan 16, 2016 11:28 am

toivo wrote:Have you checked the viewing access level of the category those articles belong to?
Morning, Toivo! Thanks for your response. Yup, checked that - all set to public, too.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24795
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Articles not showing up despite 'public' setting.

Post by Per Yngve Berg » Sat Jan 16, 2016 11:38 am

Is the Public User Group set to "Guest" in the Options in User Manager?

amruth92
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jan 16, 2016 2:34 am

Re: Articles not showing up despite 'public' setting.

Post by amruth92 » Sat Jan 16, 2016 11:52 am

Per Yngve Berg wrote:Is the Public User Group set to "Guest" in the Options in User Manager?
God Morgen, Per! Thanks for your response. Yes, the "Guest User Group" is set to public.


Locked

Return to “Access Control List (ACL) in Joomla! 2.5”