smf.discussbot_1.0.1. wie einbinden?

Moderator: Sisko1990

Forum rules
Forumregeln
Locked
Susi25
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Oct 11, 2005 6:54 pm

smf.discussbot_1.0.1. wie einbinden?

Post by Susi25 » Tue Oct 11, 2005 7:29 pm

Habe für meine Startseite Artikel verfasst.
Möchte jedoch keine Kommentare via AkoComments einbinden,
sondern Kommentare füs SMF - Forum.
Dazu habe ich smf.discussbot_1.0.1. installiert.
Leider weiss ich nicht weiter wie man es konfiguriert  ???
bin mit meinem Latain am Ende.

 
Exordium
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Sep 30, 2005 5:30 am
Contact:

Re: smf.discussbot_1.0.1. wie einbinden?

Post by Exordium » Sat Oct 15, 2005 10:17 pm

Das ist eigentlich ganz einfach:

Du suchst unter den Sitemambots den smf.discussbot aus und klickst ihn an um in die Konfiguration zu kommen.

Der 1. Parameter gibt an, wieviele Zeichen des Artikels im generierten Forenpost enthalten sein sollen. z.B. [1000]
Du kannst das Posting jederzeit überarbeiten und kürzen wenns zu lang sein sollte.

Der 2.te Parameter ist der Pfad zur Grafik, so ne Sprechblase, kannst so stehen lassen.

Der 3.te Parameter fragt ob Du Grafiken aus dem Artikel auch im Kommentarpost verlinken willst.

Der 4.te Parameter will wissen, ob beim Click auf den Kommentarlink an den Anfang oder das Ende im Kommentathread gesprungen werden soll. Ans Ende ist wohl sinnvoller.

Parameter 5 stellt dem Titel des Artikels auf Wunsch etwas vornedran z.B. [News] oder einfach leer lassen.

Bei Parameter 6 kann der Name eines Default-Forums eingetragen werden, in dem die Kommentare erzeugt werden. Das Forum *muss* schon im SMF vorhanden sein.

Parameter 7 ist für einen alternativen Text für den Link zum Kommentarthread z.b. [Kommentar(e)]

Wenn die Parameter nach Wunsch eingetragen hast, speichern.

Wenn Du jetzt einen neuen Artikel schreibst, für den Du einen Kommentar im Forum erzeugen möchtest, hast Du jetzt 2 Möglichkeiten:

Du gibst irgendwo im Artikel (am Besten ganz am Ende) entweder {mos_smf_discuss} ein. Dann wird der Kommentar im Defaultforum (siehe Parameter 6) angelegt. Oder du gibst ein {mos_smf_discuss:Forenname} um den Kommentar im Forum "Forenname" zu erzeugen. Das Forum muss im SMF schon angelegt sein!

Gruss
Exo
Last edited by Exordium on Sat Oct 15, 2005 10:20 pm, edited 1 time in total.
Lost Company a MMORPG Fansite - Powered by Joomla/SMF/JD-Wiki/Gallery 2

Susi25
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Oct 11, 2005 6:54 pm

Re: smf.discussbot_1.0.1. wie einbinden?

Post by Susi25 » Sat Oct 15, 2005 11:54 pm

Dankeschön erstmal.

Wenn ich den Kommentarlink anklicke komme ich zum Forum und da heisst es
"Sie haben nicht die Berechtigung neue Themen zu erstellen.
Bitte einloggen oder einen neuen Zugang registrieren."

Kann man die Kommentare auch zu einem Thread verlinken oder
geht das nur zum Board?

Ausserdem bleibt auf der Startseite die Anzahl der Kommentare immer auf 0.
Last edited by Susi25 on Sat Oct 15, 2005 11:57 pm, edited 1 time in total.

Exordium
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Sep 30, 2005 5:30 am
Contact:

Re: smf.discussbot_1.0.1. wie einbinden?

Post by Exordium » Sun Oct 16, 2005 8:26 am

Der Kommentarthread wird immer als neues Thema erzeugt. Am sinnvollsten erscheint mir, einfach ein Board exklusiv für die News- und Artikeldiskussionen bereitzustellen. In diesem Board sollten auch nur die Joomlaautoren das Recht haben neue Threads zu erstellen, der Rest darf aber auf diese Threads antworten. Wenn Deine Artikel natürlich von unterschiedlichen Themen handeln und Deine Forenstruktur daraufhin ausgelegt ist, funktioniert das natürlich nicht und Du musst eben immer das richtige Forum bei {mos_smf_discuss:Forum} eintragen.
Der Kommentarthread sollte auch immer gleich vom Artikelautor erzeugt werden, wenn er diesen wünscht!

Wenn nach dem Erzeugen des Threads im Forum noch (0)Kommentare angezeigt wird, dann hast Du in der globalen Joomlakonfiguration das Cachen von Inhalten aktiviert. In diesem Fall dauert es eine Weile, bis der Zähler aktualisiert wird. Wird der Zähler auch nach längerer Zeit nicht aktualisiert, dann ging leider etwas schief.

Gruss
Exo
Lost Company a MMORPG Fansite - Powered by Joomla/SMF/JD-Wiki/Gallery 2

Susi25
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Oct 11, 2005 6:54 pm

Re: smf.discussbot_1.0.1. wie einbinden?

Post by Susi25 » Mon Oct 17, 2005 8:26 am

Danke für die Hilfe. Irgendwas passt mit meinen Pfadangaben nicht.
Werde halt nen normalen Kommentarlink anbringen, dann sieht man halt die
Anzahl der Kommentare nicht, egal.

taucher
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Aug 24, 2005 5:25 am
Location: Austria
Contact:

Re: smf.discussbot_1.0.1. wie einbinden?

Post by taucher » Tue Nov 01, 2005 6:01 pm

muss dafür die smf-bridge installiert sein, oder funktioniert der bot auch ohne bridge?

Exordium
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Sep 30, 2005 5:30 am
Contact:

Re: smf.discussbot_1.0.1. wie einbinden?

Post by Exordium » Wed Nov 02, 2005 9:26 am

taucher wrote: muss dafür die smf-bridge installiert sein, oder funktioniert der bot auch ohne bridge?
Ich glaube ohne die bridge funktioniert das nicht. Zumindest muss man sich auf jeden Fall auch im Forum angemeldet haben, wenn man einen Diskussionsthread erzeugen will.

Einfach versuchen, der Bot ist ja schnell installiert.

Exo
Lost Company a MMORPG Fansite - Powered by Joomla/SMF/JD-Wiki/Gallery 2

 

Locked

Return to “Komponenten, Module, Mambots 1.0.x”