css, IE-BUG, Template

Moderator: Sisko1990

Forum rules
Forumregeln
Locked
febStaHR
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 01, 2006 7:03 am

css, IE-BUG, Template

Post by febStaHR » Fri Sep 01, 2006 8:30 am

Guten Tasch!  :D

Ich erstelle gerade eine neue Joomla Seite, mit einme eigenen Template.
http://www.logopaedielyss.ch/joomla/

Folgende Probleme habe ich atm:

1.
Der IE haut mir plötzlich riesen Zeilenabstände in der Subnavi rein (Firefox nicht)
--->
http://www.logopaedielyss.ch/joomla/

css:

Code: Select all

#subnavlist {
	width: 150px;
	float: left;
	font-size: 0.8em;
	/*background: #dcddde; */
}
#subnavlist ul {
	list-style-type: none;
}

#subnavlist li {
	list-style: none;
	margin-right: 0px;
	text-align: right;
	margin-bottom: 0;
	margin-top: 0;
}

#subnavlist li a {
	display: block;
	text-decoration: none;
	padding-right: 15px;
	padding-bottom: 5px;
	padding-top: 5px;
}

2. Problem:

Der IE kann keine Aufzählungszeichen anzeigen im Firefox klappt es:
-->
http://www.logopaedielyss.ch/joomla/kinder.html

hat jemand ne anung was das sein könnte?
Thx, cucu, merci, schöne Grüsse
Last edited by febStaHR on Fri Sep 01, 2006 11:09 am, edited 1 time in total.

User avatar
a.radtke
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 221
Joined: Thu Aug 18, 2005 8:01 am
Location: Germany Bonn
Contact:

Re: css, IE-BUG, Template

Post by a.radtke » Fri Sep 15, 2006 5:44 am

Hallo,
die Seite kann niht angezeigt werden, aber meine Glaskugel vermutet wegen der Zeilenabstände der IE Whitespace bug.
Mit einer border um die Li's oder einem height:-1 kann dieser behoben werden.


Gruss Angie
ausdrucks|Stark
Büro für Kommunikation Angie Radtke
http://www.der-auftritt.de
Blog: http://www.der-auftritt.de/wissen.html

febStaHR
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 01, 2006 7:03 am

Re: css, IE-BUG, Template

Post by febStaHR » Fri Sep 15, 2006 6:08 am

Guten Morgen

Huch, nicht dedacht dass hier noch jemand Antwortet, aber merci! Die Url ging ned mehr, weil ich die Seite live geschalten habe. (www.logopaedielyss.ch)
Die Probleme konnte ich in der zwischenzeit selber lösen...
1 Fehler draussen! Keine Zeilenabstände mehr im IE
er wollte eine breitenangabe im CSS

Code:

#subnavlist li a {
display: block;
text-decoration: none;
padding-right: 15px;
padding-bottom: 5px;
padding-top: 5px;
width: 135px;
}


-------------------------------------

edit 2

sodala, auch die Listenpunkte sind jetzt drin, habe mein CSS folgermassen ergänzt:

Code:

ul {
list-style-type:none;
}
.li {
padding-left: 12px;
padding-top: 0px;
background-image: url(../images/liste.png);
background-repeat: no-repeat;
background-position: 0px 6px;
}


Jetzt kann ich im Editor die Klasse einfach meinen Listne zuordnen und so klappt es!

OpenSef/ Joomla SEf deakt. Der erste Mainlevellink als "URL Weiterleitung" erstellt und das OpenSEF neu konf.
merci, und gruss


Locked

Return to “Template, CSS und Designfragen 1.0.x”