Problem komonenten Länkar

Moderators: chrille, Zello

Forum rules
Forumregler
Locked
magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sat Dec 08, 2007 4:36 pm

Problem komonenten Länkar

Post by magnusd » Sat Feb 22, 2014 3:23 pm

Hej
har ett problem jag haft i tidigare versioner men aldrig i 2.5
Efter flytt med Akeeba slutar länkarna och dess kategorier fungera. Får "Kategorin kan inte hittas".
eller "Kunde inte hitta länken"

Raderade alla länkar och kategorier. Kollade i PhpMyadmin. Både länkar och kategorier låg kvar. Raderade även i databasen. Skapade nya kategorier och länkar. Kollade att de skapats upp i databasen och det hade dem.

Men... "Länkar" fungerar fortfarande inte! :(

Tips?

Hälsningar
Magnus

User avatar
sgagner
Joomla! Ace
Joomla! Ace
Posts: 1224
Joined: Wed Sep 27, 2006 8:40 pm
Location: Norrköping, Sweden
Contact:

Re: Problem komonenten Länkar

Post by sgagner » Sat Mar 01, 2014 11:05 am

Hej,

Provar att stänga av SEF i Globala inställningarna om denna är påslagen. Rensa Joomlas cache och även din webbläsares cache. Testa sajten utan denna inställning och om det fungerar då, kan du slå på SEF igen.
Om du använder en SEF-komponent såsom sh404SEF eller liknande, kan du gå in i komponenten och rensa de cachade URL:erna och prova igen.

Kolla också att kategorierna i Länk-komponenten är aktiverade.
Stefan Gagner, Web8 Universal - http://www.mei-ya.se
Coordinator of Swedish Joomla Translator group.
We make the impossible while you wait. Wonders may take a little longer.

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sat Dec 08, 2007 4:36 pm

Re: Problem komonenten Länkar

Post by magnusd » Sat Mar 01, 2014 4:33 pm

Så då hörs vi i denna tråden... :-)
SEF är avstängt. Kategorierna är aktiverade. Kommit så långt att Joomla hittar underkategorin, men pekar jag menyobjektet på den översta kategorien hittas den inte. "Kunde inte hitta kategorin"
Pekar jag mot underkategorin fungerar det men länken fungerar inte. "Kunde inte hitta länken"
Fick tidigare ett tips att kolla "path" på kategorierna i databasen och dessa är felaktiga. Kommer ihåg någon gammal path. Ändrar, men det gör ingen skillnad.

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sat Dec 08, 2007 4:36 pm

Re: Problem komonenten Länkar

Post by magnusd » Sat Mar 01, 2014 5:33 pm

Jämfört lite i databasen mellan 1.5 och 2.5. I 1.5 finns inte "path" och det verkar som om det blir lite "blanda och ge" efter uppgradering med jupgrade.

User avatar
sgagner
Joomla! Ace
Joomla! Ace
Posts: 1224
Joined: Wed Sep 27, 2006 8:40 pm
Location: Norrköping, Sweden
Contact:

Re: Problem komonenten Länkar

Post by sgagner » Sun Mar 02, 2014 10:32 am

Hej,

Ja, jag har upptäckt att en rad problem kan uppstå när man använder jUpgrade.
jUpgrade Pro är lite bättre men jag använder hellre SPupgrade eller Migrate Me
Båda har sina finesser och problem men jag tycker de är klart bättre.
Stefan Gagner, Web8 Universal - http://www.mei-ya.se
Coordinator of Swedish Joomla Translator group.
We make the impossible while you wait. Wonders may take a little longer.

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sat Dec 08, 2007 4:36 pm

Re: Problem komonenten Länkar

Post by magnusd » Sun Mar 02, 2014 11:35 am

Tack för tipset. Ska kika på dessa nästa gång. Tror som sagt att problemet är "path" i databasen. Återkommer om/när jag får till det rätt.

Magnus

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sat Dec 08, 2007 4:36 pm

Re: Problem komonenten Länkar

Post by magnusd » Mon Mar 03, 2014 10:54 am

Nu verkar det som jag har fått iordning på kategorierna. Jösses vad Jupgrade hade stökat till!
Nu fungerar dock inte länkarna. Det blir konstiga sökvägar om man tittar på länkens egenskap.

http://domän.se/index.php/laenktest?task=weblink.go&id=1

http://domän2.se/jupgrade/index.php?option=com_weblinks&task=weblink.go&id=4&Itemid=144

EDIT: Den översta är riktig och fungerar. Den undre är från den site där det INTE fungerar.

User avatar
sgagner
Joomla! Ace
Joomla! Ace
Posts: 1224
Joined: Wed Sep 27, 2006 8:40 pm
Location: Norrköping, Sweden
Contact:

Re: Problem komonenten Länkar

Post by sgagner » Mon Mar 03, 2014 12:11 pm

Hej,

Den övre länken förefaller vara genererad av Joomla med SEF påslagen. Jag rekommenderar att slå av SEF i Globala inställningarna så länge man jobbar på sajten och ändrar i strukturen av artiklar/kategorier eller menyer.
Därefter kan man slå på SEF och även använda URL-omskrivning så att "index.php" försvinner ur sökvägen.
Stefan Gagner, Web8 Universal - http://www.mei-ya.se
Coordinator of Swedish Joomla Translator group.
We make the impossible while you wait. Wonders may take a little longer.


Locked

Return to “Allmänna frågor”