Problem med tabeller i artiklar

Locked
Pekka59
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat May 05, 2012 1:57 pm

Problem med tabeller i artiklar

Post by Pekka59 » Sat May 05, 2012 2:16 pm

Jag använder Joomla 2.5.4 och en komersiell mall Optimus från företaget Joomlashack. Problemet uppstår då jag kombinerar bilder och texter i en tabell. T.ex. om jag i en tabell med endast en rad och två kolumner sätter en bild i första cellen och text i andra cellen, så kommer texten alltid längs nere i den andra cellen oberoende av vilka inställningar man gör och har man flere rader text, så kommer texten t.o.m. under bildens nivå. Jag har skrivit till Joomlashack, men ännu inte fått något svar. Jag testade med att ändra mallen till Beez2 och då fungerar det perfekt. Är det någon annan som stött på detta problem med andra mallar. Irriterande att inte kunna använda tabeller då man vill placera text och bilder på en sida.

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: Problem med tabeller i artiklar

Post by EE Photo » Sat May 05, 2012 2:18 pm

Då låter det ju verkligen som det är ett problem med mallen. Eftersom du har betalt för mallen så antar jag att Joomlashack kommer att ge dig support och löser problemet.

Men varför använder du en tabell? Det går väll att placera bilder och text på samma sida utan en tabell.
Besök gärna min webbplats: http://www.fotoforalla.se/

Pekka59
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat May 05, 2012 1:57 pm

Re: Problem med tabeller i artiklar

Post by Pekka59 » Sun May 06, 2012 11:43 am

Hej!

Jag använder helst inte tabeller själv, men håller på med en ny webbplats för vår skola. En del av mina kolleger är inte så skickliga och då kan användningen av en tabell vara lättare för dem.

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: Problem med tabeller i artiklar

Post by EE Photo » Sun May 06, 2012 11:46 am

Ok jag tänkte bara att det är så otroligt mycket lättare att bara använda <p> taggar i artikel koden. Blir ju väldigt mycket mindre kod. Eller behöver du göra något som du inte kan göra med <p> taggar?
Besök gärna min webbplats: http://www.fotoforalla.se/

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Problem med tabeller i artiklar

Post by Zello » Sun May 06, 2012 11:58 am

Har du en länk till sidan?
Det är nog inte så svårt.
Troligen nåt skumt arv i CSS'en bara.
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

Pekka59
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat May 05, 2012 1:57 pm

Re: Problem med tabeller i artiklar

Post by Pekka59 » Sun May 06, 2012 1:37 pm

Jag kör Vmware Workstation och har den nya webbplatsen på en virtuell Ubuntu-server på min hemmadator. Jag var kontakt i med Joomlashack och har gott hopp om att få svar från dem imorgon. I nödfall så får jag hjälpa mina kolleger lite mera med text och bilder om vi inte hittar en lösning på tabellproblemet.

Pekka59
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat May 05, 2012 1:57 pm

Re: Problem med tabeller i artiklar

Post by Pekka59 » Sun May 06, 2012 2:38 pm

Tack för tipset! Tabellerna ärvde följande från CSS:en: vertical-align:baseline;
Jag ändrade baseline till top och nu fungerar det som det ska. Man behöver dessutom inte ändra i originalfilen utan Joomlashacks mall fungerar så att man skapar en egen css-fil som skall ha namnet custom.css.

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Problem med tabeller i artiklar

Post by Zello » Sun May 06, 2012 3:01 pm

Va bra att det löste sig!
"oförklarliga" designsaker brukar nästan alltid vara CSS på villovägar ;)
C'et står ju inte där bara för att det är snyggt :)
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

User avatar
JoomSverige
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sun Jul 10, 2011 4:48 pm
Contact:

Re: Problem med tabeller i artiklar

Post by JoomSverige » Sun May 06, 2012 5:24 pm

Att tänka på, när man använder ex editorn JCE och infogar en bild i en tabell så lägger JCE till inställning på hur bilden ska placeras, så om du sedan ändrar själva cellens egenskaper så hjälper det inte. Eg testa och klicka på infoga bild, där ser du en inställning för placering av bild.
http://www.joomlasverige.se
Ladda ner översättningar och läs om de senaste tilläggen till Joomla!
http://www.twitter.com/joomlasverige #joomlase


Locked

Return to “Användning och administration”