Långsam laddning

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
magobe
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Jan 16, 2013 6:42 pm
Location: Halmstad

Långsam laddning

Post by magobe » Wed Jan 16, 2013 6:51 pm

Hejsan
Min första post och den blev ganska lång men jag hoppas ni orkar läsa hela. Jag har tittat på Joomla under en längre tid men inte förrän nu byggt en hel sida. Vi har lagt ner en hel del arbete men nu när vi är på gång att publicera den får vi inte till det med laddningstiden. Från det att man skriver in adressen och trycker enter tar det någonstans mellan 5-30 sek innan sidan visas och under den tiden händer det ingenting, det står bara ”Väntar på”. När väl sidan väl laddas går det tillräckligt fort. Finns det någon som har några förslag på vad vi kan ändra på för att lösa det eller finns det verktyg som kan användas för att visa vad som händer i bakgrunden medan anslutningen väntar på något.

Vi har testat alla varianter på cache och GZIP Sidkomprimering (tror jag i alla fall). Det som vi tycker verkar fungera bäst är att ha cachen avstängd och sidkomprimeringen på (jag läste någonstans att man skulle ha antingen eller). Pluginet System - Cache är aktiverat och inställt på att använda webbläsarens cache.

Mallen har vi byggt själva och är väldigt enkelt utformad. Jag har testat att inaktivera de få tillägg vi har utan framgång. Samtidigt känns det som en återvändsgränd om vi måste börja att ta bort någon av de fåtal tillägg vi installerat för att få sidan att fungera. Tanken är ju att bygga på med mycket mer funktionalitet m.h.a. fler tillägg. Det som jag också är konstigt är att backend också är så segt, även där är det ”Väntar på” som gäller.

Sidan finns idag hos Loopia så kapaciteten på webbhotellet borde inte vara ett problem. Vi har testat att installera den även på andra ”hotell” men med samma resultat.

Google ger oss ett PageSpeed Score på 48 vilket ju inte är något man är så stolt över.

Som sagt, någon som har något förslag på vad vi kan göra för att bli av med denna fördröjning. All hjälp mottages mycket tacksamt.

Vill någon testa sidan finns den här:

http://nyweb.ifcentern.se

Tackar på förhand
Magnus

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Långsam laddning

Post by Zello » Wed Jan 16, 2013 6:59 pm

Hej och välkommen i det trevligaste forumet på nätet :)

Loopia är ju inte det optimala direkt för Joomlasidor eller andra liknande system som är "databasintensiva". Problemet är Loopias alltför långsamma databasservrar. Jag tänker inte rekommendera något annat hotell eftersom det endast resulterar i att tråden kommer att byta riktning och en massa mer eller mindre underbyggda fakta kommer att presenteras :). Men rent generellt så gäller nog regeln att man får vad man betalar för. Sen finns det naturligtvis undantag som det gör från alla regler.

Litet tips är att slå på Joomlas interna felsökning och se om ni kan se något i dessa listor. Då får ni bl.a. se alla databasanrop.

Skriv några fler inlägg så att er PM- kommer i gång (Tror det behövs 5 inlägg.)
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

magobe
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Jan 16, 2013 6:42 pm
Location: Halmstad

Re: Långsam laddning

Post by magobe » Thu Jan 17, 2013 9:49 am

Tack för snabbt svar. Jag får undersöka möjligheterna på Joomla och kanske ge mig ut på jakt efter att annat webbhotell (jag trodde Loopia var bra).

Jag slog på felsökningen och det var en väldans massa databasfrågor som ställdes. Intressant. Frågan är hur jag ska tolka all informationen. Ex detta

Application 0.003 seconds (+0.003); 0.61 MB (+0.610) - afterLoad
Application 1.947 seconds (+1.945); 3.93 MB (+3.319) - afterInitialise
Application 2.367 seconds (+0.419); 5.72 MB (+1.792) - afterRoute
Application 4.241 seconds (+1.874); 7.54 MB (+1.818) - afterDispatch
Application 4.345 seconds (+0.104); 7.72 MB (+0.178) - beforeRenderModule mod_articles_latest (Senaste nyheterna)
Application 6.585 seconds (+2.240); 8.32 MB (+0.600) - afterRenderModule mod_articles_latest (Senaste nyheterna)
Application 6.586 seconds (+0.001); 8.06 MB (-0.255) - beforeRenderModule mod_breadcrumbs (Sökväg)
Application 6.792 seconds (+0.207); 8.09 MB (+0.025) - afterRenderModule mod_breadcrumbs (Sökväg)
Application 6.793 seconds (+0.000); 8.08 MB (-0.005) - beforeRenderModule mod_menu (Meny)
Application 6.945 seconds (+0.153); 8.14 MB (+0.056) - afterRenderModule mod_menu (Meny)
Application 6.945 seconds (+0.000); 8.13 MB (-0.006) - beforeRenderModule mod_artwijmomenu (Art Wijmo Menu)
Application 7.331 seconds (+0.385); 8.39 MB (+0.257) - afterRenderModule mod_artwijmomenu (Art Wijmo Menu)
Application 7.339 seconds (+0.008); 8.29 MB (-0.104) - afterRender

Här har vi problemet, drygt 7 sek för att visa startsidan. Vad kan jag göra med det här?

När jag skulle logga in i Backend fick jag detta resultat

Application 0.242 seconds (+0.242); 0.70 MB (+0.704) - afterLoad
Application 3.679 seconds (+3.437); 4.04 MB (+3.339) - afterInitialise
Application 4.111 seconds (+0.431); 4.40 MB (+0.359) - afterRoute
Application 5.064 seconds (+0.953); 5.16 MB (+0.760) - beforeRenderModule mod_login (Login)
Application 8.180 seconds (+3.117); 5.83 MB (+0.665) - afterRenderModule mod_login (Login)
Application 8.229 seconds (+0.049); 5.80 MB (-0.032) - afterDispatch
Application 8.300 seconds (+0.071); 5.87 MB (+0.074) - afterRender

8 sek för att ladda sidan, det är väl inte ok?

User avatar
zpikesweden
Joomla! Explorer
Joomla! Explorer
Posts: 343
Joined: Mon Jan 22, 2007 1:23 pm
Location: Umeå
Contact:

Re: Långsam laddning

Post by zpikesweden » Mon Feb 04, 2013 8:44 pm

På Pingdom så laddar sidan på 1,43s "Your website is faster than 81% of all tested websites" vilket låter helt okej.

http://tools.pingdom.com/

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Långsam laddning

Post by Zello » Mon Feb 04, 2013 9:10 pm

Jag gjorde samma iakttagelse med Firebug. Ligger siten kvar på Loopia? I så fall har ni lyckats optimera den bra. Snyggt jobbat!
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

magobe
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Jan 16, 2013 6:42 pm
Location: Halmstad

Re: Långsam laddning

Post by magobe » Tue Feb 05, 2013 8:26 am

Jag kontaktade Loopia och fick till svar att "Den databasserver som din sida anropar har för närvarande långa svarstider på grund av hög belastning". Eftersom vi haft problemen hela tiden sedan vi la upp sidan i september blev jag lite småsur, de har uppenbarligen vetat om problemen men inte gjort något åt det. De erbjöd sig att flytta databasen vilket ledde, som ni sett, till en rejäl prestandaförbättring. Självklart vill vi att sidan ska laddas "blixtsnabbt" så helt nöjd är man ju inte än men det känns ok för tillfället.

Jobbet med utvecklingen av sidan har nu tagit fart igen när man inte längre behöver lägga all tid på laddningsproblemen och jag känner att jag börjar förstå allt bättre hur saker hänger ihop. Återkommer säkert med mer frågor framöver.

Länken tools.pingdom.com var väldigt bra. Den kommer att komma till användning framöver.

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Långsam laddning

Post by Zello » Tue Feb 05, 2013 8:53 am

Va bra att Loopia lyssnade på dig.
Blixtsnabb blir det nog aldrig ;)
Alla dynamiska sidor har en viss fördröjning p.g.a. just detta med databasen och processandet av informationen innan den skickas till besökaren.
Loopia ha en statisk server som du kan utnyttja för statiskt innehåll. Med lite pillande går det att vinna lite laddtid här.
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

magobe
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Jan 16, 2013 6:42 pm
Location: Halmstad

Re: Långsam laddning

Post by magobe » Thu Mar 21, 2013 10:25 pm

Vill bara informera om att efter Loopias uppgradering nu i veckan blev det en markant prestandaförbättring för vår sida så nu har jag inget att klaga på längre.

Evanion
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Jun 11, 2007 1:33 pm
Location: Stockholm, Sweden
Contact:

Re: Långsam laddning

Post by Evanion » Sun Apr 07, 2013 6:14 pm

Ja, deras nya servrar går inte av för hackor... jag är helt blå av avund på Loopia ;)


Locked

Return to “Användning och administration”