Page 1 of 1

Nya artiklar får avpublicera satt till 0000-00-00 00:00:00

Posted: Wed Aug 14, 2013 6:45 pm
by Tybalt
Hej!

När jag skapar nya artiklar får de automatiskt fältet avpublicera satt till 0000-00-00 00:00:00. Detta gör att när jag i ett senare skede editerar artikeln och väljer "avpublicera" så får artikeln status avpublicerad men försvinner inte från front-end utan visas fortfarande precis som om jag hade varit inloggad med publicisträttigheter. Artikeln har fortfarande avpublicera satt till 0000-00-00 00:00:00.

Ändrar jag fältet avpublicera till gårdagens datum så försvinner artikeln. Men borde inte valet "avpublicera" automatiskt sätta dagens datum och tid i fältet avpublicera?

Mvh Mikael

Re: Nya artiklar får avpublicera satt till 0000-00-00 00:00:

Posted: Thu Aug 15, 2013 7:40 am
by Zello
Väljer du status "Avpublicerad" ska artikeln försvinna från frontend. Om du fortfarande ser den måste det vara en cachad version du ser. Har du provat att tömma cachen?

"Men borde inte valet "avpublicera" automatiskt sätta dagens datum och tid i fältet avpublicera?"
Nej för då måste man ändra i dessa uppgifter när du ska publicera artikeln.
Ett vanligt arbetsflöde är att man skapar en ny artikel, sätter den till avpublicerad till den är klar och sedan publicerad den.

Re: Nya artiklar får avpublicera satt till 0000-00-00 00:00:

Posted: Thu Aug 15, 2013 9:04 am
by Tybalt
Tack för svaret! Då tror jag att jag har problem med min template som förmodligen inte hanterar/visar artiklarna i J2.5 rätt utan även visar opublicerade artiklar. (Jag använder inte cache men har tömt den i alla fall utan skillnad.)

Re: Nya artiklar får avpublicera satt till 0000-00-00 00:00:

Posted: Thu Aug 15, 2013 9:53 am
by Zello
Hur är det med cachen i webbläsaren? Det var den jag syftade på. Det brukar vara den som visar saker man inte borde se.