Security Announcements link not working, "Forgot password" not working

If you have any 'mechanical' forum or Joomla! sites related issues/suggestions with forum.joomla.org,
Post Reply
Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Security Announcements link not working, "Forgot password" not working

Post by Khue » Mon Jan 10, 2022 10:44 am

Hello,

I would like to report two issues:

1. On the Security Announcements page, the link for email notifications via FeedBurner is not working. (I unsubscribed from email notifications by accident and I would like to subscribe again, if you know a workaround please let me know.)

2. I used the "Forget my password" functionality yesterday but it didn't work (email never received). Fortunately today I remembered by password so I'm now be able to post this message. Please check as there might be an issue with email sending.

Thank you in advance.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40651
Joined: Sat Apr 05, 2008 9:58 pm

Re: Security Announcements link not working, "Forgot password" not working

Post by Webdongle » Mon Jan 10, 2022 12:02 pm

SU can not request password reminder. Depending on your Template you may not see a notice for that when you request for the password.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Mon Jan 10, 2022 12:20 pm

Webdongle wrote:
Mon Jan 10, 2022 12:02 pm
SU can not request password reminder. Depending on your Template you may not see a notice for that when you request for the password.
Thanks for your reply. Could you tell me what "SU" stands for?
To clarify, "Forgot your password" does not work on forum.joomla.org (i.e., this forum, not on my website). Sorry if my previous post was not clear.

Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Mon Jan 10, 2022 12:23 pm

@Webdongle: By the way, I didn't receive an email notification for your reply either, so I believe that there is an issue with email sending from forum.joomla.org.

Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Mon Jan 10, 2022 12:32 pm

Ok, emails from joomla.org went straight to my Spam folder:

Image

Not sure if this only happens to me...

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7381
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Security Announcements link not working, "Forgot password" not working

Post by AMurray » Mon Jan 10, 2022 10:10 pm

A sender such as "noreply@joomla.org" could be well construed as spam since it's an automated, unmonitored email address used to send the Forum's notifications.

You just need to add the email address to your "Friends" or "Whitelist" as an accepted sender in your email system or otherwise tell your email client (application, such as Outlook) it is "not spam".

Actually the screenshot you provided gives you the solution. Click the button that says "Report Not Spam". That would do the same as the other solutions above.
Regards - A Murray

Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Mon Jan 10, 2022 11:01 pm

AMurray wrote:
Mon Jan 10, 2022 10:10 pm
A sender such as "noreply@joomla.org" could be well construed as spam since it's an automated, unmonitored email address used to send the Forum's notifications.

You just need to add the email address to your "Friends" or "Whitelist" as an accepted sender in your email system or otherwise tell your email client (application, such as Outlook) it is "not spam".

Actually the screenshot you provided gives you the solution. Click the button that says "Report Not Spam". That would do the same as the other solutions above.
Thanks. That's what I had already done, but that's not the point of my post. To clarify, I was not asking for help on the email issue, but only wanted to report it to the admins (maybe they missed one of SPF, DKIM, or DMARC, who knows? As a web admin I don't ask my users to add my website's email address to their "Friends" or "Whitelist", at least not before double checking my email setup).

I'm going to GitHub to report these issues, maybe they'll get more attention there from the admins.
Last edited by Khue on Tue Jan 11, 2022 12:25 am, edited 1 time in total.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40651
Joined: Sat Apr 05, 2008 9:58 pm

Re: Security Announcements link not working, "Forgot password" not working

Post by Webdongle » Mon Jan 10, 2022 11:35 pm

A link to your github post would be helpful
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Tue Jan 11, 2022 11:15 am

Here it is: https://github.com/joomla/joomla-websites/issues/1706

I tried registering with another Gmail address and I received the activation email, so I didn't report the email issue.


Khue
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Jun 10, 2011 7:09 am

Re: Security Announcements link not working, "Forgot password" not working

Post by Khue » Tue Jan 11, 2022 2:57 pm

Indeed, the issue I'm reporting is related to one of the Joomla!'s websites and not related to the Joomla! software, so I think I used the right repo.


Post Reply

Return to “Sites & Infrastructure - Feedback/Information”