Topic reply email links broken

If you have any 'mechanical' forum or Joomla! sites related issues/suggestions with joomla.org, community.joomla.org, forum.joomla.org, vel.joomla.org.
Forum rules
READ ME <-- please read before posting, this means YOU.
Locked
User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Topic reply email links broken

Post by kenmcd » Fri Aug 19, 2005 8:06 am

Some of the links I have been receiving in email notifications are broken.

Example:
http://forum.opensourcematters.org/inde ... icseen#new
██ LibreTraining

[Unknown]
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Aug 18, 2005 1:23 am

Re: Topic reply email links broken

Post by [Unknown] » Fri Aug 19, 2005 8:48 am

What mail client are you using?

-[Unknown]

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: Topic reply email links broken

Post by kenmcd » Fri Aug 19, 2005 9:17 am

Eudora 6.2.1.2
██ LibreTraining

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Full email example

Post by kenmcd » Fri Aug 19, 2005 9:21 am

Code: Select all

X-Originating-IP: [207.210.68.122] 
To: kenmcd@xxxxxx.xxxt 
Subject: Topic reply: vBridge released 
From: "OpenSourceMatters" <admin@opensourcematters.org> 
Date: Fri, 19 Aug 2005 08:20:11 +0000 
X-Mailer: SMF 
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report 
X-AntiAbuse: Primary Hostname - rome.directrouter.com 
X-AntiAbuse: Original Domain - comcast.net 
X-AntiAbuse: Originator/Caller UID/GID - [99 502] / [47 12] 
X-AntiAbuse: Sender Address Domain - rome.directrouter.com 
X-Source: 
X-Source-Args: /usr/local/apache/bin/httpd -DSSL 
X-Source-Dir: opensourcematters.org:/public_html/forum 


A reply has been posted to a topic you are watching by timk99.


View the reply at: http://forum.opensourcematters.org/index.php=3Ftopic=3D194.new;topicseen#new


Unsubscribe to this topic by clicking here: http://forum.opensourcematters.org/index.php=3Faction=3Dnotify;topic=3D194.0


The text of the reply is shown below:


It has become really confusing where we are supposed to submit problems with vBridge - here or wh-solutions. Please make this clear.


I have installed vBridge with latest Mambo and vBulletin 3.0.8. Everything seemed to install fine.


However, when I login from vBulletin, it logs me in to mambo but not vbulletin. Also after logging in from vBulletin it returns me to my mambo home page and the forum disappears.


Also, logout fails in mambo, saying I am logged in to a private area of the site.


I can also no longer log in to my mambo administrator area. I bought vBulletin because vBridge was available - =A382. And instead I have a completely broken website. This isn't even Beta software let alone a release candidate.


What is the problem =3F


More replies may be posted, but you won't receive any more notifications until you read the topic.


Regards,
The OpenSourceMatters Team. 
██ LibreTraining

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: Topic reply email links broken

Post by kenmcd » Fri Aug 19, 2005 11:25 am

Another one

http://forum.opensourcematters.org/inde ... icseen#new


Went and found where it should go:

http://forum.opensourcematters.org/inde ... ml#msg3248

Looks like "/" gets replaced with "=3F"
And "," gets replaced with "=3D"

So top link should be:
http://forum.opensourcematters.org/inde ... icseen#new

That seems to get to the correct thread.

Perhaps something going on with the SEF?
Last edited by kenmcd on Fri Aug 19, 2005 11:33 am, edited 1 time in total.
██ LibreTraining

[Unknown]
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Aug 18, 2005 1:23 am

Re: Topic reply email links broken

Post by [Unknown] » Fri Aug 19, 2005 5:16 pm

Your client or this server seems to be dropping the very important:

Content-Transfer-Encoding: quoted-printable

Being sent along with that message.  Quoted printable is used for any message which contains unicode characters, and in it things like = and ? are escaped.  Surely you've seen the =20's in mail messages at the end of lines, for example.

Specifically, it's the £ that caused SMF to send in quoted printable.  Still, Eudora should support it fine, which leads me to the server - which, if qmail, has a problem the next beta release has a work around for.

-[Unknown]


Locked

Return to “Sites & Infrastructure - Feedback/Information”