tag list menu item delivers blank page in Joomla 3.4.4

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Locked
whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 4:34 pm

After updating my site to Joomla 3.4.4 any menu item that is of type "tagged items" or "Compact lis of tagged items" delivers a blank page. However, this is not that case with Joomla 3.4.3.

I have built an entire website off of the tags component, and it broke immediately after upgrading to the most recent Joomla 3.4.4. So I tested it on my own site, which I use for testing and I can break the site in the same way. When I roll back to Joomla 3.4.3, everything works fine.

It does not matter what template I use.

Unfortunately, Joomla was automatically updated on my server via and I can't roll back my client site to the Joomla 3.4.3 version, making this a matter of great urgency.

I am working on resolving the issue now, but if anyone has any ideas on how to fix this and stay in Joomla 3.4.4, I'd welcome input. You can view the broken tag page on one of the following two links.

http://designwritestudios.com/tag
http://lutheranarts.org/2d-artists

 
User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38461
Joined: Sat Apr 05, 2008 9:58 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by Webdongle » Mon Sep 28, 2015 4:50 pm

Did you install using the Joomla full package or a quickstart package ?

Also try with Protostar as default
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 4:57 pm

The site was originally installed via C-panel at version 3.2 and I have been updating it regularly since then via the Joomla Update component in the Joomla admin panel.

Indeed I have tested it with Protostar, and the page remains blank white. I have tested with multiple templates. I have removed all template overrides. The only thing that fixes it is rolling back to version 3.4.3.

The only other thing that fixes it is to unpublish articles with the specified tag. The I get the page that says "no matching items were found."

Thoughts?

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8808
Joined: Sat Oct 01, 2011 7:06 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by sovainfo » Mon Sep 28, 2015 5:08 pm

EDIT:
Verified both urls for HTML sent to the browser. No code shown.

Start with error_reporting set to 'maximum'. Any errors?

Enable DEBUG on both, do you see differences in queries used?
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 5:37 pm

Thank you for your replies. I appreciate it very much.

I am working with my own site http://designwritestudios.com

No errors show on the http://designwritestudios.com/tag page. Just a blank page.

I turned on Debug, but don't exactly know what I'm looking for?? I left it on if you can take a look.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38461
Joined: Sat Apr 05, 2008 9:58 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by Webdongle » Mon Sep 28, 2015 5:51 pm

whitecrane wrote:The site was originally installed via C-panel ...
That could be the cause of the problem. A lot of unofficial Joomla installs are modified and can cause problems when Joomla is updated. Another is a javascript conflict ... the blank page would indicate a js conflict.

http://forum.joomla.org/viewtopic.php?f=621&t=582860 please
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8808
Joined: Sat Oct 01, 2011 7:06 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by sovainfo » Mon Sep 28, 2015 6:10 pm

Suspect something wrong with the files in your environment.
Suggest to replace your files with those from the distribution. You may need to download the distribution first. When using the full package omit the installation folder.

Looked at the DEBUG info. Apart from the obviuos problem with the language file, can't see anything because the /tag doesn't produce anything.

Maybe you can find something in /logs or the php/webserver logs.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 6:39 pm

Site was installed via c-panel at Siteground using Softaculous in December of 2013. All upgrades and updates since that time have been done via Joomla admin area, not c-panel.

Reverting my site back to version 3.4.3 fixes the problem. So it would seem the problem lies between version 3.4.3 and 3.4.4 on the tags component. Everything else works fine.

I'll run the post assistant and see what I can see.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38461
Joined: Sat Apr 05, 2008 9:58 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by Webdongle » Mon Sep 28, 2015 7:14 pm

whitecrane wrote:...
Reverting my site back to version 3.4.3 fixes the problem. So it would seem the problem lies between version 3.4.3 and 3.4.4 on the tags component. ....
Nope ... have tested update from 3.4.3 to 3.4.4 in various environments.

Just because you have updated via the Joomla! update component does not negate the fact that there could have been something wrong with initial install that manifests with the 3.4.4 update. But in this case it looks more like a javascript conflict.

Make sure your extensions are upto date
and please http://forum.joomla.org/viewtopic.php?f=621&t=582860
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 9:09 pm

I followed your lead on the javascript issue and began testing plugins, articles etc. On my first site, found a conflict with an old RokInjection plugin which was left on the site, but not in use. Uninstalling that fixed the issue.

On the second site, I discovered that the plugin "All Videos" was to blame. Pages that had the All Video snippet would themselves load, but would cause the white screen when included in a tagged items list via the menu.

If I unpublished the article, the list would work. If I published the article but took out the All Videos snippet, the list would work.

On my site, I have 14 articles with the "All Videos" snippet being used, and they cross multiple tags, so it appeared as though all tags were affected, making me think it was the tags component.

So my installations are fine, the tags component appears to be working fine, I just need to figure out how to embed the videos on these articles. Perhaps a different plugin.

Thank you for tipping me off to the Javascript issue. I appreciate it.

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Mon Sep 28, 2015 9:38 pm

If anyone needs assistance with the same issue, I have found the following post on the "All Videos" forum here.

http://www.joomlaworks.net/forum/allvid ... mitstart=0

It involves replacing a few lines of code in the plugin file. It is now working for me.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38461
Joined: Sat Apr 05, 2008 9:58 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by Webdongle » Mon Sep 28, 2015 10:33 pm

So it was an error caused by the allvideos plugin ... they've patched but not released a new version yet ? That code 'JParameter' was depreciated in 2.5 https://docs.joomla.org/J2.5:What's_new_in_Joomla_2.5 https://docs.joomla.org/J2.5:What's_new ... d_Features
The platform removed a larger number of deprecated classes and methods
https://docs.joomla.org/Potential_backw ... tform_12.2
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by whitecrane » Tue Sep 29, 2015 2:00 am

Hmm. Yes, I see what you're saying. Perhaps I should be using a different plugin, or pursue All Videos for a better version…

I need my editors to embed [youtube] and Vimeo into their pages in as few steps as possible. I welcome your ideas.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38461
Joined: Sat Apr 05, 2008 9:58 pm

Re: tag list menu item delivers blank page in Joomla 3.4.4

Post by Webdongle » Tue Sep 29, 2015 10:14 am

In fairness it is a free extension that works well as a whole.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

 

Locked

Return to “General Questions/New to Joomla! 3.x”