Admin panel - weird login error

General questions relating to Joomla! 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
User avatar
BobbyDigi_1030
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Wed Jul 17, 2013 4:10 pm
Location: Akron, Ohio

Admin panel - weird login error

Postby BobbyDigi_1030 » Thu Jun 15, 2017 5:45 pm

I'm trying to log into my website this morning and I received the following below: (see snapshot below)

An error has occurred.

0 syntax error, unexpected '}'


The site was upgraded to 3.7.2 shortly after its release. The website is live and online and does not appear to be affected by this error. I was logged into the backend a few nights ago to make some article updates. I have not updated any modules or plugins from when the last time I was able to log in and this morning when I encountered this error.

I am at a complete loss from this and have no idea where to even begin to look to start investigating. Can anyone assist?
Last edited by mandville on Fri Jun 16, 2017 8:42 pm, edited 2 times in total.
Reason: removed url hint for security reasons
Mos Eisley...You'll never find a more wretched hive of scum and villainy. We must be cautious...

User avatar
websitedons
I've been banned!
Posts: 393
Joined: Sat May 27, 2017 9:42 am

Re: Admin panel - weird login error

Postby websitedons » Thu Jun 15, 2017 8:25 pm

1. Check your file manager at the hosting control to see the date for last change for files in the administrator directory. That will give an idea if there was an assault.

2.
Go to the database manager
Open the related database
Click table _template_styles
Edit the row for admin template 'hathor' and set column 'home' to 1
Edit the row for admin template 'isis' and set column 'home' to 0
db-template-change.jpg

Try to login
You do not have the required permissions to view the files attached to this post.


User avatar
BobbyDigi_1030
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Wed Jul 17, 2013 4:10 pm
Location: Akron, Ohio

Re: Admin panel - weird login error

Postby BobbyDigi_1030 » Fri Jun 16, 2017 6:28 pm

websitedons wrote:1. Check your file manager at the hosting control to see the date for last change for files in the administrator directory. That will give an idea if there was an assault.

2.
Go to the database manager
Open the related database
Click table _template_styles
Edit the row for admin template 'hathor' and set column 'home' to 1
Edit the row for admin template 'isis' and set column 'home' to 0
db-template-change.jpg
Try to login


The last activity from my Admin directory was the end of May. This issue started approximately 2-3 days ago. Also, swapped the templates and still got the same error...
Mos Eisley...You'll never find a more wretched hive of scum and villainy. We must be cautious...

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3421
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Admin panel - weird login error

Postby sozzled » Fri Jun 16, 2017 7:08 pm

The error reported in the OP indicates that a part of one of the PHP commands used by the website is improperly syntaxed (or parsed) on the server. If everything has been working well until a few days ago and if there have been no changes made (i.e. no file modifications) then either there has been a database change or the website has otherwise been compromised.

There may be grounds to suspect that the website has been hacked or exploited by a vulnerability from an earlier version of Joomla or from a third-party extension installed by the OP. Although there's no definite means that we who use this forum can explain why the syntax error—the unmatched end-of-block character, i.e. "}"—has occured in this case, we may be able to offer more useful suggestions if the OP provides information generated by the Forum Post Assistant; without that information, it's a bit like asking us to tell you which way the train went just by looking at the tracks (I'm sorry to say).
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
BobbyDigi_1030
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Wed Jul 17, 2013 4:10 pm
Location: Akron, Ohio

Re: Admin panel - weird login error

Postby BobbyDigi_1030 » Fri Jun 16, 2017 7:13 pm

BobbyDigi_1030 wrote:
websitedons wrote:1. Check your file manager at the hosting control to see the date for last change for files in the administrator directory. That will give an idea if there was an assault.

2.
Go to the database manager
Open the related database
Click table _template_styles
Edit the row for admin template 'hathor' and set column 'home' to 1
Edit the row for admin template 'isis' and set column 'home' to 0
db-template-change.jpg
Try to login


The last activity from my Admin directory was the end of May. This issue started approximately 2-3 days ago. Also, swapped the templates and still got the same error...


Got Debugging turned on - see attachment. I'm not seeing anything out of the ordinary. The files appear fine, based of this output. The login.php file was matched from a fresh download of the same file and they are exactly the same.

Any other ideas I should try or places to investigate?
Last edited by mandville on Fri Jun 16, 2017 8:43 pm, edited 2 times in total.
Reason: removed url hint for security reasons
Mos Eisley...You'll never find a more wretched hive of scum and villainy. We must be cautious...

User avatar
websitedons
I've been banned!
Posts: 393
Joined: Sat May 27, 2017 9:42 am

Re: Admin panel - weird login error

Postby websitedons » Fri Jun 16, 2017 8:02 pm

BobbyDigi_1030 wrote:Any other ideas I should try or places to investigate?

It seems very likely that your system may have been compromised, and a method to auto login was attempted. When I go to your /administrator area, it seemingly immediately logs in, and shows the error. Try that forum post assistant application that's shown at the top of the thread, to get some internal system data.

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3421
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Admin panel - weird login error

Postby sozzled » Fri Jun 16, 2017 8:19 pm

websitedons wrote:When I go to your /administrator area, it seemingly immediately logs in, and shows the error.
What appears to be happening is that the /administrator/index.php contains a badly-formed piece of PHP script that's responsible for displaying the login screen, in the first place, rather than the login being "auto-activated" in any sense.

I suspect that the fault is not with "login", per se. The error occurs before the user has the means to enter the account credentials, i.e. before the login occurs; not after the login has taken place. I guess the key to understanding the problem lies with the OP's opening statement: "I'm trying to login ..." (and not after login) when the error occurs.

This may even explain why the administrator site fails regardless of using Hathor or Isis. The fault occurs before the backend has the opportunity of querying the database before deciding whether to load the backend template and, after that, the login form that's associated with the loaded template.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33172
Joined: Sat Apr 05, 2008 9:58 pm

Re: Admin panel - weird login error

Postby Webdongle » Fri Jun 16, 2017 8:56 pm

websitedons wrote:.... When I go to your /administrator area, it seemingly immediately logs in, and shows the error. ...
Cant see the url ?

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3421
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Admin panel - weird login error

Postby sozzled » Fri Jun 16, 2017 9:14 pm

@Webdongle: see my PM to you.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
BobbyDigi_1030
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Wed Jul 17, 2013 4:10 pm
Location: Akron, Ohio

Re: Admin panel - weird login error

Postby BobbyDigi_1030 » Mon Jun 19, 2017 6:03 pm

Thanks for the assistance all. Once my management gets in tomorrow, I'll explain to them about this Forum Post Assistant and try to get that uploaded as soon as possible. Hopefully that will reveal more details on what/why this is happening.
Mos Eisley...You'll never find a more wretched hive of scum and villainy. We must be cautious...

User avatar
BobbyDigi_1030
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Wed Jul 17, 2013 4:10 pm
Location: Akron, Ohio

Re: Admin panel - weird login error

Postby BobbyDigi_1030 » Tue Jun 20, 2017 1:28 pm

In reading the instructions, php7 is not listed under the compatibility section. Does this work with php7? Please confirm and thanks!
Mos Eisley...You'll never find a more wretched hive of scum and villainy. We must be cautious...

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33172
Joined: Sat Apr 05, 2008 9:58 pm

Re: Admin panel - weird login error

Postby Webdongle » Tue Jun 20, 2017 11:13 pm

Try it and see


Return to “General Questions/New to Joomla! 3.x”

Who is online

Users browsing this forum: slbutrew, tetosan and 20 guests