User - Profile plugin not showing "required" fields

General questions relating to Joomla! 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
bramsan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Oct 28, 2010 8:14 pm

User - Profile plugin not showing "required" fields

Post by bramsan » Wed May 16, 2018 5:04 pm

We have the registration set-up to require "Regions", but, it is showing up as Optional. Any ideas on how to get it to work properly?

Also, no one in the USA knows what regions means, so we tried to change it in Language Overrides and it's not there.

Shouldn't this be a simple thing in Joomla?

Help?

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1629
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: User - Profile plugin not showing "required" fields

Post by fcoulter » Wed May 16, 2018 6:32 pm

In the user profile plugin there are options to set any of the profile fields to required.

As for the override, it is a quirk of Joomla that plugin language files are stored in the administrator folder. So when you create an override for a plugin language constant you need to set the filter to 'administrator'. I think that the language constant you are looking for is 'PLG_USER_PROFILE_FIELD_REGION_LABEL'. When you create the override, make sure that the 'For Both Locations' box is checked so that the override will be available for the front end of the site.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator :: VEL team member
"Wearing my tin foil hat with pride"

bramsan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Oct 28, 2010 8:14 pm

Re: User - Profile plugin not showing "required" fields

Post by bramsan » Wed May 16, 2018 6:38 pm

Thanks for the prompt reply, I will check the administrator language area.

RE: required fields... we do have Region set to "required" but it shows up as "optional" on the front end.

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1629
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: User - Profile plugin not showing "required" fields

Post by fcoulter » Wed May 16, 2018 6:50 pm

There are two sets of settings for the user profile fields:-

User profile fields for registration and administrator user forms
User profile fields for profile edit form

Make sure that you have set it to required for both sets of settings in the profile plugin.

If that is not the explanation I don't know what the issue is, because I am not having a problem setting it to 'required'. In that case it might be an issue with your template, try switching to the Protostar template and see if it works then.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator :: VEL team member
"Wearing my tin foil hat with pride"

bramsan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Oct 28, 2010 8:14 pm

Re: User - Profile plugin not showing "required" fields

Post by bramsan » Wed May 16, 2018 6:56 pm

Thanks for your help, nothing is working. Wish I could find a way to code it with CSS or something.

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1629
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: User - Profile plugin not showing "required" fields

Post by fcoulter » Thu May 17, 2018 11:26 am

Thanks for your help, nothing is working. Wish I could find a way to code it with CSS or something.
That is how the Joomla form validator works. Any input field that is required has a CSS class of 'required'.

Then the Joomla form validator is the script media/system/js/validate.js, it checks any input field with a class of 'required' and returns an error for that field if it does not have a value, it is quite a simple system, and it works.

If it is not working for you then one of these things might be going on:-
  • the validator script is not being loaded
  • it is being loaded, but another script on the page is causing javascript errors that cause scripting to fail on the page
  • the form fields are not being rendered correctly with the class of 'required', maybe by a faulty template
  • you are not using the Joomla registration form at all in which case all of this is irrelevant
Which if any of these is true I have no idea, because I am not omniscient.

If you actually want to fix this, you might try providing more information, eg the address of your site, and what measures (if any) you have already taken to check what is going. You might try showing some initiative and test out some of the suggestions that I have provided.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator :: VEL team member
"Wearing my tin foil hat with pride"

bramsan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Oct 28, 2010 8:14 pm

Re: User - Profile plugin not showing "required" fields

Post by bramsan » Thu May 17, 2018 3:10 pm

I really appreciate the help, and, the assumption that I haven't tried the suggestions you already offered is incorrect. I have spent time following ALL of your suggestions. Sorry this has been so frustrating for you.

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1629
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: User - Profile plugin not showing "required" fields

Post by fcoulter » Thu May 17, 2018 9:05 pm

OK, no problem, it just gets a bit frustrating when the feedback is no more than "nothing is working". Is there any reason why you cannot give the address of the registration form? I think that the only way to add anything more meaningful is to actually see the issue in action. Otherwise I have nothing more to suggest at the moment.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator :: VEL team member
"Wearing my tin foil hat with pride"


Post Reply

Return to “General Questions/New to Joomla! 3.x”