Cannot Update to PHP 7.2 - Getting Error Session Start Failed

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Tue Jun 02, 2020 9:05 pm

Hello All,

I have been trying to update my PHP Version from 7.1 to 7.2 but I keep getting this error message:

Warning: session_start(): Failed to read session data: user (path: /tmp) in /xxx/xxx/public_html/xxx.com/libraries/joomla/session/handler/native.php on line 260 Error: Failed to start application: Failed to start the session

I am current on Joomla version and all extensions (I believe). I have removed most of any third party extensions I was using.

I used the FPA. Hope I did it right?

Your help is much appreciated.

Thanks.

Update: After looking at the FPA results I have noticed some 3rd party extensions I didn't realize I still had. I've uninstalled most. Not sure if some of those were a problem but just wanted to let whomever is looking at this know.
Last PHP Error(s) Reported :: wrote: in Unknown on line 0
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.19-Stable (Amani) 2-June-2020
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 60 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 120 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.19: Yes | Database Supports J! 3.9.19: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.14.146-225.ELK.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | System TMP Writable: Yes | Free Disk Space : 232.91 GiB |

PHP Configuration :: Version: 7.1.14 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 02nd June 2020 15:51:18. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Version: 5.6.41-84.1 (Client:5.6.41-84.1) | Database Size: 11.24 MiB | #of Tables with config prefix: 97 | #of other Tables: 0
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.14) | date (7.1.14) | libxml (7.1.14) | openssl (7.1.14) | pcre (7.1.14) | sqlite3 (7.1.14) | zlib (7.1.14) | bcmath (7.1.14) | bz2 (7.1.14) | calendar (7.1.14) | ctype (7.1.14) | curl (7.1.14) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.14) | ftp (7.1.14) | gd (7.1.14) | gettext (7.1.14) | gmp (7.1.14) | SPL (7.1.14) | iconv (7.1.14) | session (7.1.14) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.14) | mcrypt (7.1.14) | mysqli (7.1.14) | odbc (7.1.14) | standard (7.1.14) | PDO (7.1.14) | pdo_mysql (7.1.14) | pdo_sqlite (7.1.14) | Phar (2.0.2) | posix (7.1.14) | pspell (7.1.14) | Reflection (7.1.14) | imap (7.1.14) | SimpleXML (7.1.14) | soap (7.1.14) | sockets (7.1.14) | exif (7.1.14) | tidy (7.1.14) | tokenizer (7.1.14) | wddx (7.1.14) | xml (7.1.14) | xmlreader (7.1.14) | xmlrpc (7.1.14) | xmlwriter (7.1.14) | xsl (7.1.14) | zip (1.13.5) | cgi-fcgi () | ionCube Loader () | Zend Engine (3.1.0) |
Potential Missing Extensions ::
Disabled Functions :: dl |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 100816 | Threads: 13 | Questions: 170260826 | Slow queries: 51 | Opens: 594250 | Flush tables: 1 | Open tables: 16800 | Queries per second avg: 1688.827 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) 1 | com_mailto (3.0.0) 1 |
3rd Party:: WF_FONTSELECT_TITLE (2.8.12) ? | WF_LINK_TITLE (2.8.12) ? | WF_FONTSIZESELECT_TITLE (2.8.12) ? | WF_SPELLCHECKER_TITLE (2.8.12) ? | WF_STYLESELECT_TITLE (2.8.12) ? | WF_PREVIEW_TITLE (2.8.12) ? | WF_SOURCE_TITLE (2.8.12) ? | WF_FORMATSELECT_TITLE (2.8.12) ? | WF_TABLE_TITLE (2.8.12) ? | WF_CONTEXTMENU_TITLE (2.8.12) ? | WF_REFERENCE_TITLE (2.8.12) ? | WF_VISUALCHARS_TITLE (2.8.12) ? | WF_IMGMANAGER_TITLE (2.8.12) ? | WF_ANCHOR_TITLE (2.8.12) ? | WF_SEARCHREPLACE_TITLE (2.8.12) ? | WF_BROWSER_TITLE (2.8.12) ? | WF_CLEANUP_TITLE (2.8.12) ? | WF_XHTMLXTRAS_TITLE (2.8.12) ? | WF_DIRECTIONALITY_TITLE (2.8.12) ? | WF_HELP_TITLE (2.8.12) ? | WF_VISUALBLOCKS_TITLE (2.8.12) ? | WF_HR_TITLE (2.8.12) ? | WF_WORDCOUNT_TITLE (2.8.12) ? | WF_TEXTCASE_TITLE (2.8.12) ? | WF_FULLSCREEN_TITLE (2.8.12) ? | WF_ATTRIBUTES_TITLE (2.8.12) ? | WF_NONBREAKING_TITLE (2.8.12) ? | WF_AUTOSAVE_TITLE (2.8.12) ? | WF_MEDIA_TITLE (2.8.12) ? | WF_KITCHENSINK_TITLE (2.8.12) ? | WF_EMOTIONS_TITLE (2.8.12) ? | WF_LAYER_TITLE (2.8.2) ? | WF_ARTICLE_TITLE (2.8.12) ? | JCE - Noneditable (1.0.0) ? | WF_CHARMAP_TITLE (2.8.12) ? | WF_FONTCOLOR_TITLE (2.8.12) ? | WF_CLIPBOARD_TITLE (2.8.12) ? | WF_LISTS_TITLE (2.8.12) ? | WF_STYLE_TITLE (2.8.12) ? | WF_PRINT_TITLE (2.8.12) ? | WF_LINKS_JOOMLALINKS_TITLE (2.8.12) ? | WF_AGGREGATOR_[youtube]_TITLE (2.8.12) ? | WF_AGGREGATOR_DAILYMOTION_TITLE (2.8.12) ? | WF_AGGREGATOR_VIDEO_TITLE (2.8.12) ? | WF_AGGREGATOR_VIMEO_TITLE (2.8.12) ? | WF_AGGREGATOR_AUDIO_TITLE (2.8.12) ? | WF_POPUPS_JCEMEDIABOX_TITLE (2.8.12) ? | WF_FILESYSTEM_JOOMLA_TITLE (2.8.12) ? | WF_LINK_SEARCH_TITLE (2.8.12) ? |

Components :: ADMIN ::
Core :: com_fields (3.7.0) 1 | com_login (3.0.0) 1 | com_categories (3.0.0) 1 | com_plugins (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_cache (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_contenthistory (3.2.0) 1 | com_associations (3.7.0) 1 | com_tags (3.1.0) 1 | com_search (3.0.0) 1 | com_menus (3.0.0) 1 | com_admin (3.0.0) 1 | com_config (3.0.0) 1 | com_cpanel (3.0.0) 1 | com_installer (3.0.0) 1 | com_languages (3.0.0) 1 | com_finder (3.0.0) 1 | com_templates (3.0.0) 1 | com_postinstall (3.2.0) 1 | com_media (3.0.0) 1 | com_messages (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_privacy (3.9.0) 1 | com_users (3.0.0) 1 | com_redirect (3.0.0) 1 | com_content (3.0.0) 1 | com_modules (3.0.0) 1 | com_checkin (3.0.0) 1 | com_ajax (3.2.0) 1 | com_banners (3.0.0) 1 |
3rd Party:: Akeeba (7.1.4) 1 | com_aimysitemap (27.2) 1 | COM_JCE (2.8.12) 1 | COM_OSGALLERY (3.2.8 Light) 1 |

Modules :: SITE ::
Core :: mod_feed (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_search (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_login (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_wrapper (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_tags_similar (3.1.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_articles_category (3.0.0) 1 |
3rd Party:: Simple Responsive Image Gallery (0.9) 0 | mod_relateditems_xtd (1.4) 1 | ARI Ext Menu (2.2.12) 1 | MOD_VISITORCOUNTER (3-3) 1 | Simple Image Holder (3.0.2) 1 | Featured categories (3.2.4) 1 | Fancy TagCloud (1.015) 1 | List of Articles Module (1.2.8) 1 | Blank Module (6.0.14) 1 | Latest News Extended (1.3) 1 |

Modules :: ADMIN ::
Core :: mod_toolbar (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_menu (3.0.0) 1 | mod_version (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_latest (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_login (3.0.0) 1 | mod_status (3.0.0) 1 | mod_title (3.0.0) 1 | mod_sampledata (3.8.0) 1 | mod_stats_admin (3.0.0) 1 | mod_submenu (3.0.0) 1 |
3rd Party:: MOD_VISITORCOUNTER_BACKEND_INFO (3-3) 1 | Missing MetaData (1.0.1) 1 |

Libraries ::
Core ::
3rd Party:: file_fof30 (3.5.2) ? |

Plugins ::
Core :: plg_twofactorauth_totp (3.2.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_captcha_recaptcha (3.4.0) 0 | plg_user_joomla (3.0.0) 1 | plg_user_profile (3.0.0) 0 | plg_user_terms (3.9.0) 0 | plg_user_contactcreator (3.0.0) 0 | plg_finder_tags (3.0.0) 0 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_finder_content (3.0.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_installer_packageinstaller (3.6.0) 1 | plg_installer_webinstaller (2.0.1) 1 | plg_privacy_message (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_gmail (3.0.0) 0 | plg_authentication_cookie (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_p3p (3.0.0) 0 | plg_system_remember (3.0.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_debug (3.0.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_log (3.0.0) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_stats (3.5.0) 1 | plg_system_redirect (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_sessiongc (3.8.6) 1 | plg_system_sef (3.0.0) 1 | plg_system_logout (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_content_finder (3.0.0) 0 | plg_content_joomla (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_fields (3.7.0) 1 | plg_content_vote (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_search_tags (3.0.0) 0 | plg_search_newsfeeds (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_content (3.0.0) 1 |
3rd Party:: plg_captcha_customrecaptcha (1.0.4) 0 | plg_editors_jce (2.8.12) 1 | plg_editors_tinymce (4.5.11) 1 | plg_editors_codemirror (5.52.2) 1 | plg_installer_jce (2.8.12) 1 | plg_system_jce (2.8.12) 1 | PLG_SYSTEM_BACKUPONUPDATE (7.1.4) 1 | PLG_SYSTEM_AKEEBAUPDATECHECK (7.1.4) 0 | T3 Framework (2.7.6) 1 | PLG_ECC (3-1) 1 | System - List of Articles (1.2.8) 1 | OS Gallery System (3.2.0 Light) 1 | plg_quickicon_jce (2.8.12) 1 | plg_quickicon_akeebabackup (7.1.4) 1 | plg_extension_jce (2.8.12) 1 | plg_fields_mediajce (2.8.12) 1 | plg_content_jce (2.8.12) 1 | Content - JA Thumbnail (2.6.0) 1 | Content - Easy Open Graph (1.1.5) 0 | Very Simple Image Gallery (1.6.8) 0 | PLG_CONTENT_RELATEDITEMSXTD (1.0) 0 | PLG_ACTIONLOG_AKEEBABACKUP (7.1.4) 0 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) 0 | beez3 (3.1.0) 0 | t3_blank (2.2.9) 0 | t3_bs3_blank (2.3.3) 1 |
Templates :: ADMIN :: isis (1.0) 1 | hathor (3.0.0) 1 |
Last edited by toivo on Tue Jun 02, 2020 11:45 pm, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

 
User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12510
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by toivo » Tue Jun 02, 2020 11:47 pm

That error message is displayed in most cases when the new PHP version does not have the PHP extension for mysqli selected in its configuration. In other cases the credentials of the database user in the Global Configuration have been incorrect.
Toivo Talikka, Global Moderator

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 03, 2020 1:12 am

Hello toivo,

Thank you for the response but not sure what I need to do?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12510
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by toivo » Wed Jun 03, 2020 2:21 am

Change the version of PHP to 7.2 or preferably to 7.3. Check which PHP extensions are selected and make sure mysqli is one of them.

Some older third party extensions may produced PHP errors or warnings in later versions of PHP. Those extensions will need to be updated.
Toivo Talikka, Global Moderator

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26923
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by Per Yngve Berg » Wed Jun 03, 2020 4:55 am

Run the FPA when you have the new Php version.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 03, 2020 7:24 pm

toivo wrote:
Wed Jun 03, 2020 2:21 am
Change the version of PHP to 7.2 or preferably to 7.3. Check which PHP extensions are selected and make sure mysqli is one of them.

Some older third party extensions may produced PHP errors or warnings in later versions of PHP. Those extensions will need to be updated.
Hello again,

I have found and either removed or updated older modules (that I thought I already had). I tried again to update to php 7.2 and I am still getting the same error message. What do you mean when you say:

Check which PHP extensions are selected and make sure mysqli is one of them?

Thanks again.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26923
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by Per Yngve Berg » Wed Jun 03, 2020 8:56 pm

Change session handler in configuration.php from 'database' to 'none' (php).

If you still get the same session error. The php session is badly configured on the server.

If it changes to a database error, you have a problem with the mysqli client driver.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 03, 2020 9:07 pm

Got it. Thank you Per Yngve Berg

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12510
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by toivo » Thu Jun 04, 2020 12:20 am

katz123 wrote:
Wed Jun 03, 2020 7:24 pm
What do you mean when you say:
Check which PHP extensions are selected and make sure mysqli is one of them?
The cPanel provided by your host has usually an option 'Select PHP Version' or 'PHP Selector', which allows you to select the version of PHP from a drop-down list. The page has also a list of PHP extensions in alphabetical order. Make sure 'mysqli' has been marked as enabled.

Please note that the selected PHP extensions can be and often are different for each version of PHP. Therefore, even if PHP 7.1 works all right, that does not mean that PHP 7.2 will, if its mysqli extension is not enabled.
Toivo Talikka, Global Moderator

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20118
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by leolam » Thu Jun 04, 2020 3:32 pm

@ Toivo, MySQLi is enabled as shown on the output of the FPA so that is not an issue.

@katz123. Please download https://downloads.joomla.org/cms/joomla ... ackage.zip and upload it to the Joomla update component in Components/Joomla update/tab 'upload and update' and re-install the Joomla package and see that this resolves?

Reason... your "file_fof30 (3.5.2)" is completely outdated and you need the latest version of this to be able to update to PHP 7.3 etc

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12510
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by toivo » Thu Jun 04, 2020 3:52 pm

leolam wrote:
Thu Jun 04, 2020 3:32 pm
@ Toivo, MySQLi is enabled as shown on the output of the FPA so that is not an issue.
@leolam, wasn't PHP 7.1 working until OP tried to update PHP to 7.2? The FPA results are from 7.1, but @Per asked the results from the later version.
Toivo Talikka, Global Moderator

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20118
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by leolam » Thu Jun 04, 2020 4:33 pm

sorry for that...missed that...tnx

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Thu Jun 04, 2020 6:39 pm

toivo wrote:
Thu Jun 04, 2020 12:20 am
katz123 wrote:
Wed Jun 03, 2020 7:24 pm
What do you mean when you say:
Check which PHP extensions are selected and make sure mysqli is one of them?
The cPanel provided by your host has usually an option 'Select PHP Version' or 'PHP Selector', which allows you to select the version of PHP from a drop-down list. The page has also a list of PHP extensions in alphabetical order. Make sure 'mysqli' has been marked as enabled.
Thank you. I am in cpanel and do not see a list of php extensions next to the php selector?

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Thu Jun 04, 2020 6:40 pm

leolam wrote:
Thu Jun 04, 2020 3:32 pm
@ Toivo, MySQLi is enabled as shown on the output of the FPA so that is not an issue.

@katz123. Please download https://downloads.joomla.org/cms/joomla ... ackage.zip and upload it to the Joomla update component in Components/Joomla update/tab 'upload and update' and re-install the Joomla package and see that this resolves?

Reason... your "file_fof30 (3.5.2)" is completely outdated and you need the latest version of this to be able to update to PHP 7.3 etc

Leo 8)
What is "file_fof30"? I saw that and didn't know what it meant. Thanks.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Thu Jun 04, 2020 7:05 pm

Per Yngve Berg wrote:
Wed Jun 03, 2020 8:56 pm
Change session handler in configuration.php from 'database' to 'none' (php).

If you still get the same session error. The php session is badly configured on the server.

If it changes to a database error, you have a problem with the mysqli client driver.
After changing from database to none and having my host try again to update to php 7.2 I get this error message:

Error: Call to undefined function Joomla\CMS\Language\simplexml_load_file(): The MySQLi extension for PHP is not installed or enabled.

Then hostgator support did something and the error message changed to: (and I still had session handler set to none)

Error: Failed to start application: The MySQLi extension for PHP is not installed or enabled.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Thu Jun 04, 2020 8:29 pm

Still can't upgrade to php 7.2? I did as leolam suggested and uploaded joomla 3.9.19 and installed again, still showing the same message (file_fof30 (3.5.2) ? ). I notice it is also showing the Beez and Prostar template listed but I uninstalled those? Here is the newest report from the FPA:
Forum Post Assistant (v1.5.0 (midden)) : 4th June 2020 wrote:
Last PHP Error(s) Reported :: wrote: in Unknown on line 0
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.19-Stable (Amani) 2-June-2020
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 60 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 120 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.19: Yes | Database Supports J! 3.9.19: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.14.146-225.ELK.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | System TMP Writable: Yes | Free Disk Space : 231.24 GiB |

PHP Configuration :: Version: 7.1.14 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 04th June 2020 15:28:13. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Version: 5.6.41-84.1 (Client:5.6.41-84.1) | Database Size: 11.21 MiB | #of Tables with config prefix: 93 | #of other Tables: 0
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.14) | date (7.1.14) | libxml (7.1.14) | openssl (7.1.14) | pcre (7.1.14) | sqlite3 (7.1.14) | zlib (7.1.14) | bcmath (7.1.14) | bz2 (7.1.14) | calendar (7.1.14) | ctype (7.1.14) | curl (7.1.14) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.14) | ftp (7.1.14) | gd (7.1.14) | gettext (7.1.14) | gmp (7.1.14) | SPL (7.1.14) | iconv (7.1.14) | session (7.1.14) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.14) | mcrypt (7.1.14) | mysqli (7.1.14) | odbc (7.1.14) | standard (7.1.14) | PDO (7.1.14) | pdo_mysql (7.1.14) | pdo_sqlite (7.1.14) | Phar (2.0.2) | posix (7.1.14) | pspell (7.1.14) | Reflection (7.1.14) | imap (7.1.14) | SimpleXML (7.1.14) | soap (7.1.14) | sockets (7.1.14) | exif (7.1.14) | tidy (7.1.14) | tokenizer (7.1.14) | wddx (7.1.14) | xml (7.1.14) | xmlreader (7.1.14) | xmlrpc (7.1.14) | xmlwriter (7.1.14) | xsl (7.1.14) | zip (1.13.5) | cgi-fcgi () | ionCube Loader () | Zend Engine (3.1.0) |
Potential Missing Extensions ::
Disabled Functions :: dl |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 272230 | Threads: 49 | Questions: 538415566 | Slow queries: 248 | Opens: 1676157 | Flush tables: 1 | Open tables: 16800 | Queries per second avg: 1977.796 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) 1 | com_mailto (3.0.0) 1 |
3rd Party:: WF_FONTSELECT_TITLE (2.8.12) ? | WF_LINK_TITLE (2.8.12) ? | WF_FONTSIZESELECT_TITLE (2.8.12) ? | WF_SPELLCHECKER_TITLE (2.8.12) ? | WF_STYLESELECT_TITLE (2.8.12) ? | WF_PREVIEW_TITLE (2.8.12) ? | WF_SOURCE_TITLE (2.8.12) ? | WF_FORMATSELECT_TITLE (2.8.12) ? | WF_TABLE_TITLE (2.8.12) ? | WF_CONTEXTMENU_TITLE (2.8.12) ? | WF_REFERENCE_TITLE (2.8.12) ? | WF_VISUALCHARS_TITLE (2.8.12) ? | WF_IMGMANAGER_TITLE (2.8.12) ? | WF_ANCHOR_TITLE (2.8.12) ? | WF_SEARCHREPLACE_TITLE (2.8.12) ? | WF_BROWSER_TITLE (2.8.12) ? | WF_CLEANUP_TITLE (2.8.12) ? | WF_XHTMLXTRAS_TITLE (2.8.12) ? | WF_DIRECTIONALITY_TITLE (2.8.12) ? | WF_HELP_TITLE (2.8.12) ? | WF_VISUALBLOCKS_TITLE (2.8.12) ? | WF_HR_TITLE (2.8.12) ? | WF_WORDCOUNT_TITLE (2.8.12) ? | WF_TEXTCASE_TITLE (2.8.12) ? | WF_FULLSCREEN_TITLE (2.8.12) ? | WF_ATTRIBUTES_TITLE (2.8.12) ? | WF_NONBREAKING_TITLE (2.8.12) ? | WF_AUTOSAVE_TITLE (2.8.12) ? | WF_MEDIA_TITLE (2.8.12) ? | WF_KITCHENSINK_TITLE (2.8.12) ? | WF_EMOTIONS_TITLE (2.8.12) ? | WF_LAYER_TITLE (2.8.2) ? | WF_ARTICLE_TITLE (2.8.12) ? | JCE - Noneditable (1.0.0) ? | WF_CHARMAP_TITLE (2.8.12) ? | WF_FONTCOLOR_TITLE (2.8.12) ? | WF_CLIPBOARD_TITLE (2.8.12) ? | WF_LISTS_TITLE (2.8.12) ? | WF_STYLE_TITLE (2.8.12) ? | WF_PRINT_TITLE (2.8.12) ? | WF_LINKS_JOOMLALINKS_TITLE (2.8.12) ? | WF_AGGREGATOR_[youtube]_TITLE (2.8.12) ? | WF_AGGREGATOR_DAILYMOTION_TITLE (2.8.12) ? | WF_AGGREGATOR_VIDEO_TITLE (2.8.12) ? | WF_AGGREGATOR_VIMEO_TITLE (2.8.12) ? | WF_AGGREGATOR_AUDIO_TITLE (2.8.12) ? | WF_POPUPS_JCEMEDIABOX_TITLE (2.8.12) ? | WF_FILESYSTEM_JOOMLA_TITLE (2.8.12) ? | WF_LINK_SEARCH_TITLE (2.8.12) ? |

Components :: ADMIN ::
Core :: com_fields (3.7.0) 1 | com_login (3.0.0) 1 | com_categories (3.0.0) 1 | com_plugins (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_cache (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_contenthistory (3.2.0) 1 | com_associations (3.7.0) 1 | com_tags (3.1.0) 1 | com_search (3.0.0) 1 | com_menus (3.0.0) 1 | com_admin (3.0.0) 1 | com_config (3.0.0) 1 | com_cpanel (3.0.0) 1 | com_installer (3.0.0) 1 | com_languages (3.0.0) 1 | com_finder (3.0.0) 1 | com_templates (3.0.0) 1 | com_postinstall (3.2.0) 1 | com_media (3.0.0) 1 | com_messages (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_privacy (3.9.0) 1 | com_users (3.0.0) 1 | com_redirect (3.0.0) 1 | com_content (3.0.0) 1 | com_modules (3.0.0) 1 | com_checkin (3.0.0) 1 | com_ajax (3.2.0) 1 | com_banners (3.0.0) 1 |
3rd Party:: Akeeba (7.1.4) 1 | com_aimysitemap (27.2) 1 | COM_JCE (2.8.12) 1 |

Modules :: SITE ::
Core :: mod_feed (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_search (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_login (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_wrapper (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_tags_similar (3.1.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_articles_category (3.0.0) 1 |
3rd Party:: mod_relateditems_xtd (1.7.1) 1 | Latest News + Date (3.0.1) 1 | ARI Ext Menu (2.2.12) 1 | Minifrontpagepro (1.1.1) 1 | Latest News Extended (1.3) 1 |

Modules :: ADMIN ::
Core :: mod_toolbar (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_menu (3.0.0) 1 | mod_version (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_latest (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_login (3.0.0) 1 | mod_status (3.0.0) 1 | mod_title (3.0.0) 1 | mod_sampledata (3.8.0) 1 | mod_stats_admin (3.0.0) 1 | mod_submenu (3.0.0) 1 |
3rd Party::

Libraries ::
Core ::
3rd Party:: file_fof30 (3.5.2) ? |

Plugins ::
Core :: plg_twofactorauth_totp (3.2.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_captcha_recaptcha (3.4.0) 0 | plg_user_joomla (3.0.0) 1 | plg_user_profile (3.0.0) 0 | plg_user_terms (3.9.0) 0 | plg_user_contactcreator (3.0.0) 0 | plg_finder_tags (3.0.0) 0 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_finder_content (3.0.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_installer_packageinstaller (3.6.0) 1 | plg_installer_webinstaller (2.0.1) 1 | plg_privacy_message (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_gmail (3.0.0) 0 | plg_authentication_cookie (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_p3p (3.0.0) 0 | plg_system_remember (3.0.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_debug (3.0.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_log (3.0.0) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_stats (3.5.0) 1 | plg_system_redirect (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_sessiongc (3.8.6) 1 | plg_system_sef (3.0.0) 1 | plg_system_logout (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_content_finder (3.0.0) 0 | plg_content_joomla (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_fields (3.7.0) 1 | plg_content_vote (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_search_tags (3.0.0) 0 | plg_search_newsfeeds (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_content (3.0.0) 1 |
3rd Party:: plg_editors_jce (2.8.12) 1 | plg_editors_tinymce (4.5.11) 1 | plg_editors_codemirror (5.52.2) 1 | plg_installer_jce (2.8.12) 1 | plg_system_jce (2.8.12) 1 | PLG_SYSTEM_BACKUPONUPDATE (7.1.4) 1 | PLG_SYSTEM_AKEEBAUPDATECHECK (7.1.4) 0 | T3 Framework (2.7.6) 1 | plg_quickicon_jce (2.8.12) 1 | plg_quickicon_akeebabackup (7.1.4) 1 | plg_extension_jce (2.8.12) 1 | plg_fields_mediajce (2.8.12) 1 | plg_content_jce (2.8.12) 1 | Content - JA Thumbnail (2.6.0) 1 | PLG_CONTENT_RELATEDITEMSXTD (1.0.1) 0 | PLG_ACTIONLOG_AKEEBABACKUP (7.1.4) 0 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) ? | beez3 (3.1.0) ? | t3_blank (2.2.9) 0 | t3_bs3_blank (2.3.3) 1 |
Templates :: ADMIN :: isis (1.0) 1 | hathor (3.0.0) 1 |
Last edited by toivo on Fri Jun 05, 2020 1:09 am, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26923
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by Per Yngve Berg » Thu Jun 04, 2020 8:48 pm

Still php 7.1. You have to run the FPA when php 7.2 is enabled.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Thu Jun 04, 2020 9:27 pm

Per Yngve Berg wrote:
Thu Jun 04, 2020 8:48 pm
Still php 7.1. You have to run the FPA when php 7.2 is enabled.
Oh. So when I have hostgator switch to 7.2 even though it doesn't work - I need to run the FPA? Sorry, I didn't realize that is what you meant. OK. Will do.

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 24, 2020 8:38 pm

Hello, Sorry it has taken so long for me to run the script again.

So, if I did this right this time, I had hostgator set the site to php 7.2. Ran the FPA script while site was broken. Below is the output:
Forum Post Assistant (v1.5.0 (midden)) : 24th June 2020 wrote:
Last PHP Error(s) Reported :: wrote: in Unknown on line 0
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.19-Stable (Amani) 2-June-2020
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 60 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 120 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.19: Yes | Database Supports J! 3.9.19: Unknown | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.14.146-225.ELK.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | System TMP Writable: Yes | Free Disk Space : 225.12 GiB |

PHP Configuration :: Version: 7.2.31 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 24th June 2020 15:31:43. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 256M | Max. POST Size: 260M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Connection Error: PHP function mysqli_connect not found.
Detailed Environment :: wrote:PHP Extensions :: Core (7.2.31) | date (7.2.31) | libxml (7.2.31) | openssl (7.2.31) | pcre (7.2.31) | zlib (7.2.31) | filter (7.2.31) | hash (1.0) | pcntl (7.2.31) | readline (7.2.31) | Reflection (7.2.31) | SPL (7.2.31) | session (7.2.31) | standard (7.2.31) | cgi-fcgi () | Zend Engine (3.2.0) |
Potential Missing Extensions :: xml | zip | curl | iconv | mbstring | mysqli | pdo_mysql |
Disabled Functions :: dl |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) ? | com_mailto (3.0.0) ? |
3rd Party:: WF_FONTSELECT_TITLE (2.8.14) ? | WF_LINK_TITLE (2.8.14) ? | WF_FONTSIZESELECT_TITLE (2.8.14) ? | WF_SPELLCHECKER_TITLE (2.8.14) ? | WF_STYLESELECT_TITLE (2.8.14) ? | WF_PREVIEW_TITLE (2.8.14) ? | WF_SOURCE_TITLE (2.8.14) ? | WF_FORMATSELECT_TITLE (2.8.14) ? | WF_TABLE_TITLE (2.8.14) ? | WF_CONTEXTMENU_TITLE (2.8.14) ? | WF_REFERENCE_TITLE (2.8.14) ? | WF_VISUALCHARS_TITLE (2.8.14) ? | WF_IMGMANAGER_TITLE (2.8.14) ? | WF_ANCHOR_TITLE (2.8.14) ? | WF_SEARCHREPLACE_TITLE (2.8.14) ? | WF_BROWSER_TITLE (2.8.14) ? | WF_CLEANUP_TITLE (2.8.14) ? | WF_XHTMLXTRAS_TITLE (2.8.14) ? | WF_DIRECTIONALITY_TITLE (2.8.14) ? | WF_HELP_TITLE (2.8.14) ? | WF_VISUALBLOCKS_TITLE (2.8.14) ? | WF_HR_TITLE (2.8.14) ? | WF_WORDCOUNT_TITLE (2.8.14) ? | WF_TEXTCASE_TITLE (2.8.14) ? | WF_FULLSCREEN_TITLE (2.8.14) ? | WF_ATTRIBUTES_TITLE (2.8.14) ? | WF_NONBREAKING_TITLE (2.8.14) ? | WF_AUTOSAVE_TITLE (2.8.14) ? | WF_MEDIA_TITLE (2.8.14) ? | WF_KITCHENSINK_TITLE (2.8.14) ? | WF_EMOTIONS_TITLE (2.8.14) ? | WF_LAYER_TITLE (2.8.2) ? | WF_ARTICLE_TITLE (2.8.14) ? | JCE - Noneditable (1.0.0) ? | WF_CHARMAP_TITLE (2.8.14) ? | WF_FONTCOLOR_TITLE (2.8.14) ? | WF_CLIPBOARD_TITLE (2.8.14) ? | WF_LISTS_TITLE (2.8.14) ? | WF_STYLE_TITLE (2.8.14) ? | WF_PRINT_TITLE (2.8.14) ? | WF_LINKS_JOOMLALINKS_TITLE (2.8.14) ? | WF_AGGREGATOR_[youtube]_TITLE (2.8.14) ? | WF_AGGREGATOR_DAILYMOTION_TITLE (2.8.14) ? | WF_AGGREGATOR_VIDEO_TITLE (2.8.14) ? | WF_AGGREGATOR_VIMEO_TITLE (2.8.14) ? | WF_AGGREGATOR_AUDIO_TITLE (2.8.14) ? | WF_POPUPS_JCEMEDIABOX_TITLE (2.8.14) ? | WF_FILESYSTEM_JOOMLA_TITLE (2.8.14) ? | WF_LINK_SEARCH_TITLE (2.8.14) ? |

Components :: ADMIN ::
Core :: com_fields (3.7.0) ? | com_login (3.0.0) ? | com_categories (3.0.0) ? | com_plugins (3.0.0) ? | com_actionlogs (3.9.0) ? | com_cache (3.0.0) ? | com_joomlaupdate (3.6.2) ? | com_contenthistory (3.2.0) ? | com_associations (3.7.0) ? | com_tags (3.1.0) ? | com_search (3.0.0) ? | com_menus (3.0.0) ? | com_admin (3.0.0) ? | com_config (3.0.0) ? | com_cpanel (3.0.0) ? | com_installer (3.0.0) ? | com_languages (3.0.0) ? | com_finder (3.0.0) ? | com_templates (3.0.0) ? | com_postinstall (3.2.0) ? | com_media (3.0.0) ? | com_messages (3.0.0) ? | com_newsfeeds (3.0.0) ? | com_privacy (3.9.0) ? | com_users (3.0.0) ? | com_redirect (3.0.0) ? | com_content (3.0.0) ? | com_modules (3.0.0) ? | com_checkin (3.0.0) ? | com_ajax (3.2.0) ? | com_banners (3.0.0) ? |
3rd Party:: Akeeba (7.2.1) ? | com_aimysitemap (27.3) ? | COM_JCE (2.8.14) ? |

Modules :: SITE ::
Core :: mod_feed (3.0.0) ? | mod_articles_latest (3.0.0) ? | mod_whosonline (3.0.0) ? | mod_menu (3.0.0) ? | mod_footer (3.0.0) ? | mod_search (3.0.0) ? | mod_custom (3.0.0) ? | mod_login (3.0.0) ? | mod_finder (3.0.0) ? | mod_wrapper (3.0.0) ? | mod_random_image (3.0.0) ? | mod_articles_news (3.0.0) ? | mod_syndicate (3.0.0) ? | mod_articles_categories (3.0.0) ? | mod_users_latest (3.0.0) ? | mod_languages (3.5.0) ? | mod_tags_similar (3.1.0) ? | mod_breadcrumbs (3.0.0) ? | mod_articles_archive (3.0.0) ? | mod_related_items (3.0.0) ? | mod_banners (3.0.0) ? | mod_stats (3.0.0) ? | mod_articles_popular (3.0.0) ? | mod_tags_popular (3.1.0) ? | mod_articles_category (3.0.0) ? |
3rd Party:: mod_relateditems_xtd (1.7.1) ? | Latest News + Date (3.0.1) ? | ARI Ext Menu (2.2.12) ? | Minifrontpagepro (1.1.1) ? | Latest News Extended (1.3) ? |

Modules :: ADMIN ::
Core :: mod_toolbar (3.0.0) ? | mod_feed (3.0.0) ? | mod_privacy_dashboard (3.9.0) ? | mod_multilangstatus (3.0.0) ? | mod_latestactions (3.9.0) ? | mod_menu (3.0.0) ? | mod_version (3.0.0) ? | mod_quickicon (3.0.0) ? | mod_latest (3.0.0) ? | mod_logged (3.0.0) ? | mod_popular (3.0.0) ? | mod_custom (3.0.0) ? | mod_login (3.0.0) ? | mod_status (3.0.0) ? | mod_title (3.0.0) ? | mod_sampledata (3.8.0) ? | mod_stats_admin (3.0.0) ? | mod_submenu (3.0.0) ? |
3rd Party::

Libraries ::
Core ::
3rd Party:: file_fof30 (3.6.1) ? |

Plugins ::
Core :: plg_twofactorauth_totp (3.2.0) ? | plg_twofactorauth_yubikey (3.2.0) ? | plg_captcha_recaptcha_invisible (3.8) ? | plg_captcha_recaptcha (3.4.0) ? | plg_user_joomla (3.0.0) ? | plg_user_profile (3.0.0) ? | plg_user_terms (3.9.0) ? | plg_user_contactcreator (3.0.0) ? | plg_finder_tags (3.0.0) ? | plg_finder_newsfeeds (3.0.0) ? | plg_finder_contacts (3.0.0) ? | plg_finder_categories (3.0.0) ? | plg_finder_content (3.0.0) ? | PLG_INSTALLER_URLINSTALLER (3.6.0) ? | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) ? | plg_installer_packageinstaller (3.6.0) ? | plg_installer_webinstaller (2.0.1) ? | plg_privacy_message (3.9.0) ? | plg_privacy_user (3.9.0) ? | plg_privacy_consents (3.9.0) ? | plg_privacy_actionlogs (3.9.0) ? | plg_privacy_content (3.9.0) ? | plg_authentication_ldap (3.0.0) ? | plg_authentication_joomla (3.0.0) ? | plg_authentication_gmail (3.0.0) ? | plg_authentication_cookie (3.0.0) ? | plg_editors-xtd_pagebreak (3.0.0) ? | plg_editors-xtd_menu (3.7.0) ? | plg_editors-xtd_module (3.5.0) ? | plg_editors-xtd_fields (3.7.0) ? | plg_editors-xtd_article (3.0.0) ? | plg_editors-xtd_image (3.0.0) ? | plg_editors-xtd_readmore (3.0.0) ? | plg_system_cache (3.0.0) ? | plg_system_p3p (3.0.0) ? | plg_system_remember (3.0.0) ? | plg_system_updatenotification (3.5.0) ? | plg_system_languagecode (3.0.0) ? | plg_system_debug (3.0.0) ? | plg_system_highlight (3.0.0) ? | plg_system_fields (3.7.0) ? | plg_system_log (3.0.0) ? | plg_system_languagefilter (3.0.0) ? | plg_system_stats (3.5.0) ? | plg_system_redirect (3.0.0) ? | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_logrotation (3.9.0) ? | plg_system_sessiongc (3.8.6) ? | plg_system_sef (3.0.0) ? | plg_system_logout (3.0.0) ? | plg_system_privacyconsent (3.9.0) ? | plg_quickicon_extensionupdate (3.0.0) ? | plg_quickicon_phpversioncheck (3.7.0) ? | plg_quickicon_privacycheck (3.9.0) ? | plg_quickicon_joomlaupdate (3.0.0) ? | plg_extension_joomla (3.0.0) ? | plg_fields_checkboxes (3.7.0) ? | plg_fields_user (3.7.0) ? | plg_fields_url (3.7.0) ? | plg_fields_imagelist (3.7.0) ? | plg_fields_textarea (3.7.0) ? | plg_fields_color (3.7.0) ? | plg_fields_editor (3.7.0) ? | plg_fields_integer (3.7.0) ? | plg_fields_calendar (3.7.0) ? | plg_fields_sql (3.7.0) ? | plg_fields_repeatable (3.9.0) ? | plg_fields_text (3.7.0) ? | plg_fields_radio (3.7.0) ? | plg_fields_media (3.7.0) ? | plg_fields_usergrouplist (3.7.0) ? | plg_fields_list (3.7.0) ? | plg_content_finder (3.0.0) ? | plg_content_joomla (3.0.0) ? | plg_content_pagebreak (3.0.0) ? | plg_content_pagenavigation (3.0.0) ? | plg_content_loadmodule (3.0.0) ? | plg_content_confirmconsent (3.9.0) ? | plg_content_fields (3.7.0) ? | plg_content_vote (3.0.0) ? | plg_content_emailcloak (3.0.0) ? | PLG_ACTIONLOG_JOOMLA (3.9.0) ? | plg_search_tags (3.0.0) ? | plg_search_newsfeeds (3.0.0) ? | plg_search_contacts (3.0.0) ? | plg_search_categories (3.0.0) ? | plg_search_content (3.0.0) ? |
3rd Party:: plg_editors_jce (2.8.14) ? | plg_editors_tinymce (4.5.11) ? | plg_editors_codemirror (5.52.2) ? | plg_installer_jce (2.8.14) ? | plg_system_jce (2.8.14) ? | PLG_SYSTEM_BACKUPONUPDATE (7.2.1) ? | PLG_SYSTEM_AKEEBAUPDATECHECK (7.2.1) ? | T3 Framework (2.7.6) ? | plg_quickicon_jce (2.8.14) ? | plg_quickicon_akeebabackup (7.2.1) ? | plg_extension_jce (2.8.14) ? | plg_fields_mediajce (2.8.14) ? | plg_content_jce (2.8.14) ? | PLG_CONTENT_RELATEDITEMSXTD (1.0.1) ? | PLG_ACTIONLOG_AKEEBABACKUP (7.2.1) ? |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) ? | beez3 (3.1.0) ? | t3_blank (2.2.9) ? | t3_bs3_blank (2.3.3) ? |
Templates :: ADMIN :: isis (1.0) ? | hathor (3.0.0) ? |
Not sure this matters or not but I deleted the beez and protostar templates yet they still are showing in this report?
Last edited by toivo on Wed Jun 24, 2020 11:47 pm, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26923
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by Per Yngve Berg » Wed Jun 24, 2020 8:54 pm

Database Configuration :: Connection Error: PHP function mysqli_connect not found

Potential Missing Extensions :: xml | zip | curl | iconv | mbstring | mysqli

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 24, 2020 9:48 pm

I saw that. What does it mean? and what do I need to do? Thank you

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9172
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by sozzled » Wed Jun 24, 2020 9:55 pm

@kat123: I don't know what features Hostgator provides to their customers that allow their customers to change PHP settings but, from my experience with other webhosting companies who offer cPanel facilities, changing PHP settings are normally accessed through something like that. In my opinion, not knowing how Hostgator operates, I would ask Hostgator to help guide you with setting up these missing PHP extensions.

Lastly, there's no need to "delete" beez3 or protostar. In fact you could cause more problems if you do try to do that.

When you have fixed the PHP 7.2 problems, you should use the database "fix" utility and extensions "discover" utility to repair any damage that you may have inadvertently caused. Good luck.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 24, 2020 10:32 pm

Oh. Interesting. I did not know uninstalling those templates could cause issues. We have always removed them. You learn something all the time.

Should I reinstall them?

And just out of curiosity? Why would those extensions be missing? And did I cause this issue somehow?

Thank you @sozzled for clarification.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9172
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by sozzled » Wed Jun 24, 2020 10:41 pm

First things first. Ask Hostgator to help you add the missing PHP extensions. Then we can address the other problems.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

katz123
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Sun Feb 01, 2009 4:16 am

Re: Cannot Update to PHP 7.2 - Getting Error Session Start Failed

Post by katz123 » Wed Jun 24, 2020 10:42 pm

Alright. Thanks. I'll see what Hostgator can help me with.

 

Post Reply

Return to “General Questions/New to Joomla! 3.x”