Can't send messages from the website after site transfer Topic is solved

General questions relating to Joomla! 3.x.
eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Sun Jan 24, 2021 10:30 pm

Webdongle wrote:
Sun Jan 24, 2021 7:32 pm
afaik Joomla puts a session cookie on the visiting computer and stores the value in the database.

If the extention is picking up the wrong cookie it could be accessing the wrong database?

Check for hard coded links. If you want you could send me the jpa backup.
It's messing up, it is possible that Joomla is configured with the correct db and the extension points to abother db, but i wouldn't know how to verify it.
The links are messing up, sometimes i saw the old site buttons pointing to the new site.
It's very kind of you,

Thank you, looking forward.
It's in Italian, the component to send messages is in the page "raccontaci", the side modules are not working in this jpa, i don't know why.
Last edited by eiasu on Sun Jan 24, 2021 11:33 pm, edited 1 time in total.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Sun Jan 24, 2021 11:08 pm

ok got it. You can remove it now

Addendum
When I visit the 'raccontaci' page then I go to the admin window and click a different menu item then I have to re log in

Addendum 2
Visiting the 'raccontaci' page deletes the session cookie from the database 's session table
Navigating the front end with other menu items deletes the session cookie from the database 's session table
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Mon Jan 25, 2021 12:17 am

Is there a way to fix these misconfigurations?

Besides that i also wanted to ask you why you strongly prefer wamp over xampp, i use it and i find it fine,
Thanks

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Mon Jan 25, 2021 12:27 am

Disable the 'AJAX - EU e-Privacy Directive' plugin and see what happens then

Also
System - EU e-Privacy Directive
and
http://localhost/atest/administrator/in ... n_id=10036
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

Pavel-ww
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Tue Jun 30, 2020 12:17 pm

Re: Can't send messages from the website after site transfer

Post by Pavel-ww » Mon Jan 25, 2021 7:38 am

Hi. If you want to receive forms from the site, you must use domain mail. Private mailboxes are not designed for this. Most likely all your mails fall under the gmail spam filter.
3.jpg
You do not have the required permissions to view the files attached to this post.

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Mon Jan 25, 2021 8:40 am

Thank you all for the support,
i checked spam email, there is no email sent from the site.

I disabled the 3 plugins
disabled privacy plugin.jpg
and now the message changed, is no more about expired session but is
"Avviso
Impossibile avviare la funzione mail.
Invio del messaggio fallito.: Impossibile avviare la funzione mail."

"Notice
impossible to start mail function. Message delivery failed.: impossible to start mail funciont"

but on the local xampp i have problem with test mail:
Error test mail.jpg
I should restore an old version on the internet domain and give it a try, but to be honest, i did so many changes now that i am very much afraid to spoil something, so i will try on the local server, maybe using wamp instead of xampp i could avoid the mail problem?
You do not have the required permissions to view the files attached to this post.

Pavel-ww
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Tue Jun 30, 2020 12:17 pm

Re: Can't send messages from the website after site transfer

Post by Pavel-ww » Mon Jan 25, 2021 9:41 am

eiasu wrote:
Mon Jan 25, 2021 8:40 am
i checked spam email, there is no email sent from the site.
You cannot checked this. The spam filter completely does not allow emails to enter your mailbox. Spam folder is not a spam filter.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Mon Jan 25, 2021 10:09 am

So those plugins are causing the session error. But you also have email errors.

Perhaps set up a fresh install (no sample data). Then use https://extensions.joomla.org/extension/j2xml/ to move categories/articles etc. ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Mon Jan 25, 2021 10:47 am

Pavel,
as soon as i click the form button there is an error message, there is no email send at all.

Webdongle,
yes that's the problem, thank you, i will work around the privacy plugin, i will try some other plugin.
The mail error is because i have an older php on my xampp that does not implement the php mail function.

Thank you all very much, i have not yet fixed the error but it is clear the way to go.

Great community, thanks!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Mon Jan 25, 2021 2:17 pm

Localhost by default doesn't have email function. There are ways to send emails via localhost but many sources say can leave your PC vulnerable. Best imho is test email on remote host.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13261
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Can't send messages from the website after site transfer

Post by toivo » Mon Jan 25, 2021 2:46 pm

Forward Joomla's emails from localhost to the Gmail SMTP server, as long as the website uses an application specific password (ASP), as described in the tutorial How do I use Gmail as my mail server?.

In this scenario your workstation does not run a mail server or receive any replies to the emails it has sent. The replies go to the designated Gmail mailbox.
Toivo Talikka, Global Moderator

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Mon Jan 25, 2021 5:32 pm

Thank you very much,
there is a lot to learn from you.

Very much appreciated

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Wed Feb 10, 2021 6:30 pm

by the way, i just read on the richeyweb documentation page that:

https://www.richeyweb.com/documentation ... -directive

HELP

I keep getting logged out of /administrator!
The plugin removes all cookies it finds while you're browsing the frontend of your website. This includes the /administrator cookie if you're logged into /administrator. The solution is to use a 2nd browser while browsing the site and /administrator at the same time. Chrome has the "Incognito" window, which can be used to maintain the necessary separation while using this plugin.

So this explains why i get logged out all the time

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27541
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Can't send messages from the website after site transfer

Post by Per Yngve Berg » Wed Feb 10, 2021 7:22 pm

Site and administrator have separate sessions, unless you have set shared login in Global Configuration.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Thu Feb 11, 2021 3:38 am

Incognito has no affect on Joomla's session cookies. Yes, cookies plural. As Per Yngve Berg says "Site and administrator have separate sessions".
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Thu Feb 11, 2021 8:53 am

Ok i understand, i wanted just to share something that might be useful for someone with the same issue, but seemingly it's not.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Thu Feb 11, 2021 10:05 am

It is not useful it is incorrect information. Perhaps check your facts before sharing it
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

eiasu
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Jul 12, 2018 8:59 am

Re: Can't send messages from the website after site transfer

Post by eiasu » Thu Feb 11, 2021 11:30 am

Webdongle wrote:
Thu Feb 11, 2021 10:05 am
It is not useful it is incorrect information. Perhaps check your facts before sharing it
ok good to know, i trusted and reported exactly what i read on Richey Documentation page, since i assumed they know what they write so i copied here what is written there since i also use their eu-privacy extension.

Let me know, you or any admin, at this point what is more helpful, if i should remove my previous post, or it is enough to underline that that information is completely wrong and misguiding.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39463
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't send messages from the website after site transfer

Post by Webdongle » Thu Feb 11, 2021 12:08 pm

Trusting and assuming (what is posted on the internet) are probably the two biggest reasons misinformation is so abundant on the internet.

Again "Perhaps check your facts before sharing it"
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.


Post Reply

Return to “General Questions/New to Joomla! 3.x”