Some of the links in a module do not work

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
Carolek
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Wed Jul 18, 2012 2:15 pm

Some of the links in a module do not work

Post by Carolek » Sat Sep 18, 2021 11:19 am

Hello
I create a module with some links: facebook, whatsapp, email and phone.
All the links seems to be the same but only facebook link is working. Everything else does not work.
I can't understand why.

Here is the code:

Code: Select all

<div style="float: left;"><button type="button"> <span style="font-size: 14pt; font-family: verdana, geneva, sans-serif;"> <a href="tel:972506885851" target="_blank" rel="noopener noreferrer">050-6885851</a>  <img src="http://www.franckbakosh.co.il/images/2021/iconphone.png" alt="telephone" width="40" height="40" /></span></button> <a href="mailto:franck.bakosh@gmail.com" target="_blank" rel="alternate noopener noreferrer"><img src="http://www.franckbakosh.co.il/images/2021/email.png" alt="email" width="40" height="40" /></a> <a title="whatsapp" href="https://wa.link/pn041z" target="_blank" rel="noopener noreferrer"> <img src="http://www.franckbakosh.co.il/images/1-12340_whatsapp-logo-whats-app-logo-whatsapp.png" alt="whatsapp" width="40" height="40" /></a> <a title="facebook" href="https://www.facebook.com/franck.bakosh" target="_blank" rel="noopener noreferrer"><img src="http://www.franckbakosh.co.il/images/social-facebook-button-blue-icon--social-bookmark-iconset--yootheme-6.png" alt="facebook" width="40" height="40" /></a></div>
The site is offline for now.
I noticed that if there is a display: inline-grid on the DIV that contains all the links, they all work, but then, they do not sit well on the page.
Anyone have an idea?
Thanks in advance.

User avatar
Pavel-ww
Joomla! Explorer
Joomla! Explorer
Posts: 457
Joined: Tue Jun 30, 2020 12:17 pm

Re: Some of the links in a module do not work

Post by Pavel-ww » Sat Sep 18, 2021 6:28 pm

Hi. Your code contains errors. And I would recommend using CSS in the file, but do not use the inline CSS code within tags.

Code: Select all

<div style="float: left;"> 
    <a href="tel:972506885851">
        050-6885851
        <img src="http://www.franckbakosh.co.il/images/2021/iconphone.png" alt="telephone" width="40" height="40" />
    </a> 
    <a href="mailto:franck.bakosh@gmail.com">
        <img src="http://www.franckbakosh.co.il/images/2021/email.png" alt="email" width="40" height="40" />
    </a>
    <a title="whatsapp" href="https://wa.link/pn041z" target="_blank" rel="noopener noreferrer"> 
        <img src="http://www.franckbakosh.co.il/images/1-12340_whatsapp-logo-whats-app-logo-whatsapp.png" alt="whatsapp" width="40" height="40" />
    </a> 
    <a title="facebook" href="https://www.facebook.com/franck.bakosh" target="_blank" rel="noopener noreferrer">
        <img src="http://www.franckbakosh.co.il/images/social-facebook-button-blue-icon--social-bookmark-iconset--yootheme-6.png" alt="facebook" width="40" height="40" />
    </a>
</div>

Carolek
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Wed Jul 18, 2012 2:15 pm

Re: Some of the links in a module do not work

Post by Carolek » Sat Sep 18, 2021 7:18 pm

This code is not working either, any idea?

User avatar
Pavel-ww
Joomla! Explorer
Joomla! Explorer
Posts: 457
Joined: Tue Jun 30, 2020 12:17 pm

Re: Some of the links in a module do not work

Post by Pavel-ww » Sun Sep 19, 2021 7:18 am

Carolek wrote:
Sat Sep 18, 2021 7:18 pm
This code is not working either, any idea?
Hi. What do you mean? It can't not work - all links work as it should. Share a link to your site

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28210
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Some of the links in a module do not work

Post by Per Yngve Berg » Sun Sep 19, 2021 8:20 am

Putting your email address on the site is not a very good idea. Harvest boots will pick up your address and send you spam.

Use a contact form.

PS. Have you checked the source code of the rendered page. The email cloaking plugin may have messed up the code.

Carolek
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Wed Jul 18, 2012 2:15 pm

Re: Some of the links in a module do not work

Post by Carolek » Sun Sep 19, 2021 8:32 am

Pavel-ww wrote:
Sun Sep 19, 2021 7:18 am
Carolek wrote:
Sat Sep 18, 2021 7:18 pm
This code is not working either, any idea?
Hi. What do you mean? It can't not work - all links work as it should. Share a link to your site
http://www.franckbakosh.co.il/

I open it for a while. Thanks.

User avatar
Pavel-ww
Joomla! Explorer
Joomla! Explorer
Posts: 457
Joined: Tue Jun 30, 2020 12:17 pm

Re: Some of the links in a module do not work

Post by Pavel-ww » Sun Sep 19, 2021 12:49 pm

Menu UL overlaps it. Therefore, links do not work
1.jpg
You do not have the required permissions to view the files attached to this post.

Carolek
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Wed Jul 18, 2012 2:15 pm

Re: Some of the links in a module do not work

Post by Carolek » Sun Sep 19, 2021 1:50 pm

Thank you! I will check it!

User avatar
Pavel-ww
Joomla! Explorer
Joomla! Explorer
Posts: 457
Joined: Tue Jun 30, 2020 12:17 pm

Re: Some of the links in a module do not work

Post by Pavel-ww » Sun Sep 19, 2021 4:06 pm

You are wellcome


Post Reply

Return to “General Questions/New to Joomla! 3.x”