User Group Not Working for One Member

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

User Group Not Working for One Member

Post by andlutz » Thu Oct 21, 2021 1:55 pm

I created a user group to allow a limited number of users to access one component. This user group works well for one user. No other users can access the component. Any ideas why it works for one but not all members of the group?

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1853
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: User Group Not Working for One Member

Post by darb » Thu Oct 21, 2021 6:48 pm

You set it up wrong..have you read the Joomla docs?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Thu Oct 21, 2021 7:11 pm

darb wrote:
Thu Oct 21, 2021 6:48 pm
You set it up wrong...
:laugh: :laugh: :laugh:


The user that can access it is also in another user group that has access.
The new user group has not been selected in the correct view level. If the new user group has access to admin login then it also needs to be selected in the 'Special' view/access level.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Thu Oct 21, 2021 8:47 pm

The issue is the admin login. Thanks, I'll look further into that.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Thu Oct 21, 2021 9:19 pm

The admin menu is access level 'Special'

To create a group that has access to one Component in /administrator
* Create User group with 'Registered' as Parent
* In Global config Permissions Allow admin login (leave everything else Inherited
* In the desired Component Options Permissions Allow Create, Edit, Delete etc. and 'Access Administration Interface'
* In View/Access level 'Special' select the new user group. Do the same for the other View/access levels that you want members of that user group to see e.g. 'Registered'.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Fri Oct 22, 2021 1:41 pm

Thank you very much for the detailed steps, Webdongle. This is exactly how I have set this up, however, once the user logs into the administrative interface she gets a blank page with her info in the upper right corner. I am missing some little, very important thing and it is maddening trying to figure it out. I appreciate your assistance and will let you know once I find where I've made the error.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Fri Oct 22, 2021 2:34 pm

andlutz wrote:
Fri Oct 22, 2021 1:41 pm
.... once the user logs into the administrative interface she gets a blank page with her info in the upper right corner. I am missing some little, very important thing ...
Users >>> Access levels >>> Special ... select the new user group? (allows members of the user group to see the admin menu).

Components >>> select component >>> Options >>> Permissions ... Allow 'Access Administration Interface'? (allows members of the user group to see the Component menu item and the sub menu item for the specific Component).
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Fri Oct 22, 2021 4:51 pm

While I have set the Global Permissions for this component to allow for access to the administration interface, this particular component doesn't have ''Access Administration Interface" -- it does have "Access Administration Features (or Categories, or Events...)" all of which are set to Allow.

See screenshot for list of all available options.
Image

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Fri Oct 22, 2021 5:51 pm

Try in Global config Permissions Allow 'Access Administration Interface'
And see if a user in the new user group can see the menu item then.

If it can then it is a badly written component and you have a couple of work arounds. You could Disallow all the other Components and Categories and Users at their Options. Or perhaps write a plugin. Although it beggars belief that a component would be written that doesn't have a separate 'Access Administration Interface'.

If still no avail after temporarily Allow 'Access Administration Interface' in Global config then the problem is elsewhere.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Fri Oct 22, 2021 7:24 pm

Thank you so much for sticking with this issue. I do have 'Access Administration Interface' allowed in the Global config Permissions.

Interestingly, if I move this special group out from under 'Manager' and under a different group that has many more permissions, then she can log in. But this user should not have access to this other stuff, only one component.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Fri Oct 22, 2021 7:40 pm

andlutz wrote:
Fri Oct 22, 2021 7:24 pm
...
Interestingly, if I move this special group out from under 'Manager' and under a different group that has many more permissions, then she can log in. But this user should not have access to this other stuff, only one component.
The whole point of
Webdongle wrote:
Thu Oct 21, 2021 9:19 pm
...
To create a group that has access to one Component in /administrator
* Create User group with 'Registered' as Parent
* In Global config Permissions Allow admin login (leave everything else Inherited

...
Is to prevent users of the new group having access to all of the Components.


IF you set it like that AND the component doesn't have Permissions Allow 'Access Administration Interface' THEN ... You need to set it in Global Config and Disallow Access Administration Interface' for everything in the Admin menu !!!
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Sat Oct 23, 2021 12:57 pm

Since I have obviously set something incorrect, I deleted the group and started fresh with a new group under 'Registered'. In the global configuration, I set 'Access Administration Interface' to 'Allow' and left everything inherited. At this point I expect the user to log in and see more than desired but I simply want her to be able to log in and see something.... She still arrives at a blank page with her info in the upper right-hand corner.

I inherited this site from a previous administrator. Is it possible that she configured it in such a way to be causing this issue? I've been looking around but nothing stands out.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Sat Oct 23, 2021 1:21 pm

Is it a commercial or hobby site?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Sat Oct 23, 2021 8:21 pm

It is for the members only site for a non-profit organization.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Sat Oct 23, 2021 10:08 pm

If you want to pm me a SA login then I can take a quick look
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Sun Oct 24, 2021 12:52 am

I tried to send you a PM but it says I’m too new here to do so. Are you able to initiate a PM with me?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Sun Oct 24, 2021 9:59 am

Emailed via forum email domain same as domain in my sig
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Tue Oct 26, 2021 1:31 pm

I sent an email on the 24th and wonder if you have received it.
Thank you!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Tue Oct 26, 2021 2:50 pm

Nope try again please
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

andlutz
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Oct 21, 2021 1:50 pm

Re: User Group Not Working for One Member

Post by andlutz » Tue Oct 26, 2021 3:00 pm

Confirming that is the email address I sent the message to and just resent. Thank you!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Tue Oct 26, 2021 4:02 pm

I had checked junk but hadn't seen it. Have replied. Also recommend you install Akeeba.

Addendum
The 'Special' (a Joomla default user group) is missing from Users >>> Groups
The user group that the Admin menu module is set to can not be found in Users >>> Groups
The Users >>> Groups has been modified at some stage but I can not see a Component installed which does that.

You have extplorer installed ... suggest you uninstall it.
You have a lot to update.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40488
Joined: Sat Apr 05, 2008 9:58 pm

Re: User Group Not Working for One Member

Post by Webdongle » Wed Oct 27, 2021 3:07 pm

Looked at the site
Admin is not in the 'Special' view/access level it' in 'Special -- DONT TOUCH!'
So in Users >>> Access Levels >>> 'Special -- DONT TOUCH!' ... I selected the new user group.
Works now

In the component's Options >>> Permissions ... you may wish to allow Create, Edit etc.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

jonemartin
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Nov 09, 2021 5:03 pm

Re: User Group Not Working for One Member

Post by jonemartin » Tue Nov 09, 2021 5:05 pm

Thank you


Post Reply

Return to “General Questions/New to Joomla! 3.x”