Having some difficulty setting up hyperlink in module Topic is solved

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
arlattimor
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Fri Jul 01, 2011 2:50 am

Having some difficulty setting up hyperlink in module

Post by arlattimor » Tue Aug 09, 2022 9:07 pm

I seem to be having some issues with setting up a hyperlink within a module. When I click the link I get a 404 error. Not sure what I'm doing wrong guys. Your guidance and assistance is always appreciated!Image
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 7976
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Having some difficulty setting up hyperlink in module

Post by AMurray » Tue Aug 09, 2022 9:43 pm

On viewing https://joshuawayofhope.org, confirming the bottom menu module with the three links under 'Activities', none of those links work and all lead to 404's.

A 404 error generally indicates 'file not found'. With Joomla, this could be caused by a few things, including but not limited to:
  • the page not existing,
  • unpublished article, or
  • no permissions to view it/them.
I would suggest to investigate further the 2nd and 3rd point above, could you advise the status (information on the Content tab), - article permissions (registered, public, guest etc.), and published state of the article?

Other routine things to try: (1) a different browser? (2) clear the joomla and browser caches?
Regards - A Murray

arlattimor
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Fri Jul 01, 2011 2:50 am

Re: Having some difficulty setting up hyperlink in module

Post by arlattimor » Tue Aug 09, 2022 10:11 pm

The article is published for some reason I keep getting this 404 and I dont know why its is making me so mad!!!!!
You do not have the required permissions to view the files attached to this post.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Having some difficulty setting up hyperlink in module

Post by sozzled » Tue Aug 09, 2022 10:17 pm

There are many problems with this website and they have nothing to do with whether articles are published or whether there is a module that has links to these articles.

Your articles do not have a menu item that points to them. Also, you have only partially enabled SEF URLs. I suggest that you read the documentation about how to enable SEF URLs.

Your articles exist; you do not have a menu item that allows you to access them. Anyway, here's the link to display the article about the raffle: https://joshuawayofhope.org//index.php? ... icle&id=15 (but the "click here" is broken).
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Having some difficulty setting up hyperlink in module

Post by sozzled » Thu Aug 11, 2022 7:14 am

The problem has been fixed.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

arlattimor
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Fri Jul 01, 2011 2:50 am

Re: Having some difficulty setting up hyperlink in module

Post by arlattimor » Thu Aug 11, 2022 4:16 pm

ok I Have resolved the 404 problem Image

How can i get the title of the article is centered and remove the word blog and a broken picture link. Where is global configuration to shut off a little guidance?

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Having some difficulty setting up hyperlink in module

Post by sozzled » Fri Aug 12, 2022 3:53 am

arlattimor wrote:
Thu Aug 11, 2022 4:16 pm
How can i get the title of the article is centered and remove the word blog and a broken picture link. Where is global configuration to shut off a little guidance?
Different problem: please start a new topic for it.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20518
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ Germany/ S'pore/Bogor/ North America
Contact:

Re: Having some difficulty setting up hyperlink in module

Post by leolam » Fri Aug 12, 2022 3:34 pm

sozzled wrote:
Thu Aug 11, 2022 7:14 am
The problem has been fixed.
How did you fix it?

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Having some difficulty setting up hyperlink in module

Post by sozzled » Fri Aug 12, 2022 4:27 pm

@leolam: I didn't fix this. The OP fixed this. I just observed the issue has been fixed, that's all. ;)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)


Post Reply

Return to “General Questions/New to Joomla! 3.x”