Is Joomla 3.10 compatible with MariaDB 10.4?

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
User avatar
sohopros
Joomla! Intern
Joomla! Intern
Posts: 90
Joined: Fri Jul 22, 2011 1:51 pm
Contact:

Is Joomla 3.10 compatible with MariaDB 10.4?

Post by sohopros » Thu Sep 29, 2022 12:35 am

We are upgrading our server database to MariaDB 10.4 soon and would like to know if there are any known issues with Joomla 3.x (our sites are currently on Joomla! 3.10.11), or if we are safe to move forward. Are there any known issues we should look for?

Thank you
SOHO Prospecting
https://www.sohoprospecting.com - Joomla Website development
Southern California - USA
Phone 866.644.7646

SharkyKZ
Joomla! Hero
Joomla! Hero
Posts: 2459
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: Is Joomla 3.10 compatible with MariaDB 10.4?

Post by SharkyKZ » Thu Sep 29, 2022 5:15 am

I have some sites running on MariaDB 10.3 through 10.5. Never had any issues related to it. It's a drop in replacement for MySQL. Although future versions could start deviating more. Haven't tried with 10.6 yet.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29484
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Is Joomla 3.10 compatible with MariaDB 10.4?

Post by Per Yngve Berg » Thu Sep 29, 2022 7:14 am

As of Mysql v5.7, zero dates are not any longer allowed. If you have zero date (0000-00-00), the have to be replaced by NULL.

Don't know what version of Mariadb it corresponding with.


Post Reply

Return to “General Questions/New to Joomla! 3.x”