Cannot upgrade to another version

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
talsadmin2
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Oct 04, 2023 8:09 am

Cannot upgrade to another version

Post by talsadmin2 » Wed Apr 03, 2024 5:47 pm

We are currently running our community website on Joomla version 3.10.2. This was created and launched about 2 years ago and everything works fine. However we are now being advised from everyone that we should upgrade to the latest version of Joomla otherwise the whole thing will fall over.

The problem is that the template is not compatible neither are most of the modules etc so it would require a complete rebuild of the website.

How urgent is this and how long before we can expect it to cause problems? Is there anything we can do to protect the site in the meantime?

Regards

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 31027
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Cannot upgrade to another version

Post by Per Yngve Berg » Wed Apr 03, 2024 6:36 pm

Upgrade to the latest 3.10.12. You are 10 versions behind.

There is a paid subscription where you can still get security updates for 3.x

Your largest problem will be that the site is not compatible with newer php versions and how long the host will let compatible php versions will be available on your server.

talsadmin2
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Oct 04, 2023 8:09 am

Re: Cannot upgrade to another version

Post by talsadmin2 » Sat Apr 13, 2024 11:42 am

Hi, can you let me know where I can find a link to the paid subscription option. My host is being quite cooperative regarding the php version so far. I think for the moment this is the only option available to us.

Regards

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9827
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Cannot upgrade to another version

Post by AMurray » Sat Apr 13, 2024 10:09 pm

Extended Long term support (for Joomla 3.10.x): https://elts.joomla.org/

Even so, Joomla 3.10 should run on PHP 8.0.x (even though it is EOL).

It's your extensions you need to be concerned with as well, more so given they are developed by individual developers. They may not be as active in keeping the extensions up to date.
Regards - A Murray
General Support Moderator


Post Reply

Return to “General Questions/New to Joomla! 3.x”