Why the forward slashes?

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Locked
User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 1:06 am

I just upgraded to Joomla 3.0 and installed a new template.

It seems to be working fine, but sometimes when I try to save an article, forward slashes are added, thus corrupting the output. See the screenshot below.

Image

I have tried with both with No Editor selected in the General Configuration and with Tiny Editor selected with the same results.

Can someone tell me what's going on?

Thanks

gsw
Last edited by greg waddell on Sat Nov 17, 2012 5:48 pm, edited 1 time in total.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40350
Joined: Sat Apr 05, 2008 9:58 pm

Re: Why the forward slashes?

Post by Webdongle » Sat Nov 17, 2012 2:14 am

That's a back slash
Is it on localhost or remote server ?

In the first line they are there so the " (quotation mark) is interpreted as a character not a command.

Not sure why there are so many in the other line.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the added slashes?

Post by greg waddell » Sat Nov 17, 2012 2:30 am

This is on a server.

This is the code I type into the article.

Code: Select all

<a href="http://dl.dropbox.com/u/2133/photos/site-under-construction.gif" target="_Blank"><img src="http://dl.dropbox.com/u/2133/photos/site-under-construction.gif" alt="Under Construction" /></a>
And this is what happens to it when I save it...

Code: Select all

<a href=\"http://dl.dropbox.com/u/2133/photos/site-under-construction.gif\" target=\"_Blank\"><img src=\"http://dl.dropbox.com/u/2133/photos/site-under-construction.gif\" alt=\"Under Construction\" /></a>
Very frustrating.

G
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40350
Joined: Sat Apr 05, 2008 9:58 pm

Re: Why the forward slashes?

Post by Webdongle » Sat Nov 17, 2012 2:43 am

What editor are you using ?
Is the page displaying correctly ?

Normally forward slashes are used when coding php rather than using in a Joomla Article. Are you using a 3rd party extension to insert the code ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 3:54 am

I have it set to "No Editor" in the global configuration and No it is not rendering correctly.

No... I am just typing the code into the joomla article editor area.

gsw
Last edited by greg waddell on Sat Nov 17, 2012 4:00 am, edited 1 time in total.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 3:56 am

Image
Last edited by greg waddell on Sat Nov 17, 2012 5:46 pm, edited 1 time in total.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40350
Joined: Sat Apr 05, 2008 9:58 pm

Re: Why the forward slashes?

Post by Webdongle » Sat Nov 17, 2012 4:12 am

set a standard Template as default for the front end ... then see what happens when you save the text ?

<a href="http://dl.dropbox.com/u/2133/photos/sit ... uction.gif" target="_Blank"><img src="http://dl.dropbox.com/u/2133/photos/sit ... uction.gif" alt="Under Construction" /></a>

Saves as that when I tested on my site.

Is your site localhost or remote host ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 4:49 am

The site is remote host, if I'm understanding your questions. It is hosted by SiteGround.

I made the Atomic template the default. Deleted previous code and pasted the correct code into the editor again with the same result.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 5:27 am

I also tried a different backend template... same result. It adds additional backslashes upon saving. I did find this article. Could I be experiencing something similar?

http://www.nonumber.nl/forum/AdvancedMo ... 0&start=10
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40350
Joined: Sat Apr 05, 2008 9:58 pm

Re: Why the forward slashes?

Post by Webdongle » Sat Nov 17, 2012 1:06 pm

You have AMM ?
You updated to AMM 3.4.4 ? Did that solve the problem ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 5:28 pm

I don't even know what AMM is. I was just citing that link because they talked about added backslashes popping up, which is what is happening to me.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 5:50 pm

One thing I noticed is that it adds the backslashes just before quotation marks. Could this have something to do with turning magic quotes off? How is that done?
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

kryps
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Mon Oct 16, 2006 8:19 pm

Re: Why the forward slashes?

Post by kryps » Sat Nov 17, 2012 5:56 pm

1) Apply the fix: http://forum.joomla.org/viewtopic.php?f=706&t=766329
2) Remove the slashes you already have.
3) Double check Joomla -> System -> System Information -> PHP Settings -> Magic Quotes is Off

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40350
Joined: Sat Apr 05, 2008 9:58 pm

Re: Why the forward slashes?

Post by Webdongle » Sat Nov 17, 2012 6:40 pm

greg waddell wrote:...Could this have something to do with turning magic quotes off?...
Doh .... now I remember :-[
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
greg waddell
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jan 22, 2009 5:04 am
Location: Mississippi
Contact:

Re: Why the forward slashes?

Post by greg waddell » Sat Nov 17, 2012 6:45 pm

kryps,

I tried the .htaccess file first and that made the administrator site unaccessible for some reason.
So, I deleted that and tried the php.ini file and that seems to have worked.

Thanks for the tip.
Greg Waddell
http://www.LeadStrategic.com
Twitter: DrGregWaddell
"It is an act of faith to assert that our thoughts have any relation to reality at all" (G. K. Chesterton).

equa24
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Aug 17, 2012 6:52 am
Contact:

Re: Why the forward slashes?

Post by equa24 » Fri Apr 12, 2013 7:41 am

I had the same problem, and those tips fix that, thank you very much guys...

dado023
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Sun Jan 14, 2007 1:25 pm

Re: Why the forward slashes?

Post by dado023 » Sat Jun 01, 2013 2:17 am

magic quotes off worked for me, tnx for this

hpsgty
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jun 01, 2013 1:29 am

Re: Why the forward slashes?

Post by hpsgty » Sat Jun 01, 2013 7:09 am

Normally forward slashes are used when coding php rather than using in a Joomla Article. Are you using a 3rd party extension to insert the code ?

rashaeg
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri May 31, 2013 9:45 pm

Re: Why the forward slashes?

Post by rashaeg » Sat Jun 01, 2013 10:15 pm

i have the same problem and no solution till now

grayz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Dec 12, 2006 8:37 pm

Re: Why the forward slashes?

Post by grayz » Mon Jul 15, 2013 8:11 pm

rashaeg,

You should set
magic_quotes_gpc OFF

It's set in php.ini, if you cannot edit php.ini ask the hosting company for support.
In my case I could not change it even through .htaccess (because of FastCGi and not custom php.ini file available), only the hoster can do something on their side.
www.justPHP.net - HACKS for Hot Property, Custom 404 Error Pages, Templates for Joomla etc.
Developing: www.zerno.org.ua


Locked

Return to “General Questions/New to Joomla! 3.x”