Error 404 After Creating a Contact Us Page

General questions relating to Joomla! 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
OOsorioR
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Jun 05, 2012 9:04 pm

Error 404 After Creating a Contact Us Page

Postby OOsorioR » Thu Jan 11, 2018 7:34 pm

I first created a Contact Us page in a test environment and was able to get a Contact Us page, this by following the instructions found here: https://www.siteground.com/tutorials/jo ... t-us-page/

I then went to my production site and went through the motions of creating the Contact Us page and got error 404.

I have no idea what could have happened. Appreciate any help.

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4240
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Error 404 After Creating a Contact Us Page

Postby sozzled » Thu Jan 11, 2018 7:53 pm

Are you using SEF URLs?

Do you have a file named .htaccess in the root folder of your Joomla website filesystem?

What version of Joomla are you currently using?
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

OOsorioR
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Jun 05, 2012 9:04 pm

Re: Error 404 After Creating a Contact Us Page

Postby OOsorioR » Thu Jan 11, 2018 11:36 pm

Search Engine Friendly is set to yes.

I do have a file named .htaccess in the root folder.

Joomla version: Joomla 3.8.3 Stable

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4240
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Error 404 After Creating a Contact Us Page

Postby sozzled » Fri Jan 12, 2018 12:39 am

What happens if you rename the file .htaccess to htaccess.old?
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33958
Joined: Sat Apr 05, 2008 9:58 pm

Re: Error 404 After Creating a Contact Us Page

Postby Webdongle » Fri Jan 12, 2018 1:07 am


OOsorioR
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Jun 05, 2012 9:04 pm

Re: Error 404 After Creating a Contact Us Page

Postby OOsorioR » Fri Jan 12, 2018 2:20 am

Still getting Error 404 and a new .htaccess was not created.

kjersos
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Fri Nov 10, 2017 4:56 am

Re: Error 404 After Creating a Contact Us Page

Postby kjersos » Fri Jan 12, 2018 3:06 am

Not sure this will be a solution if there is another problem that is not yet solved and the reason your contact form is not working. But if the purpose was to get a contact us form up and running I highly recommend Breezing Forms. There is a free version that will do everything that you probably need to do. I just set one up on my site. Just follow the intro video for documentation. Support has been helping me figure out a complicated use and have been absolutely amazing and helpful.

https://extensions.joomla.org/extension ... ing-forms/

Hope this helps!

OOsorioR
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Jun 05, 2012 9:04 pm

Re: Error 404 After Creating a Contact Us Page

Postby OOsorioR » Mon Jan 15, 2018 11:14 pm

Food for thought. Comparing my test site to the production site I find that the difference is that my production site has a Spanish language extension. This may possibly be the cause of the problem.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33958
Joined: Sat Apr 05, 2008 9:58 pm

Re: Error 404 After Creating a Contact Us Page

Postby Webdongle » Tue Jan 16, 2018 10:40 am

OOsorioR wrote:Still getting Error 404 and a new .htaccess was not created.

Still waiting for the fpa viewtopic.php?f=621&t=582860


Return to “General Questions/New to Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 19 guests