smart search never highlight words with accents

General questions relating to Joomla! 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
danioli18
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 09, 2018 8:41 am

smart search never highlight words with accents

Post by danioli18 » Fri Feb 09, 2018 9:41 am

Hi

I have an article with accented words (joomla 3.8.5). When I search the words in advanced search the final smart search result never highlight the words with accents.
I think joomla has lost the ability to highlight words with accents in smart search since version 3.4.8


Best regards

User avatar
Duckdown
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sat Jun 25, 2016 7:00 am

Re: smart search never highlight words with accents

Post by Duckdown » Tue Feb 20, 2018 11:03 pm

From the search box on the front page of our site (3.8.5) it does find 'ā', the only one I can think of that is in our site. The word I searched highlighted instances 'a' and "ā" so I need to do some editing. That only says I can do it in 3.8.5, not why you find it is not working. Sorry.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5327
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: smart search never highlight words with accents

Post by sozzled » Wed Feb 21, 2018 12:01 am

@danioli18: Search for "database collation and character encoding" on the forum. You're probably not using the right methods used from J! 3.5+; database collation and character encoding is important when using Joomla's search features.

UPDATE: Hmmm ... I could be wrong but I thought I read somewhere on GitHub that this might be a known issue. ??? I don't have time to research it now (and it may be a red herring); I might get back to this tomorrow depending on how much free time I have.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

danioli18
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 09, 2018 8:41 am

Re: smart search never highlight words with accents

Post by danioli18 » Sun Feb 25, 2018 5:51 pm

Hi, thanks for the answers.

Joomla has two types of search: "normal" search and smart search. In the "normal" search, the accented words are highlighted in the search result, although in the article where the words are, they are not highlighted. But what I am saying here is that accented words are not highlighted in the smart search result or in the article where the accented words are, something that joomla 3.4.8 does.

thanks in advance

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5327
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: smart search never highlight words with accents

Post by sozzled » Sun Feb 25, 2018 6:12 pm

I haven't made any further effort to investigate the claims that words containing accented characters are not properly highlighted in displaying the results from the smart search feature. As I indicated in my earlier reply, the facility to do this properly may depend on the database collation / character encoding mechanism that you're using in your website. (I could be wrong but I think we should confirm what you're using.)

The database collation / character encoding before J! 3.5 is different (or, by default, it was different) to later versions. What are you using?
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

danioli18
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 09, 2018 8:41 am

Re: smart search never highlight words with accents

Post by danioli18 » Mon Feb 26, 2018 10:05 am

Hi Sozzled thanks for your reply

I am using Joomla 3.8.5 with: Collation utf8mb4-unicode_ci

and Joomla 3.4.8 with: Collation utf8_general_ci


thanks


Post Reply

Return to “General Questions/New to Joomla! 3.x”