Edit Icon won't hide for blog layout

General questions relating to Joomla! 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 122
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Edit Icon won't hide for blog layout

Postby asearle1 » Tue Mar 06, 2018 9:26 am

Hallo Everyone,

I have a site where the global setting is that articles should not display the edit symbol. All settings are "Use Global".

However, I recently created a "Blog" layout menu item containing/displaying four pages but find that each of these pages displays the edit icon/symbol which is not what I want.

I have dug around in the article settings, the menu settings and the category settings adjusting "show icons" to hide and changing permissions and owners. But the edit icons are still displaying.

Indeed, I ran a test with an article which, when displaying full-page, did not have the edit icon but, when included in the blog-layout, did. This prompted me to assume that the key must lie in the Blog menu entry so I adjusted "Show icons" there (to both "user article settings" and to "hide") but this didn't change anything.

Can anyone help me here? There must be setting that I have missed. Or do Blog-layouts operate in a fundamental different way?

Many thanks for any tips that you can give me.

Yours,
Alan

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4971
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Edit Icon won't hide for blog layout

Postby sozzled » Tue Mar 06, 2018 9:31 am

I understand that this setting can be changed but I haven't looked into it too deeply. Perhaps this might help: viewtopic.php?f=706&t=858897
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 122
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Any other suggestions?

Postby asearle1 » Wed Mar 07, 2018 6:43 am

Hallo again everyone,

This is driving me completely crazy: Why is it that I can can comfortably set the edit icon to display or not display using the global setting or the article settings ... but for a blog-layout it doesn't seem to count?

With my blog-page the edit icon always appears for each of the four articles which I am displaying.

Has anyone got an idea on this?

Many thanks,
Alan

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4971
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Edit Icon won't hide for blog layout

Postby sozzled » Wed Mar 07, 2018 7:16 am

You can't remove the edit icon for superusers (at least, I haven't worked out how to do it).

You can remove the ability to edit articles from the frontend (i.e. remove the edit icon) for everyone else. Does that help you?
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 122
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Re: Edit Icon won't hide for blog layout

Postby asearle1 » Wed Mar 07, 2018 7:25 am

You might be right that that is the problem: I am logged on as a super-user.

The strange thing is that the edit icon disappears (for the very same articles) when they are not included in the blog layout.

I would like to try it with a non-superuser but the problem is that the site is currently off-line, so I can only view it as superuser.

I will continue to investigate and will give feedback on what I find out.

Many thanks for your help/tips/time.

Yours gratefully,
Alan

User avatar
Jaydot
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 168
Joined: Sun Jun 04, 2017 12:11 pm
Location: The Netherlands
Contact:

Re: Edit Icon won't hide for blog layout

Postby Jaydot » Wed Mar 07, 2018 9:45 am

asearle1 wrote:...the site is currently off-line...
That's probably the missing clue...
Switch the site online for a sec and check again, the edit symbol should be gone.

While the site is offline, you are essentially doing a front-end log-in to view it. As super user, you have permission to edit articles, so Joomla will dutifully show you the edit icon when you log in to the front end. You can hide the icon by changing the permissions, but you don't want to do that for the super user (in fact I'm not sure it's possible switch off editing permission for super users).
The fact that an opinion is widely held is no evidence whatsoever that it is not utterly absurd.
Personal website: https://jaydot.nl


Return to “General Questions/New to Joomla! 3.x”

Who is online

Users browsing this forum: AMurray, bennate, CDXXonline, fightback ninja, sozzled and 9 guests