Update to J3.9 didn't install privacy tool or user actions log

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
MarketingPDX
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Mar 08, 2012 8:48 pm
Location: Portland, OR
Contact:

Update to J3.9 didn't install privacy tool or user actions log

Post by MarketingPDX » Tue Oct 30, 2018 9:26 pm

Weird... I ran about 35 updates today. All went fine, except for one site, which updated to 3.9, but did not apparemtly install the privacy area or the user actions log. Both were missing from the User dropdown upon initial install. I later noticed that, if I went to "Discover", they were there. So, I discovered them & they're ok now. Just wanted to mention that, in case this happens to others. Could be a fluke thing, though...
Last edited by imanickam on Wed Oct 31, 2018 5:36 am, edited 1 time in total.
Reason: Moved the topic from the forum General Questions/New to Joomla! 3.x to the forum Migrating/Upgrading to Joomla! 3.x

User avatar
Slackervaara
Joomla! Ace
Joomla! Ace
Posts: 1003
Joined: Sat Aug 13, 2011 6:27 am

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by Slackervaara » Tue Oct 30, 2018 9:49 pm

You have to enable the plugin for user actions log for it to work.

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2071
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by JAVesey » Tue Oct 30, 2018 10:57 pm

Slackervaara wrote:
Tue Oct 30, 2018 9:49 pm
You have to enable the plugin for user actions log for it to work.
This isn't what the OP said; they weren't actually installed and were found using the "discover" procedure. Not the same as having to enable the plugin (this and others), which is the expected behaviour.

All I can say is that my two site updates went ahead without error; I didn't have to use the "discover" process.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.13 and PHP7.3.x

urbanj
Joomla! Intern
Joomla! Intern
Posts: 68
Joined: Fri Sep 25, 2009 1:39 pm

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by urbanj » Wed Oct 31, 2018 3:45 pm

Ok try

go to extensions> manage> database> click fix database
go to extensions> manage> discover

and you should see all the privacy suite stuff there so tick the check boxes and click install

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2071
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by JAVesey » Wed Oct 31, 2018 5:28 pm

urbanj wrote:
Wed Oct 31, 2018 3:45 pm
Ok try

go to extensions> manage> database> click fix database
go to extensions> manage> discover

and you should see all the privacy suite stuff there so tick the check boxes and click install
The OP said "discover" had been done and this allowed the installation to go ahead, so no need for this advice ;)

The OP was reporting what had happened and, effectively, asking:
1. anyone else?
2. ideas as to why?

The OP doesn't need further advice on installing v3.9.0 as this has been achieved.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.13 and PHP7.3.x

urbanj
Joomla! Intern
Joomla! Intern
Posts: 68
Joined: Fri Sep 25, 2009 1:39 pm

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by urbanj » Wed Oct 31, 2018 8:06 pm

My reading skills let me down there lol. It has been reported a few times on the joomla FB group but no one has any idea why

MarketingPDX
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Mar 08, 2012 8:48 pm
Location: Portland, OR
Contact:

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by MarketingPDX » Fri Nov 02, 2018 12:22 am

... Yeah, I wasn't really asking any questions. Just sharing the experience as a courtesy, in case anyone out there did an update and couldn't find the new features. This only happened to me on one of many dozens of Joomla updates. So, perhaps it was just a rare fluke.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37533
Joined: Sat Apr 05, 2008 9:58 pm

Re: Update to J3.9 didn't install privacy tool or user actions log

Post by Webdongle » Fri Nov 02, 2018 9:19 am

Just as belt and bracers ... Components >>>> Joomla update ... check for updates ... Reinstall Joomla core files.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”