XML Support Required

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum. Note: Users creating new sites can use either version 2.5 or 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
edroberts1943
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Mon Jan 21, 2013 1:59 am

XML Support Required

Postby edroberts1943 » Sun Feb 12, 2017 3:01 am

Re-installing a saved Joomla site on a newly loaded ubuntu system, the Akeeba Kickstart pre-analysis indicated that XML Support is required but missing from my system. I could find no place in the Kickstart documentation or on this forum to explain what XML Support is or how to install it.

After a lot of Google searches, I finally determined that XML support is an optional feature of PHP.

On ubuntu, all I needed to do was:

Code: Select all

sudo apt-get install php-xml
and then restart the apache2 service.

Hopefully, this post will provide others a more direct path to the solution.
Last edited by imanickam on Sun Feb 12, 2017 4:34 am, edited 1 time in total.
Reason: Marked with Information icon

BMCLLC
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Mon Sep 29, 2014 2:01 am

Re: XML Support Required

Postby BMCLLC » Wed Feb 15, 2017 7:51 pm

Hi,
I have performed an Akeeba Backup for my site as well. I get an XML setup file missing error message every time I try to update the Joomla! I am currently at J!v3.6.2. I attempt updating from the Patch Package as well and get the same error message.

I am not on the ubuntu platform but the Debian platform instead. I know I am on Apache, but not sure which version. On MySQL because of shared hosting.

I have been directed to look in the PHP.ini file, but find nothing comparable to what is described here:
Code: Select all
sudo apt-get install php-xml

Could I have some help restoring my website to update functionality?

Thanks,

jigneshaakoliya
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Mon Dec 12, 2016 11:23 am
Contact:

Re: XML Support Required

Postby jigneshaakoliya » Fri Feb 17, 2017 11:54 am

BMCLLC wrote:Hi,
I have performed an Akeeba Backup for my site as well. I get an XML setup file missing error message every time I try to update the Joomla! I am currently at J!v3.6.2. I attempt updating from the Patch Package as well and get the same error message.

I am not on the ubuntu platform but the Debian platform instead. I know I am on Apache, but not sure which version. On MySQL because of shared hosting.

I have been directed to look in the PHP.ini file, but find nothing comparable to what is described here:
Code: Select all
sudo apt-get install php-xml

Could I have some help restoring my website to update functionality?

Thanks,

Hi,
please check if you have correct permissions on the folders, correct file ownership?

Thanks
Jignesh Aakoliya
PHP Developer
http://www.ifourtechnolab.com

edroberts1943
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Mon Jan 21, 2013 1:59 am

Re: XML Support Required

Postby edroberts1943 » Sat Feb 18, 2017 2:16 am

I may be misreading what you said, but the code is a command to install php-xml support and would not be found in the php.ini file.

It sounds that you are on a commercial hosting service like JustHost. It that is the case, it should be the hosting service provider's responsibility to assure that PHP and any of its extensions required to support Joomla! are installed. You should not be expected to install php extensions. I am assuming that the hosting service provided Joomla! as well. If possible, I would suggest you contact your provider's service and carefully explain the problem. I have experience with only one provider, JustHost,and I could be wrong; but, that is where I would go first with JustHost. Good Luck.

BMCLLC
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Mon Sep 29, 2014 2:01 am

Re: XML Support Required

Postby BMCLLC » Sat Feb 18, 2017 3:19 am

I presented the issue as a bug to Nicholas K. Dionysopoulos, Director at Akeeba Ltd.
His tip was that the issue is not with Akeeba, but with the Joomla Installer having issues.

Solution:
Perform a manual Joomla! update by uploading by FTP the extracted Stable-Full-Package contents as I did, or likely as an alternative the Stable-Patch-Package, overwriting the directories in the root Joomla directory. All along having the Discover in the Admin browser ready to install the uploaded contents.
This brought me to the updated Joomla version of either my site or my Admin.
Of course I had performed a backup of the site and downloaded the site-mydomain.com-20170217-xxxxx.jpa file to my HDD prior to the FTP upload.


Return to “Installation Joomla! 3.x”

Who is online

Users browsing this forum: MichaelFelt and 4 guests