A real puzzling website transfer that failed

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum. Note: Users creating new sites can use either version 2.5 or 3.x. Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
FuzMic
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 194
Joined: Mon Oct 08, 2012 4:45 am

A real puzzling website transfer that failed

Postby FuzMic » Sat Nov 18, 2017 6:32 am

A real puzzling website transfer that failed


I have a working Joomla website in a pc wampserver localhost. It is running Jm3.8.2 with Helix 3 v2.4 as template and a sp pagebuilder v3; it had full access both front & back. Everything here looks perfect with these latest updates.

Then I backup all the folders as zip and transfer to another pc local host. With phpadmin I export the related mysql.datatbase from the 1st pc and import into 2nd.

But when I access the 2nd pc website, it flag the following error
Fatal error: Can't use function return value in write context in /localhost.website/components/com_sppagebuilder/helpers/helper.php on line 34

Of course this is caused by sp pagebuilder as all pages created the sp pagebuilder suffers the same fate.

I can access the Joomla backend in the 2nd pc, and change the home page to an ordinary article, then website have no error on opening but the moment I try to open a menu with a sp pagebuilder, the same error occur.


The PUZZLE is
Why the website works on the 1st pc, but an exact duplicate in the 2nd pc, the fatal error occur. I have done this way of transfer many times without a single error. This is my first encounter.

Any pointers guys.
Last edited by toivo on Sat Nov 18, 2017 8:42 am, edited 1 time in total.
Reason: mod note: moved to 3.x Installation

User avatar
effrit
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 175
Joined: Sun Nov 12, 2017 2:21 pm
Location: middle of Russia
Contact:

Re: A real puzzling website transfer that failed

Postby effrit » Sat Nov 18, 2017 7:51 am

hello. it may be php version difference.
try update it to 5.6 or 7.x if older.

FuzMic
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 194
Joined: Mon Oct 08, 2012 4:45 am

Re: A real puzzling website transfer that failed

Postby FuzMic » Sat Nov 18, 2017 11:14 am

Effrit you may be right as my localhost is using 5.6.25 my host is using 5.4.45 and is recommending host to update to 5.6 & higher, i will try that direction. Thanks.

PS at cpanel set to php 5.6 then make sure configuration.php don't use cachelite but file, it all ok

:D :D

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18466
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: A real puzzling website transfer that failed

Postby leolam » Mon Nov 20, 2017 6:17 am

You should update your PHP version rto PHP 7-branch. Joomla works very well with latest PHP 7.1.x

(https://downloads.joomla.org/technical-requirements)

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team


Return to “Installation Joomla! 3.x”

Who is online

Users browsing this forum: Rickardo and 3 guests