Can't install Joomla 3.9.26 Topic is solved

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Can't install Joomla 3.9.26

Post by dagroupinc » Wed Apr 21, 2021 9:44 pm

I've tried (clean) installing Joomla 3.9.26 two different ways and can't get to the Joomla installation screen.

Manual Installation:
Upload zip file and extract using cPanel, create new database, etc.
Error Message:
Error: Call to undefined function Joomla\CMS\Language\simplexml_load_file(): Call to undefined function simplexml_load_file()

Automated Installation by Hosting Provider:
Softoculous Automated Installation
Error Message:
Warning: session_start(): Failed to read session data: user (path: /tmp) in /home2/dagroup/public_html/new4/libraries/joomla/session/handler/native.php on line 260
Error: Failed to start application: Failed to start the session

Does anyone have a solution?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13453
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Can't install Joomla 3.9.26

Post by toivo » Thu Apr 22, 2021 1:55 am

Check the PHP configuration from the cPanel provided by your host. Normally the following PHP extensions are enabled: libxml, xml, SimpleXML, xmlreader, xmlwriter. Once you enable them, the error message should disappear.

About the Softaculours Automated Installation: experts in this forum usually do not recommend automated installations and updates because of issues that may pop up later. In your case, it looks like something in the database connection details is incorrect.
Toivo Talikka, Global Moderator

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Thu Apr 22, 2021 1:21 pm

Toivo—all PHP extensions are enabled.

As I stated above we never use the auto-install function—we always manually install Joomla. The only reason we auto-installed this time was to help us narrow down the issue. If we can't manually install Joomla and it won't install using Softoculous—then we're getting closer to identifying the problem.

The configuration.php file points to the correct database, correct password, ....

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Thu Apr 22, 2021 3:51 pm

toivo—the PHP extensions you refer to are enabled: libxml, xml, SimpleXML, xmlreader, xmlwriter.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13453
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Can't install Joomla 3.9.26

Post by toivo » Fri Apr 23, 2021 9:26 am

dagroupinc wrote:
Wed Apr 21, 2021 9:44 pm
Error Message:
Error: Call to undefined function Joomla\CMS\Language\simplexml_load_file(): Call to undefined function simplexml_load_file()
dagroupinc wrote:
Thu Apr 22, 2021 3:51 pm
toivo—the PHP extensions you refer to are enabled: libxml, xml, SimpleXML, xmlreader, xmlwriter.
Are you sure that you are looking at the right version of PHP? The function simplexml_load_file() is a native PHP function included in the SimpleXML extension. If the function simplexml_load_file() is not found, it means that PHP has not been configured correctly with the SimpleXML extension.

Ref. https://www.php.net/manual/en/function. ... d-file.php

Double-check the PHP version that Joomla is using. You can also post the results from the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs so that our volunteer experts can review the configuration.
Toivo Talikka, Global Moderator

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 1:37 pm

Yes, I did check that right away and when I run phpinfo.php it says v7.3.27. However, I also see the following:

Configuration File (php.ini) Path: /opt/cpanel/ea-php73/root/etc
Loaded Configuration File: /opt/php70/lib/php.ini

The hosting provider has been looking into this for the past 2 days :-((

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13453
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Can't install Joomla 3.9.26

Post by toivo » Fri Apr 23, 2021 1:55 pm

If the file phpinfo.php was run from the main Joomla folder, both phpinfo.php and Joomla are using the loaded configuration file for PHP 7.0. If you were to run the FPA script, the FPA results would confirm that.

Does the main Joomla folder have an .htaccess file which forces Joomla - and phpinfo.php - to use PHP 7.0?
Toivo Talikka, Global Moderator

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 2:04 pm

I'll try FPA but yes PHP is set to 73 in the htaccess file

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 2:16 pm

Image
You do not have the required permissions to view the files attached to this post.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13453
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Can't install Joomla 3.9.26

Post by toivo » Fri Apr 23, 2021 2:24 pm

The messages in red at the bottom of the above image include several errors in PHP 7.0.

The earlier listing from phpinfo() also confirmed that the php.ini file was loaded from the php70 folder. Is it possible that the .htaccess file in the main Joomla folder has for example a directive or a syntax error which prevents PHP 7.3 from getting loaded?
Toivo Talikka, Global Moderator

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39824
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't install Joomla 3.9.26

Post by Webdongle » Fri Apr 23, 2021 2:48 pm

Or perhaps a .htaccess file above Joomla root. Or a php.ini file in Joomla root?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 3:07 pm

Yes, I found that the php(dot)ini file is referencing php70 but changing that to 73 doesn't affect any change. It may be that the path is wrong or the file doesn't =exist. I'm assuming that something isn't configured on the server correctly.

Still can't get to the Joomla install interface—2 days and counting

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39824
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't install Joomla 3.9.26

Post by Webdongle » Fri Apr 23, 2021 4:01 pm

dagroupinc wrote:
Fri Apr 23, 2021 3:07 pm
Yes, I found that the php(dot)ini file is referencing php70 but changing that to 73 doesn't affect any change. ...
Delete it or rename to php70.bak. Keep it like that until you find the problem. Also please the results of the fpa
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 4:15 pm

Not sure I have access to that. The only reference I can find is in the htaccess file:

/opt/php70/lib

I've tried changing that to 73 but that didn't help

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39824
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't install Joomla 3.9.26

Post by Webdongle » Fri Apr 23, 2021 5:41 pm

delete it or comment it out
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
dagroupinc
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Apr 06, 2010 6:09 pm

Re: Can't install Joomla 3.9.26

Post by dagroupinc » Fri Apr 23, 2021 6:44 pm

The hosting provider FINALLY updated /opt/php70/lib to 74 and the universe is now back in alignment.

Thank you to everyone for pointing us in the right direction!


Post Reply

Return to “Installation Joomla! 3.x”