Subdomain install fails - can't configure database

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
gfliger51
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Feb 27, 2021 12:55 pm

Subdomain install fails - can't configure database

Post by gfliger51 » Sat Jul 02, 2022 2:09 pm

I've recently created a subdomain off my main site to setup a testing site. I've created a database and a user. I downloaded the 3.10.10 installation package, unpacked it and uploaded it to the subdomain folder. I've accessed the installation files through it's URL and attempt the configuration. At Step 2 (Database Configuration) I enter in the username, password, database name, and table name. When I click on the NEXT button to continue I get the following error: JINVALID TOKEN NOTICE. From this point I'm stuck. I can't continue. I've gone through all the steps (including deleting the database and recreating it) repeatedly to no avail. I can't get past the database configuration screen. Below is a dump from the FPA script I ran. Maybe it will help:

Any insight would be greatly appreciated as this is beginning to get very frustrating.

Forum Post Assistant (v1.6.5) : 2-Jul-2022 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.10.10-Stable (Daraja) 18-June-2022
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Not Found

Host Configuration :: OS: Linux | OS Version: 3.10.0-1160.66.1.el7.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br | System TMP Writable: Yes | Free Disk Space : 94.52 GiB |

PHP Configuration :: Version: 7.4.30 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 0 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: No | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Database Credentials incomplete or not available Nothing to display.
Missing credentials detected: Connection Type missing | Database Name missing |MySQL Host missing | Table Prefix missing | Database Username missing | Database Password missing |User Privileges : Unknown
Detailed Environment :: wrote:PHP Extensions :: Core (7.4.30) | date (7.4.30) | libxml (7.4.30) | openssl (7.4.30) | pcre (7.4.30) | zlib (7.4.30) | filter (7.4.30) | hash (7.4.30) | pcntl (7.4.30) | readline (7.4.30) | Reflection (7.4.30) | SPL (7.4.30) | session (7.4.30) | standard (7.4.30) | cgi-fcgi (7.4.30) | bcmath (7.4.30) | calendar (7.4.30) | ctype (7.4.30) | curl (7.4.30) | dom (20031129) | ftp (7.4.30) | gd (7.4.30) | iconv (7.4.30) | imap (7.4.30) | json (7.4.30) | mbstring (7.4.30) | mysqlnd (mysqlnd 7.4.30) | PDO (7.4.30) | Phar (7.4.30) | posix (7.4.30) | SimpleXML (7.4.30) | sockets (7.4.30) | sqlite3 (7.4.30) | tokenizer (7.4.30) | xml (7.4.30) | xmlwriter (7.4.30) | xsl (7.4.30) | mysqli (7.4.30) | pdo_mysql (7.4.30) | pdo_sqlite (7.4.30) | xmlreader (7.4.30) | Zend Engine (3.4.0) |
Potential Missing Extensions :: zip |

Switch User Environment :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (---) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: Site ::
Core :: com_mailto (3.0.0) ? | com_wrapper (3.0.0) ? |
3rd Party::

Components :: Admin ::
Core :: com_actionlogs (3.9.0) ? | com_admin (3.0.0) ? | com_ajax (3.2.0) ? | com_associations (3.7.0) ? | com_banners (3.0.0) ? | com_cache (3.0.0) ? | com_categories (3.0.0) ? | com_checkin (3.0.0) ? | com_config (3.0.0) ? | com_content (3.0.0) ? | com_contenthistory (3.2.0) ? | com_cpanel (3.0.0) ? | com_fields (3.7.0) ? | com_finder (3.0.0) ? | com_installer (3.0.0) ? | com_joomlaupdate (3.10.1) ? | com_languages (3.0.0) ? | com_login (3.0.0) ? | com_media (3.0.0) ? | com_menus (3.0.0) ? | com_messages (3.0.0) ? | com_modules (3.0.0) ? | com_newsfeeds (3.0.0) ? | com_plugins (3.0.0) ? | com_postinstall (3.2.0) ? | com_privacy (3.9.0) ? | com_redirect (3.0.0) ? | com_search (3.0.0) ? | com_tags (3.1.0) ? | com_templates (3.0.0) ? | com_users (3.0.0) ? |
3rd Party::

Modules :: Site ::
Core :: mod_articles_archive (3.0.0) ? | mod_articles_categories (3.0.0) ? | mod_articles_category (3.0.0) ? | mod_articles_latest (3.0.0) ? | mod_articles_news (3.0.0) ? | mod_articles_popular (3.0.0) ? | mod_banners (3.0.0) ? | mod_breadcrumbs (3.0.0) ? | mod_custom (3.0.0) ? | mod_feed (3.0.0) ? | mod_finder (3.0.0) ? | mod_footer (3.0.0) ? | mod_languages (3.5.0) ? | mod_login (3.0.0) ? | mod_menu (3.0.0) ? | mod_random_image (3.0.0) ? | mod_related_items (3.0.0) ? | mod_search (3.0.0) ? | mod_stats (3.0.0) ? | mod_syndicate (3.0.0) ? | mod_tags_popular (3.1.0) ? | mod_tags_similar (3.1.0) ? | mod_users_latest (3.0.0) ? | mod_whosonline (3.0.0) ? | mod_wrapper (3.0.0) ? |
3rd Party::

Modules :: Admin ::
Core :: mod_custom (3.0.0) ? | mod_feed (3.0.0) ? | mod_latest (3.0.0) ? | mod_latestactions (3.9.0) ? | mod_logged (3.0.0) ? | mod_login (3.0.0) ? | mod_menu (3.0.0) ? | mod_multilangstatus (3.0.0) ? | mod_popular (3.0.0) ? | mod_privacy_dashboard (3.9.0) ? | mod_quickicon (3.0.0) ? | mod_sampledata (3.8.0) ? | mod_stats_admin (3.0.0) ? | mod_status (3.0.0) ? | mod_submenu (3.0.0) ? | mod_title (3.0.0) ? | mod_toolbar (3.0.0) ? | mod_version (3.0.0) ? |
3rd Party::

Libraries ::
Core ::
3rd Party::

Plugins ::
Core :: PLG_ACTIONLOG_JOOMLA (3.9.0) ? | plg_authentication_cookie (3.0.0) ? | plg_authentication_gmail (3.0.0) ? | plg_authentication_joomla (3.0.0) ? | plg_authentication_ldap (3.0.0) ? | plg_captcha_recaptcha (3.4.0) ? | plg_captcha_recaptcha_invisible (3.8) ? | plg_content_confirmconsent (3.9.0) ? | plg_content_emailcloak (3.0.0) ? | plg_content_fields (3.7.0) ? | plg_content_finder (3.0.0) ? | plg_content_joomla (3.0.0) ? | plg_content_loadmodule (3.0.0) ? | plg_content_pagebreak (3.0.0) ? | plg_content_pagenavigation (3.0.0) ? | plg_content_vote (3.0.0) ? | plg_editors-xtd_article (3.0.0) ? | plg_editors-xtd_fields (3.7.0) ? | plg_editors-xtd_image (3.0.0) ? | plg_editors-xtd_menu (3.7.0) ? | plg_editors-xtd_module (3.5.0) ? | plg_editors-xtd_pagebreak (3.0.0) ? | plg_editors-xtd_readmore (3.0.0) ? | plg_extension_joomla (3.0.0) ? | plg_fields_calendar (3.7.0) ? | plg_fields_checkboxes (3.7.0) ? | plg_fields_color (3.7.0) ? | plg_fields_editor (3.7.0) ? | plg_fields_imagelist (3.7.0) ? | plg_fields_integer (3.7.0) ? | plg_fields_list (3.7.0) ? | plg_fields_media (3.7.0) ? | plg_fields_radio (3.7.0) ? | plg_fields_repeatable (3.9.0) ? | plg_fields_sql (3.7.0) ? | plg_fields_text (3.7.0) ? | plg_fields_textarea (3.7.0) ? | plg_fields_url (3.7.0) ? | plg_fields_user (3.7.0) ? | plg_fields_usergrouplist (3.7.0) ? | plg_finder_categories (3.0.0) ? | plg_finder_contacts (3.0.0) ? | plg_finder_content (3.0.0) ? | plg_finder_newsfeeds (3.0.0) ? | plg_finder_tags (3.0.0) ? | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) ? | plg_installer_packageinstaller (3.6.0) ? | PLG_INSTALLER_URLINSTALLER (3.6.0) ? | plg_privacy_actionlogs (3.9.0) ? | plg_privacy_consents (3.9.0) ? | plg_privacy_content (3.9.0) ? | plg_privacy_message (3.9.0) ? | plg_privacy_user (3.9.0) ? | plg_quickicon_eos310 (3.10.0) ? | plg_quickicon_extensionupdate (3.0.0) ? | plg_quickicon_joomlaupdate (3.0.0) ? | plg_quickicon_phpversioncheck (3.7.0) ? | plg_quickicon_privacycheck (3.9.0) ? | plg_search_categories (3.0.0) ? | plg_search_contacts (3.0.0) ? | plg_search_content (3.0.0) ? | plg_search_newsfeeds (3.0.0) ? | plg_search_tags (3.0.0) ? | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_cache (3.0.0) ? | plg_system_debug (3.0.0) ? | plg_system_fields (3.7.0) ? | plg_system_highlight (3.0.0) ? | plg_system_languagecode (3.0.0) ? | plg_system_languagefilter (3.0.0) ? | plg_system_log (3.0.0) ? | plg_system_logout (3.0.0) ? | plg_system_logrotation (3.9.0) ? | plg_system_p3p (3.0.0) ? | plg_system_privacyconsent (3.9.0) ? | plg_system_redirect (3.0.0) ? | plg_system_remember (3.0.0) ? | plg_system_sef (3.0.0) ? | plg_system_sessiongc (3.8.6) ? | plg_system_stats (3.5.0) ? | plg_system_updatenotification (3.5.0) ? | plg_twofactorauth_totp (3.2.0) ? | plg_twofactorauth_yubikey (3.2.0) ? | plg_user_contactcreator (3.0.0) ? | plg_user_joomla (3.0.0) ? | plg_user_profile (3.0.0) ? | plg_user_terms (3.9.0) ? |
3rd Party:: plg_editors_codemirror (5.60.0) ? | plg_editors_tinymce (4.5.12) ? |
Templates Discovered :: wrote:Templates :: Site :: beez3 (3.1.0) ? | protostar (1.0) ? |
Templates :: Admin :: hathor (3.0.0) ? | isis (1.0) ? |

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41701
Joined: Sat Apr 05, 2008 9:58 pm

Re: Subdomain install fails - can't configure database

Post by Webdongle » Sat Jul 02, 2022 2:49 pm

Create a file called test.php and paste the following (substitute "localhost", "database", "user" and "password" with yours)

Code: Select all

<?php
$servername   = "localhost";
$database = "database";
$username = "user";
$password = "password";

// Create connection
$conn = new mysqli($servername, $username, $password, $database);
// Check connection
if ($conn->connect_error) {
   die("Connection failed: " . $conn->connect_error);
}
  echo "Connected successfully";
?>

Then point your browser at subdomain.site.com/test.php
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

gfliger51
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Feb 27, 2021 12:55 pm

Re: Subdomain install fails - can't configure database

Post by gfliger51 » Mon Jul 04, 2022 11:32 am

Got it up and running. Stupid mistake on my part, but that's because the instructions, while simple, are not very intuitive and I'm a novice at this.

The issue with the database configuration was the Table Name entry. Instructions and appearances would make it seem that you need to input more than required. The field explains that you can input your own prefix if you want or accept the randomly generated one by the system. The last mention is that the prefix must end with an underscore. At that point the instructions end. The fields above that for the username and database name all require an entry that ends with an underscore plus the name needed. In the Table Name Prefix field you're presented with an entry field that can accept around 20 or so characters AFTER the prefix. Makes you think that you need to enter in a table name after the prefix entry since the field is so long. I was assuming that's what I had to do so was defining a table name and entering it after the underscore in the table prefix. THAT was the problem. I stumbled upon the solution when I accidentally clicked on the next button and hadn't added anything to the end of the table prefix on my last attempt. I was then moved on to the third screen where I could finish the setup and start the installation. All is working now.

Someone might mention this to the Joomla developers. If the field only requires 5 characters ending with an underscore, make the field just long enough to accept the required characters and no more. And if they don't do that, mention in the field instructions that NOTHING NEEDS TO BE ENTERED AFTER THE UNDERSCORE! I'm sure this will result in alleviating any grief a future Joomla installer might run into.

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4749
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Subdomain install fails - can't configure database

Post by gws » Mon Jul 04, 2022 12:06 pm

Glad you fixed it. The FPA reports Allow url fopen: No this must be yes or you will have problems installing some extensions/ updates. Usually configurable in the php options on the server.

gfliger51
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Feb 27, 2021 12:55 pm

Re: Subdomain install fails - can't configure database

Post by gfliger51 » Mon Jul 04, 2022 12:21 pm

Hmm. Thanks for the heads-up on the url fopen setting. Not sure where I have to go to correct this. I don't see where I would change this in cPanel so I assume I have to run WHM to find the area to make the change?

gfliger51
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Feb 27, 2021 12:55 pm

Re: Subdomain install fails - can't configure database

Post by gfliger51 » Mon Jul 04, 2022 12:30 pm

Nevermind. I found it. Had to go into WHM to make the change.


Post Reply

Return to “Installation Joomla! 3.x”