Transferred site loads all pages except home page. DirectoryIndex doesn't help

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
maestroc
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sun Dec 04, 2005 7:27 pm
Contact:

Transferred site loads all pages except home page. DirectoryIndex doesn't help

Post by maestroc » Wed Aug 03, 2022 6:59 pm

I'm confused and sure this is a simple fix but I am just not seeing it...

I just transferred a working, fully functional site from one server to another using the cpanel account transfer tool. I changed the nameserver info to point to the right place and all seems to have propagated correctly. Old server used PHP8 but the new one for now only has 7.4 (if that matters somehow).

The problem is that on the new server when you go to https://anglicantarime.org you get a download of the raw, unrendered index.php file. If I add https://anglicantarime.org/index.php to the end of the URL then it loads fine. If I then click on any of the menu items the links seem to work fine as well except for the Home menu item which again, does the partial file download.

I have dozens of other Joomla sites on this new server and do not have this issue on any of them.

I tried adding DirectoryIndex index.php to the htaccess file but it doesn't fix it.
Also tried clearing cache, setting the live site variable, and even tried it without the htaccess file enabled. Same thing happens in all cases.
There is no index.html in the root folder to conflict with things.

What am I missing here?

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 7840
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Transferred site loads all pages except home page. DirectoryIndex doesn't help

Post by AMurray » Wed Aug 03, 2022 9:38 pm

I'm not seeing the problem.

https://anglicantarime.org/ loads the home page and https://anglicantarime.org/index.php does too.

Maybe it was a temporary issue with the update of the DNS and the propagation process or perhaps was an issue with the method you used to transfer the site.

If needed in future, I would investigate using Akeeba Backup and Kickstart. (Akeeba Backup would be essential anyway for site administration and routine backups - don't rely solely on the web host or the cPanel functions for that).
Regards - A Murray

maestroc
Joomla! Explorer
Joomla! Explorer
Posts: 417
Joined: Sun Dec 04, 2005 7:27 pm
Contact:

Re: Transferred site loads all pages except home page. DirectoryIndex doesn't help

Post by maestroc » Wed Aug 03, 2022 9:48 pm

After seeing your comment I tried it on my wife's computer and it loads there as well. Didn't think to flush DNS or anything so that is probably it. Normally I do use akeeba when dealing with just a website but moving a whole account including all the email requires the cpanel method. Thank you for the input!

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 7840
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Transferred site loads all pages except home page. DirectoryIndex doesn't help

Post by AMurray » Wed Aug 03, 2022 10:09 pm

moving the website is one thing, moving an entire 'hosting account' is another matter entirely. I thought you were simply using the the cPanel database backup/restore tools.
Regards - A Murray


Post Reply

Return to “Installation Joomla! 3.x”