What PHP 8.0 extensions have to be included for J! websites to operate? Topic is solved

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
mitokat
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Tue Apr 15, 2008 7:24 pm

What PHP 8.0 extensions have to be included for J! websites to operate?

Post by mitokat » Wed Sep 14, 2022 6:46 pm

We are setting up a new server running php 8.0 for a few Joomla 3.0 sites which will then be upgraded in the next few months to 4.0. Having lots of issues with the copied over sites, as in they do not work. So this brings me to my question, what php extensions have to be added to the regular 8.0 installation for the sites to run. The copied sites are showing an error and I even tried a fresh install of the last versions of 3.0 and 4.0 but nothing worked. Can anyone point me in the right direction?

Thanks in advance
Last edited by imanickam on Wed Sep 14, 2022 10:01 pm, edited 1 time in total.
Reason: Modified the Subject to reflect the content of the post

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29293
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: php8.0 (Issue Resolved)

Post by Per Yngve Berg » Wed Sep 14, 2022 7:15 pm

J3.0 does not run on php 8 as it's 10 years old.

Both 3.0 and 4.0 is outdated. Current versions is 3.10.11 and 4.2.2


Post Reply

Return to “Installation Joomla! 3.x”