Installation would not even run the install script.

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
atk0309
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 09, 2018 1:18 pm

Installation would not even run the install script.

Post by atk0309 » Tue Jan 09, 2018 1:31 pm

Problem Description :: Forum Post Assistant (v1.3.7) : 9th January 2018 wrote:500 in logs
Actions Taken To Resolve by Forum Post Assistant (v1.3.7) 9th January 2018 wrote:Reinstalled OS, reinstalled apache, scoured the forums and did everything everybody suggested. Set permissions, added rewrite etc.
Forum Post Assistant (v1.3.7) : 9th January 2018 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.8.3-Stable (Amani) 12-December-2017
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Not Found

Host Configuration :: OS: Linux | OS Version: 4.9.0-4-amd64 | Technology: x86_64 | Web Server: Apache/2.4.25 (Debian) | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 36.46 GiB |

PHP Configuration :: Version: 7.0.19-1 | PHP API: apache2handler | Session Path Writable: Yes | Display Errors: | Error Reporting: 22527 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 2M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 128M

MySQL Configuration :: Database Credentials incomplete or not available Nothing to display.
Missing credentials detected: Connection Type missing | MySQL Host missing | Table Prefix missing | Database Username missing | Database Password missing |
Detailed Environment :: wrote:PHP Extensions :: Core (7.0.19-1) | date (7.0.19-1) | libxml (7.0.19-1) | openssl (7.0.19-1) | pcre (7.0.19-1) | zlib (7.0.19-1) | filter (7.0.19-1) | hash (1.0) | Reflection (7.0.19-1) | SPL (7.0.19-1) | session (7.0.19-1) | standard (7.0.19-1) | apache2handler () | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $) | PDO (7.0.19-1) | calendar (7.0.19-1) | ctype (7.0.19-1) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | fileinfo (1.0.5) | ftp (7.0.19-1) | gettext (7.0.19-1) | iconv (7.0.19-1) | json (1.4.0) | mysqli (7.0.19-1) | pdo_mysql (7.0.19-1) | Phar (2.0.2) | posix (7.0.19-1) | readline (7.0.19-1) | shmop (7.0.19-1) | sockets (7.0.19-1) | sysvmsg (7.0.19-1) | sysvsem (7.0.19-1) | sysvshm (7.0.19-1) | tokenizer (7.0.19-1) | Zend OPcache (7.0.19-1) | Zend Engine (3.0.0) |
Potential Missing Extensions :: xml | zip | curl | mbstring | mysql | mcrypt | suhosin |
Disabled Functions :: pcntl_alarm | pcntl_fork | pcntl_waitpid | pcntl_wait | pcntl_wifexited | pcntl_wifstopped | pcntl_wifsignaled | pcntl_wifcontinued | pcntl_wexitstatus | pcntl_wtermsig | pcntl_wstopsig | pcntl_signal | pcntl_signal_dispatch | pcntl_get_last_error | pcntl_strerror | pcntl_sigprocmask | pcntl_sigwaitinfo | pcntl_sigtimedwait | pcntl_exec | pcntl_getpriority | pcntl_setpriority | |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe

Apache Modules :: core | mod_so | mod_watchdog | http_core | mod_log_config | mod_logio | mod_version | mod_unixd | mod_access_compat | mod_alias | mod_auth_basic | mod_authn_core | mod_authn_file | mod_authz_core | mod_authz_host | mod_authz_user | mod_autoindex | mod_deflate | mod_dir | mod_env | mod_filter | mod_mime | prefork | mod_negotiation | mod_php7 | mod_reqtimeout | mod_setenvif | mod_status | Apache/2.4.25 (Debian) |
Potential Missing Modules :: mod_rewrite | mod_expires | mod_security | mod_evasive | mod_dosevasive | mod_ssl | mod_qos | mod_userdir |
Folder Permissions :: wrote:Core Folders :: images/ (775) | components/ (775) | modules/ (775) | plugins/ (775) | language/ (775) | templates/ (775) | cache/ (775) | logs/ (---) | tmp/ (775) | administrator/components/ (775) | administrator/modules/ (775) | administrator/language/ (775) | administrator/templates/ (775) | administrator/logs/ (775) |

Elevated Permissions (First 10) :: cache/ (775) | images/ (775) | images/banners/ (775) | images/headers/ (775) | images/sampledata/ (775) | images/sampledata/fruitshop/ (775) | images/sampledata/parks/ (775) | images/sampledata/parks/animals/ (775) | images/sampledata/parks/landscape/ (775) | tmp/ (775) |
Extensions Discovered :: wrote:Components :: SITE :: com_mailto (3.0.0) | com_wrapper (3.0.0) |
Components :: ADMIN :: com_login (3.0.0) | com_menus (3.0.0) | com_tags (3.1.0) | com_checkin (3.0.0) | com_fields (3.7.0) | com_newsfeeds (3.0.0) | com_messages (3.0.0) | com_cache (3.0.0) | com_banners (3.0.0) | com_associations (3.7.0) | com_modules (3.0.0) | com_search (3.0.0) | com_redirect (3.0.0) | com_content (3.0.0) | com_finder (3.0.0) | com_categories (3.0.0) | com_languages (3.0.0) | com_contenthistory (3.2.0) | com_templates (3.0.0) | com_joomlaupdate (3.6.2) | com_config (3.0.0) | com_users (3.0.0) | com_ajax (3.2.0) | com_plugins (3.0.0) | com_admin (3.0.0) | com_media (3.0.0) | com_cpanel (3.0.0) | com_installer (3.0.0) | com_postinstall (3.2.0) |

Modules :: SITE :: mod_syndicate (3.0.0) | mod_feed (3.0.0) | mod_footer (3.0.0) | mod_tags_popular (3.1.0) | mod_banners (3.0.0) | mod_custom (3.0.0) | mod_related_items (3.0.0) | mod_breadcrumbs (3.0.0) | mod_articles_archive (3.0.0) | mod_articles_popular (3.0.0) | mod_stats (3.0.0) | mod_articles_news (3.0.0) | mod_articles_categories (3.0.0) | mod_users_latest (3.0.0) | mod_articles_category (3.0.0) | mod_search (3.0.0) | mod_languages (3.5.0) | mod_whosonline (3.0.0) | mod_wrapper (3.0.0) | mod_menu (3.0.0) | mod_tags_similar (3.1.0) | mod_finder (3.0.0) | mod_articles_latest (3.0.0) | mod_random_image (3.0.0) | mod_login (3.0.0) |
Modules :: ADMIN :: mod_feed (3.0.0) | mod_latest (3.0.0) | mod_custom (3.0.0) | mod_quickicon (3.0.0) | mod_submenu (3.0.0) | mod_sampledata (3.8.0) | mod_logged (3.0.0) | mod_stats_admin (3.0.0) | mod_version (3.0.0) | mod_popular (3.0.0) | mod_menu (3.0.0) | mod_multilangstatus (3.0.0) | mod_toolbar (3.0.0) | mod_status (3.0.0) | mod_title (3.0.0) | mod_login (3.0.0) |

Plugins :: SITE :: plg_authentication_ldap (3.0.0) | plg_authentication_cookie (3.0.0) | plg_authentication_joomla (3.0.0) | plg_authentication_gmail (3.0.0) | plg_fields_calendar (3.7.0) | plg_fields_text (3.7.0) | plg_fields_usergrouplist (3.7.0) | plg_fields_media (3.7.0) | plg_fields_radio (3.7.0) | plg_fields_editor (3.7.0) | plg_fields_user (3.7.0) | plg_fields_textarea (3.7.0) | plg_fields_color (3.7.0) | plg_fields_list (3.7.0) | plg_fields_integer (3.7.0) | plg_fields_imagelist (3.7.0) | plg_fields_checkboxes (3.7.0) | plg_fields_url (3.7.0) | plg_fields_sql (3.7.0) | plg_editors_codemirror (5.30.0) | plg_editors_tinymce (4.5.8) | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) | PLG_INSTALLER_URLINSTALLER (3.6.0) | plg_installer_packageinstaller (3.6.0) | plg_user_contactcreator (3.0.0) | plg_user_profile (3.0.0) | plg_user_joomla (3.0.0) | plg_quickicon_phpversioncheck (3.7.0) | plg_quickicon_joomlaupdate (3.0.0) | plg_quickicon_extensionupdate (3.0.0) | plg_search_contacts (3.0.0) | plg_search_categories (3.0.0) | plg_search_tags (3.0.0) | plg_search_newsfeeds (3.0.0) | plg_search_content (3.0.0) | plg_system_logout (3.0.0) | plg_system_stats (3.5.0) | plg_system_languagefilter (3.0.0) | plg_system_cache (3.0.0) | plg_system_debug (3.0.0) | plg_system_fields (3.7.0) | plg_system_p3p (3.0.0) | plg_system_sef (3.0.0) | plg_system_remember (3.0.0) | plg_system_redirect (3.0.0) | plg_system_log (3.0.0) | plg_system_updatenotification (3.5.0) | plg_system_highlight (3.0.0) | plg_system_languagecode (3.0.0) | plg_twofactorauth_yubikey (3.2.0) | plg_twofactorauth_totp (3.2.0) | plg_extension_joomla (3.0.0) | plg_editors-xtd_readmore (3.0.0) | plg_editors-xtd_article (3.0.0) | plg_editors-xtd_fields (3.7.0) | plg_editors-xtd_menu (3.7.0) | plg_editors-xtd_image (3.0.0) | plg_editors-xtd_pagebreak (3.0.0) | plg_editors-xtd_module (3.5.0) | plg_captcha_recaptcha (3.4.0) | plg_content_fields (3.7.0) | plg_content_loadmodule (3.0.0) | plg_content_pagenavigation (3.0.0) | plg_content_emailcloak (3.0.0) | plg_content_pagebreak (3.0.0) | plg_content_vote (3.0.0) | plg_content_joomla (3.0.0) | plg_content_finder (3.0.0) | plg_finder_contacts (3.0.0) | plg_finder_categories (3.0.0) | plg_finder_tags (3.0.0) | plg_finder_newsfeeds (3.0.0) | plg_finder_content (3.0.0) |
Templates Discovered :: wrote:Templates :: SITE :: beez3 (3.1.0) | protostar (1.0) |
Templates :: ADMIN :: hathor (3.0.0) | isis (1.0) |

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3900
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Installation would not even run the install script.

Post by AMurray » Tue Jan 09, 2018 9:20 pm

I can see a few settings that could cause issues (not just with installation but future use of the CMS); you should adjust these in your php.ini file as these are likely preventing the installation.

Max. Upload Size: 2M (change to 20M) | Max. POST Size: 8M (change to 20M) | Max. Input Time: 60 | Max. Execution Time: 30 (change to 300)

Also the permissions are incorrect. Folders should be CHMOD 755 (not 775) and files 644.

The above should be changed to start with; either you can change the php.ini or ask your host how/if you can change such settings.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5612
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Installation would not even run the install script.

Post by sozzled » Tue Jan 09, 2018 9:38 pm

I agree with all that @AMurray has written (especially about increasing PHP upload quotas and fixing those folder/file permissions) but I also observe that there's an issue here w.r.t. how you're attempting to connect the database to Joomla.

I note that you're using PHP 7.0.10-1; you should be aware that PHP 7+ does not support the database connection type of "mysql" (you should use, instead, the connection type of "mysqli"). Further, I would also ask if you have actually created the database—before you attempted to run the installation procedure—that you'll be using with this new Joomla website and have you created a database username (with all privileges)?

The FPA report shows that a Joomla file structure has been created but indicates that the database has not been created.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installation would not even run the install script.

Post by Webdongle » Tue Jan 09, 2018 11:23 pm

PHP API: apache2handler could cause problems writing the configuration.php file. If the configuration.php does not exist then no database details will be found.

The question is ... are you running a dedicated server and setting it up yourself ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19081
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Installation would not even run the install script.

Post by leolam » Wed Jan 10, 2018 6:16 pm

Webdongle wrote:PHP API: apache2handler could cause problems writing the configuration.php file. If the configuration.php does not exist then no database details will be found.
This is completely wrong information

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installation would not even run the install script.

Post by Webdongle » Wed Jan 10, 2018 8:38 pm

Your stalking my posts and posting they are incorrect is getting tiresome. It means that in order to prevent your misinformation about my posts causing confusion to newbies I need to post the proof of what I say.

PHP API: apache2handler does cause file Ownership issues >>> well documented
With file Ownership issues the configuration.php file does not written >>> well known
With no configuration.php the fpa reports no database details found. >>> fpa from a working Joomla after the configuration.php file was removed.
Last PHP Error(s) Reported :: Forum Post Assistant (v1.3.0) : 10th January 2018 wrote:[08-Jan-2018 00:23:44 UTC] PHP 19. array_intersect() C:\wamp64\www\j381\tmp\install_5a52ba0a391fa\packages\install_5a52ba0b18d11\perfectinstaller.php:91
Forum Post Assistant (v1.3.0) : 10th January 2018 wrote:
Basic Environment :: wrote:Joomla! Instance :: .- ()
Joomla! Configured :: Not Found

Host Configuration :: OS: Windows NT | OS Version: 10.0 | Technology: AMD64 | Web Server: Apache/2.4.27 (Win64) PHP/5.6.31 | Encoding: gzip, deflate | Doc Root: C:/wamp64/www | System TMP Writable: Yes

PHP Configuration :: Version: 5.6.31 | PHP API: apache2handler | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32767 | Log Errors To: c:/wamp64/logs/php_error.log | Last Known Error: 10th January 2018 20:21:25. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 120 | Memory Limit: 128M

MySQL Configuration :: Database Credentials incomplete or not available Nothing to display.
Missing credentials detected: Connection Type missing | MySQL Host missing | Table Prefix missing | Database Username missing | Database Password missing |
Detailed Environment :: wrote:PHP Extensions :: Core (5.6.31) | bcmath () | calendar () | ctype () | date (5.6.31) | ereg () | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | mcrypt () | SPL (0.2) | odbc (1.0) | pcre () | Reflection ($Id: 5f15287237d5f78d75b19c26915aa7bd83dee8b8 $) | session () | standard (5.6.31) | mysqlnd (mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $) | tokenizer (0.1) | zip (1.12.5) | zlib (2.0) | libxml () | dom (20031129) | PDO (1.0.4dev) | bz2 () | SimpleXML (0.1) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | apache2handler () | openssl () | curl () | com_dotnet (0.1) | fileinfo (1.0.5) | gd () | gettext () | gmp () | intl (1.1.0) | imap () | ldap () | mbstring () | exif (1.4 $Id: 1c8772f76be691b7b3f77ca31eb788a2abbcefe5 $) | mysql (1.0) | mysqli (0.1) | Phar (2.0.2) | pdo_mysql (1.0.2) | pdo_sqlite (1.0.1) | soap () | sockets () | sqlite3 (0.7-dev) | xmlrpc (0.51) | xsl (0.1) | mhash () | Zend OPcache (7.0.6-devFE) | xdebug (2.5.5) | Zend Engine (2.6.0) |
Potential Missing Extensions :: suhosin |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe

Apache Modules :: core | mod_win32 | mpm_winnt | http_core | mod_so | mod_access_compat | mod_actions | mod_alias | mod_allowmethods | mod_asis | mod_auth_basic | mod_auth_digest | mod_authn_core | mod_authn_file | mod_authz_core | mod_authz_groupfile | mod_authz_host | mod_authz_user | mod_autoindex | mod_cache | mod_cache_disk | mod_cgi | mod_dir | mod_env | mod_file_cache | mod_include | mod_isapi | mod_log_config | mod_mime | mod_negotiation | mod_rewrite | mod_setenvif | mod_userdir | mod_vhost_alias | mod_php5 | Apache/2.4.27 (Win64) PHP/5.6.31 |
Potential Missing Modules :: mod_expires | mod_deflate | mod_security | mod_evasive | mod_dosevasive | mod_ssl | mod_qos | mod_userdir |
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (---) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) |
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5612
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Installation would not even run the install script.

Post by sozzled » Wed Jan 10, 2018 8:47 pm

@Webdongle: I'll file that piece of useful information away for future reference. Thanks :)

A Joomla website without a configuration.php file causes the FPA report generator to report "Missing credentials detected"

The next question is why was the configuration.php file not created (or why was it removed)? I look forward to the next instalment! :laugh:
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installation would not even run the install script.

Post by Webdongle » Wed Jan 10, 2018 9:00 pm

sozzled wrote:A Joomla website without a configuration.php file causes the FPA report generator to report "Missing credentials detected"
Yes missing credentials not missing database.


sozzled wrote:...
The next question is why was the configuration.php file not created (or why was it removed)? I look forward to the next instalment! :laugh:
PHP API: apache2handler looks like the culprit. Will be interesting to see if the OP is running the server or has a managed package.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3295
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Installation would not even run the install script.

Post by ribo » Wed Jan 10, 2018 9:13 pm

AMurray wrote:I can see a few settings that could cause issues (not just with installation but future use of the CMS); you should adjust these in your php.ini file as these are likely preventing the installation.

Max. Upload Size: 2M (change to 20M) | Max. POST Size: 8M (change to 20M) | Max. Input Time: 60 | Max. Execution Time: 30 (change to 300)

Also the permissions are incorrect. Folders should be CHMOD 755 (not 775) and files 644.

The above should be changed to start with; either you can change the php.ini or ask your host how/if you can change such settings.
All the changes except the permissions is not a reason for OP to have 500 error in joomla install
chat room spontes : http://www.spontes.com

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3295
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Installation would not even run the install script.

Post by ribo » Wed Jan 10, 2018 9:17 pm

I think that the issue is related with this viewtopic.php?t=825880
chat room spontes : http://www.spontes.com


Post Reply

Return to “Installation Joomla! 3.x”