Installation of Joomla 4 component is aborted

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
panicoschr
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Thu Feb 19, 2015 3:59 pm

Installation of Joomla 4 component is aborted

Post by panicoschr » Sat Jan 20, 2018 5:26 am

Hi
i found no other place to post my question which is related to Joomla 4 so i did this here. If there is another link to do that, please let me know.

The problem i am facing is this. When i try to install my component i get this error. The installer actually installs the 'admin' and then throws this error and installation is aborted.

JInstaller: :Install: Error SQL Data too long for column 'version_id' at row 1

Can someone help?
Thanks

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3951
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Installation of Joomla 4 component is aborted

Post by AMurray » Sat Jan 20, 2018 6:00 am

That would be expected; Joomla 4 is not released yet. It's only at 'alpha' stage. Don't expect it to be working fully and correctly without errors.

If you have problems, you can post them here: https://issues.joomla.org

Which component is "your component" (are you the developer of it?).

I have found even well-known components don't have a JOomla 4 equivalent yet, and any Joomla 3 version doesn't work in J4.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
JAVesey
Joomla! Ace
Joomla! Ace
Posts: 1836
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Installation of Joomla 4 component is aborted

Post by JAVesey » Sat Jan 20, 2018 7:54 pm

AMurray wrote:I have found even well-known components don't have a JOomla 4 equivalent yet, and any Joomla 3 version doesn't work in J4.
Ive got some things to install but, as you say, many don’t yet either install or work.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.0


Post Reply

Return to “Installation Joomla! 3.x”