Authentification problem after migrating to a new platform

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Authentification problem after migrating to a new platform

Post by sbayle » Thu Apr 19, 2018 3:14 pm

I try to migrate a Joomla 3.8 site from an old PHP5.4 platform to PHP7.0
I tried on a test server, everything worked fine but when I put it on the preprod server, whereas the site works fine, I cannot log into the backend. With none of the users I have.
As the migration worked fine on my test server, I think there is a configuration problem on the preprod server but I dont have access to the apache/php configuration and my IT says the server is OK.

I purged everything and tried to install a brand new Joomla and I keep looping at the first step of the installation.

What can I ask my IT to check on the server to fix this problem.

Thanks

dottedhippo
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Aug 29, 2012 7:41 pm

Re: Authentification problem after migrating to a new platform

Post by dottedhippo » Thu Apr 19, 2018 3:37 pm

Can you read off the installation page what the version of PHP is on the server?

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Fri Apr 20, 2018 8:09 am

The server is running PHP 7.0.27

dottedhippo
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Aug 29, 2012 7:41 pm

Re: Authentification problem after migrating to a new platform

Post by dottedhippo » Fri Apr 20, 2018 8:32 am

That seems to be ok. I fear I have not enough know-how to help you from here. Ik hope others will.

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Fri Apr 20, 2018 8:34 am

Thanks for taking time to try to help anyway.

dottedhippo
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Aug 29, 2012 7:41 pm

Re: Authentification problem after migrating to a new platform

Post by dottedhippo » Fri Apr 20, 2018 8:46 am

You probably did, but to be sure, did you use the most recent version of kickstart or installer?

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Fri Apr 20, 2018 9:19 am

Yes, I did. Even if the site I migrate is not at the most recent version (but 3.8 ).
Last edited by sbayle on Fri Apr 20, 2018 10:07 am, edited 1 time in total.

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Fri Apr 20, 2018 10:07 am

I keep searching what can cause my site to prevent login to the backend and I found this page : https://www.itoctopus.com/10-reasons-wh ... la-website
In the section 7, it says that if the system can't write in the logs directory is a reason for login to fail.
It happens I don't have logs even if it seems to be properly configured.
public $log_path = '/home/webuser/www/logs';
and the rights are set to 775 so the www-data user should be able to write in it. Changing the rights to 777 didn't change anything.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24630
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Authentification problem after migrating to a new platform

Post by Per Yngve Berg » Fri Apr 20, 2018 10:47 am

I suggest you use the FPA.

viewtopic.php?f=714&t=793531

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Fri Apr 20, 2018 12:05 pm

I'm new to Joomla, I didn't knew about FPA, thanks.
That confirm me the IT crew didn't do the job well, I can now ask them to correctly set the server.

Code: Select all

Warning: is_writable(): open_basedir restriction in effect. File(/var/lib/php/sessions) is not within the allowed path(s): (/home/webuser/www:/tmp) in /home/webuser/www/fpa-en.php on line 1396

sbayle
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Apr 19, 2018 1:10 pm

Re: Authentification problem after migrating to a new platform

Post by sbayle » Wed Apr 25, 2018 9:01 am

Final word, the problem was caused by an Apache security module that was a bit to aggressive.
After beeing able to install a fresh Joomla! 3.8.7 successfully, I tried to migrate my site (3.8.6) but it didn't work either.
I had to upgrade my site from 3.8.6 to 3.8.7 before migrate but after that everything went as expected.
Thanks for the help.


Post Reply

Return to “Installation Joomla! 3.x”