How to upgrade from 3.65 to 3.87

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
lillianfidler
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Mar 31, 2008 8:28 pm
Location: St. John's, Newfoundland, Canada
Contact:

How to upgrade from 3.65 to 3.87

Post by lillianfidler » Thu Apr 19, 2018 5:04 pm

I'm not sure how to upgrade from 3.65 to 3.87

I didn't actually see any upgrade packages in the downloads to do that...

thank you

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5830
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by sozzled » Thu Apr 19, 2018 6:51 pm

Use the Joomla! Update component to update from J! 3.6.5 to J! 3.8.7. The procedure is automatic.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

lillianfidler
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Mar 31, 2008 8:28 pm
Location: St. John's, Newfoundland, Canada
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by lillianfidler » Thu Apr 19, 2018 6:55 pm

It doesn't work - I get an ajax error. Normally, when I get this I just upload the files manually and overwrite, then fix the database. But I can't find the upgrade files or am unsure which files to use :.) thank you.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5830
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by sozzled » Thu Apr 19, 2018 7:10 pm

If you are getting an "AJAX error" this indicates that there's an issue with the hosting platform.

Manually copying files from the Joomla distribution packages is not how you update Joomla. Manually replacing files within a Joomla installation only results in further problems. There were also sweeping changes made between J! 3.6.5 and J! 3.8.x: a large number of files were removed! Therefore, if you copy files from the distribution package (without removing existing files) and you do not allow the Joomla! Update component to make necessary changes to the database as part of the update procedure, it's no wonder that you will get "AJAX errors" or other problems.

I cannot tell you which things to replace, which things to remove or what other changes (including modifications to the database) you need to do. J! 3.6.5 was released a little over a year ago (December 2016). There have been 20 updates to Joomla in that time. I think you need to reconsider how you maintain your websites properly so that you do not get yourself into situations like this one.

I say again, the only way to update from J! 3.6.5 to J! 3.8.7 is to use the Joomla! Update component. Any other "method" is either a myth or it's something that highly skilled professionals may be able to do (if you pay them enough for their time).

If you post the Forum Post Assistant Report here, someone—not me—may be able to assist you. Good luck.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

lillianfidler
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Mar 31, 2008 8:28 pm
Location: St. John's, Newfoundland, Canada
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by lillianfidler » Thu Apr 19, 2018 7:17 pm

Hi, Thank you for that. This isn't actually my website, I've been given it to clean and update after an attack actually. I told the client how important it is to keep the site updated, but sometimes they just don't listen.

I setup a test server in order to clean the site and I read somewhere in the joomla documentation to start with the same version of Joomla that was installed on the website (3.65) and then upgrade from there.

Should I perhaps have started with joomla 3.87 instead? - should I go back to the test site, start over and installed version 3.87 (don't want to necessarily do this...)

Also, if I go back to godaddy now with this issue (we are also getting hosting timeout errors - I think you replied to another post on this), I think they are going to now say that the Joomla is not at the latest version and that's why I'm having these problem. But I can't do upgrade due to ajax errors, plus the timeout errors.

Your advice greatly appreciated.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5830
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by sozzled » Thu Apr 19, 2018 7:21 pm

Perhaps you should start again. It may be a lot easier. ;)

No comment about GoDaddy. That's your problem. I do not know any professional website designers/developers who use this "service".
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

lillianfidler
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Mar 31, 2008 8:28 pm
Location: St. John's, Newfoundland, Canada
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by lillianfidler » Thu Apr 19, 2018 8:19 pm

Thank you for that... by the way. This is the link where it says that if you can't update/upgrade manually to copy the files via ftp....

https://docs.joomla.org/J3.x:Upgrading_ ... 4.x_to_3.5

Method C

then use postupdate.php

Is this then a valid option? or is this old?

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5830
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by sozzled » Thu Apr 19, 2018 8:30 pm

If it was a choice between eating cardboard and eating a box of chocolates, what would you do? (I know which choice would leave me with a smile on my face.)

I repeat, there is only one way to update Joomla from J! 3.6.5 to J! 3.8.7 and that is to use the Joomla! Update component. Any other "method" is for "other people" (who would rather eat cardboard).

As I wrote earlier, there were sweeping changes made to Joomla after J! 3.6 that involved the removal of a number of files. Did you not read that? Therefore, if you replace files—the so-called "Method C" that you read in that old article—and you do not remove some existing files on the target website, what do you think will be the consequences of doing that? I have no idea if the so-called "postupdate.php" approach will resolve those issues, sorry. Use the "cardboard-eating method" at your own risk. 8)
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

lillianfidler
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Mar 31, 2008 8:28 pm
Location: St. John's, Newfoundland, Canada
Contact:

Re: How to upgrade from 3.65 to 3.87

Post by lillianfidler » Thu Apr 19, 2018 8:42 pm

got it. No eating cardboard here 8)


Post Reply

Return to “Installation Joomla! 3.x”