Administrator 404 Component not found

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
fafolaktik
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Apr 21, 2018 11:37 pm

Administrator 404 Component not found

Post by fafolaktik » Sat Apr 21, 2018 11:45 pm

Greetings !

Sorry for the newbie question, its my first Joomla installation.

After running the installation successfully, the administrator pages loads but fails once login is successful.

404 Component not found.
/var/www/html/libraries/src/Component/ComponentHelper.php:347

The sample site data which I requested during the setup loads fine. But I can't access the actual CMS.

Xenial
PHP7.0
Postgres db

No clue how to proceed.. :( :-[ .

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 9611
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Administrator 404 Component not found

Post by toivo » Sun Apr 22, 2018 8:11 am

If the back end fails immediately after a successful login, check the file administrator/components/com_cpanel/cpanel.php, which may be missing or has become corrupted.

Locate the file from the installation package and upload it to the server. If further error messages show that more files are missing, it would be best to start from a clean folder and repeat the installation.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
troubleshooting smtp and other articles https://talikka.com/joomla

fafolaktik
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Apr 21, 2018 11:37 pm

Re: Administrator 404 Component not found

Post by fafolaktik » Sun Apr 22, 2018 5:43 pm

thanks for the reply. I did try that several times only to obtain the same result.

In the end, I updated the root folder path in the nginx sites config after the installation was complete which seemed to solve the problem.

Pre-install config:

root /var/www/html/joomla387

Post install config change to :

root /var/www/html/joomla387/administrator


Hopefully nothing else comes from this.


Post Reply

Return to “Installation Joomla! 3.x”