Blank admin page after upgrade - not getting errors

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
vdsm
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jan 30, 2010 3:02 pm

Blank admin page after upgrade - not getting errors

Post by vdsm » Tue Jul 31, 2018 9:49 am

I moved my website to a new host and used Akeeba Backup to get everything up and running with the new host. That all went silky smooth.
Since I had moved the website and planned potential downtime anyway, I decided to finally upgrade from Joomla 3.7.3 Stable to Joomla 3.8.10.
That went smooth as well, and everything seemed to be working just fine, until I visitited the backend and found nothing more than a blank page.

What have I tried so far:
  • Set configuration.php public $error_reporting to E_ALL (also tried maximum and development)
  • Added ini_set('display_errors',true); error_reporting( E_ALL ); to configuration.php
  • Added ini_set('display_errors',true); error_reporting( E_ALL ); to index.php
  • Screamed like a little girl
I'm not getting any errors, just the blank page. Any ideas?

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3416
Joined: Tue Aug 23, 2005 1:56 pm
Location: Kent / Sussex / Surrey border UK
Contact:

Re: Blank admin page after upgrade - not getting errors

Post by gws » Tue Jul 31, 2018 10:59 am

Blank pages are often php related, is your new server using a different php version to the old one?

vdsm
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jan 30, 2010 3:02 pm

Re: Blank admin page after upgrade - not getting errors

Post by vdsm » Tue Jul 31, 2018 2:42 pm

I'm not entirely sure. The reason I switched servers is because you can't actually 'control' anything on one.com's control panel. So I can't see (or don't know how to) the PHP version on there.
Isn't it weird though that I can't produce any errors?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19040
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Blank admin page after upgrade - not getting errors

Post by leolam » Tue Aug 07, 2018 5:11 am

post output as described: viewtopic.php?f=714&t=793531

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5504
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Blank admin page after upgrade - not getting errors

Post by sozzled » Tue Aug 07, 2018 7:24 am

Although "screaming like a little girl" may be somewhat cathartic, one other suggestion is to look at the file error_log in the same folder where you will find configuration.php. Look at the last few lines of that file.

A far more useful suggestion would be to use the Forum Post Assistant report generator tool.

I would, more likely, very quietly slip away from one.com's reach into my hip pocket. ;)
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?


Post Reply

Return to “Installation Joomla! 3.x”