Page 1 of 2

"remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 4:15 pm
by HZolfaghar
Hi every one

i'm trying to install joomla 3.9 quick start full package.
at the last step the "remove installation folder" buttom not working & the response in network monitor is:

Code: Select all

Joomla\Filesystem\File::delete: Failed deleting inaccessible file COPYRIGHT
i am joomla web designer. our team test this problem on 3 PC ubuntu with xampp & ampps & not work. but test on windows PC & working true.

After review, I concluded that, the directory /libraries/joomla/filesysyem was removed in joomla 3.9 & when i restore this directory from joomla 3.8 the "remove installation folder" buttom Works fine.

Given that I have not seen a report so far. I do not know the problem is so simple or too complicated!

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 4:44 pm
by toivo
HZolfaghar wrote:i'm trying to install joomla 3.9 quick start full package.
Where did you download this package from?

Quick start packages are usually not recommended at this forum because of issues users have had with them. The normal method is to download the full installation package of the latest version from https://downloads.joomla.org.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 6:05 pm
by toivo
HZolfaghar wrote:Joomla\Filesystem\File::delete: Failed deleting inaccessible file COPYRIGHT
This error message is not about a non-existent directory. The message means simply that the deletion process was unable to delete the file called COPYRIGHT, which should have been accessible from the installation folder.

However, the error message is odd because the last step of the installation, the removal of the installation folder, does not delete files individually but it removes the whole folder in one go. This is how the removal of the installation folder happens in both in 3.8.13 and 3.9.0. However, if you installed a quick start package, we do not really know how it has been put together and which functions take care of the removal of the installation folder.

More importantly, you should not have restored any directories because
  • that can easily cause something else to break in the future, and
  • the function File::delete() is not missing from Joomla 3.9.0
The function File::delete is actually defined in two separate files in Joomla 3.9.0, libraries/vendor/joomla/filesystem/src/File.php and also in libraries/src/Filesystem/File.php.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 6:59 pm
by HZolfaghar
toivo wrote:
Sun Nov 18, 2018 4:44 pm
Where did you download this package from?

Quick start packages are usually not recommended at this forum because of issues users have had with them. The normal method is to download the full installation package of the latest version from https://downloads.joomla.org.

I mean that full installation package & i download from https://downloads.joomla.org & try too install without any change !

toivo wrote:
Sun Nov 18, 2018 6:05 pm
This error message is not about a non-existent directory. The message means simply that the deletion process was unable to delete the file called COPYRIGHT, which should have been accessible from the installation folder.

However, the error message is odd because the last step of the installation, the removal of the installation folder, does not delete files individually but it removes the whole folder in one go. This is how the removal of the installation folder happens in both in 3.8.13 and 3.9.0. However, if you installed a quick start package, we do not really know how it has been put together and which functions take care of the removal of the installation folder.

More importantly, you should not have restored any directories because
  • that can easily cause something else to break in the future, and
  • the function File::delete() is not missing from Joomla 3.9.0
The function File::delete is actually defined in two separate files in Joomla 3.9.0, libraries/vendor/joomla/filesystem/src/File.php and also in libraries/src/Filesystem/File.php.
I know exactly what this error is. I wanted to explain to you why the buttom not working. because that request the function from old path that not exist.
Well, I want to know why Joomla! Requests this function from the previous path?
And again I must say, i use full installation package & i download from https://downloads.joomla.org & try too install without any change !

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 7:31 pm
by toivo
Ok, now it is understood that you downloaded the installation file from https://downloads.joomla.org. The words "Joomla 3.9 quick start" made it sound like a file containing a full Joomla installation with templates and third party extensions, often provided for example by template developers.

Many people have installed Joomla 3.9 as a new installation, but no one else has reported a similar error at this support forum or posted a bug report to the Joomla! Issue Tracker at https://issues.joomla.org/.

So that others can review the configuration of your site, can you please post the results of the Forum Post Assistant (FPA) by following the instruction from viewtopic.php?f=714&t=793531.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 7:52 pm
by sozzled
I've seen a few discussions on this forum where people have had problems successfully removing the installation files from their websites. The reasons why this happens (from time to time) are varied. The reasons include folder/file permissions, folder/file ownership, webhosting providers, for example
... among others.

I don't know why this problem is happening in this case but it may help to use the Forum Post Assistant. (Detailed instructions are here: viewtopic.php?f=621&t=656394&start=120#p3543744)

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 8:30 pm
by HZolfaghar
toivo wrote:
Sun Nov 18, 2018 7:31 pm
Ok, now it is understood that you downloaded the installation file from https://downloads.joomla.org. The words "Joomla 3.9 quick start" made it sound like a file containing a full Joomla installation with templates and third party extensions, often provided for example by template developers.

Many people have installed Joomla 3.9 as a new installation, but no one else has reported a similar error at this support forum or posted a bug report to the Joomla! Issue Tracker at https://issues.joomla.org/.

So that others can review the configuration of your site, can you please post the results of the Forum Post Assistant (FPA) by following the instruction from viewtopic.php?f=714&t=793531.
Hi
I dont know how to share result. atach an image
https://screenshots.firefox.com/GnCSaLs ... /localhost

Re: "remove installation folder" button not work in joomla 3.9

Posted: Sun Nov 18, 2018 8:35 pm
by sozzled
sozzled wrote:
Sun Nov 18, 2018 7:52 pm
... Forum Post Assistant: Detailed instructions are here: viewtopic.php?f=621&t=656394&start=120#p3543744

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 9:03 pm
by toivo
FPA results cannot be attached as an image.

Please read the instruction from the document included in the expanded zip file, from where you found the actual FPA script.

Use the links from the FPA page, first to generate the results and then create the box containing BBCode, the contents of which you need to copy and paste into a new post in this topic.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Sun Nov 18, 2018 9:10 pm
by HZolfaghar
Forum Post Assistant (v1.4.5 (Ganymede)) : 18th November 2018 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.0-Stable (Amani) 30-October-2018
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (644) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: No | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: N/A | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: N/A | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.0: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.15.0-39-generic | Technology: x86_64 | Web Server: Apache/2.4.27 (Unix) OpenSSL/1.1.0f PHP/5.6.31 | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 635.14 GiB |

PHP Configuration :: Version: 5.6.31 | PHP API: apache2handler | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 22519 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 128M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: -2M

Database Configuration :: Version: 5.6.37 (Client:5.6.37) | Host: --protected-- (--protected--) | Localhost: Yes | Collation: utf8_general_ci (Character Set: utf8) | Database Size: 4.12 MiB | #of Tables: 78
Detailed Environment :: wrote:PHP Extensions :: Core (5.6.31) | date (5.6.31) | ereg () | libxml () | pcre () | dom (20031129) | fileinfo (1.0.5) | filter (0.11.0) | gmp () | hash (1.0) | json (1.2.1) | SPL (0.2) | bz2 () | posix () | Reflection ($Id: 5f15287237d5f78d75b19c26915aa7bd83dee8b8 $) | session () | SimpleXML (0.1) | standard (5.6.31) | xml () | xmlreader (0.1) | xmlwriter (0.1) | mysqlnd (mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $) | apache2handler () | openssl () | curl () | gettext () | intl (1.1.0) | imap () | ldap () | mbstring () | exif (1.4 $Id: 1c8772f76be691b7b3f77ca31eb788a2abbcefe5 $) | mysql (1.0) | mysqli (0.1) | PDO (1.0.4dev) | pdo_mysql (1.0.2) | pdo_pgsql (1.0.2) | pdo_sqlite (1.0.1) | pgsql () | pcntl () | shmop () | soap () | sockets () | sqlite3 (0.7-dev) | tidy (2.0) | xsl (0.1) | zip (1.12.5) | gd () | zlib (2.0) | xmlrpc (0.51) | memcache (2.2.7) | Phar (2.0.2) | mcrypt () | mongodb (1.2.9) | tokenizer (0.1) | wddx () | iconv () | dba () | ftp () | calendar () | ctype () | bcmath () | pdo_dblib (1.0.1) | sysvsem () | sysvshm () | mhash () | ionCube Loader () | xdebug (2.5.5) | Zend Engine (2.6.0) |
Potential Missing Extensions ::

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe

Apache Modules :: core | mod_so | http_core | prefork | mod_authn_file | mod_authn_core | mod_authz_host | mod_authz_groupfile | mod_authz_user | mod_authz_core | mod_access_compat | mod_auth_basic | mod_socache_shmcb | mod_reqtimeout | mod_filter | mod_mime | mod_log_config | mod_env | mod_headers | mod_setenvif | mod_version | mod_ssl | mod_unixd | mod_status | mod_autoindex | mod_cgi | mod_vhost_alias | mod_dir | mod_alias | mod_rewrite | mod_php5 | Apache/2.4.27 (Unix) OpenSSL/1.1.0f PHP/5.6.31 |
Potential Missing Modules :: mod_expires | mod_deflate | mod_security | mod_evasive | mod_dosevasive | mod_qos | mod_userdir |
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (---) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) | administrator/logs/ (777) |

Elevated Permissions (First 10) :: components/ (777) | components/com_banners/ (777) | components/com_banners/helpers/ (777) | components/com_banners/models/ (777) | components/com_content/ (777) | components/com_content/controllers/ (777) | components/com_content/models/ (777) | components/com_content/models/forms/ (777) | components/com_content/views/ (777) | components/com_content/views/form/ (777) |
Database Information :: wrote:Database statistics :: Uptime: 57005 | Threads: 1 | Questions: 1253 | Slow queries: 0 | Opens: 716 | Flush tables: 1 | Open tables: 64 | Queries per second avg: 0.021 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_mailto (3.0.0) 1 | com_wrapper (3.0.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_banners (3.0.0) 1 | com_content (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_modules (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_privacy (3.9.0) 1 | com_associations (3.7.0) 1 | com_users (3.0.0) 1 | com_ajax (3.2.0) 1 | com_fields (3.7.0) 1 | com_config (3.0.0) 1 | com_plugins (3.0.0) 1 | com_admin (3.0.0) 1 | com_media (3.0.0) 1 | com_search (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_tags (3.1.0) 1 | com_categories (3.0.0) 1 | com_checkin (3.0.0) 1 | com_contenthistory (3.2.0) 1 | com_languages (3.0.0) 1 | com_menus (3.0.0) 1 | com_cpanel (3.0.0) 1 | com_login (3.0.0) 1 | com_templates (3.0.0) 1 | com_cache (3.0.0) 1 | com_redirect (3.0.0) 1 | com_installer (3.0.0) 1 | com_finder (3.0.0) 1 | com_messages (3.0.0) 1 | com_postinstall (3.2.0) 1 |
3rd Party::

Modules :: SITE ::
Core :: mod_articles_category (3.0.0) 1 | mod_login (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_wrapper (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_custom (3.0.0) 1 | mod_search (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_finder (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_whosonline (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_banners (3.0.0) 1 |
3rd Party::

Modules :: ADMIN ::
Core :: mod_login (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_title (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_latest (3.0.0) 1 | mod_version (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_status (3.0.0) 1 | mod_sampledata (3.8.0) 1 |
3rd Party::

Plugins :: SITE ::
Core :: plg_user_terms (3.9.0) 0 | plg_user_profile (3.0.0) 0 | plg_user_contactcreator (3.0.0) 0 | plg_user_joomla (3.0.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_finder_tags (3.0.0) 1 | plg_finder_content (3.0.0) 1 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_search_tags (3.0.0) 1 | plg_search_content (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_loadmodule (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | plg_content_finder (3.0.0) 0 | plg_content_vote (3.0.0) 0 | plg_content_pagenavigation (3.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_twofactorauth_totp (3.2.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_extension_joomla (3.0.0) 1 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_installer_packageinstaller (3.6.0) 1 | plg_captcha_recaptcha_invisibl (3.8) 1 | plg_captcha_recaptcha (3.4.0) 0 | plg_authentication_gmail (3.0.0) 0 | plg_authentication_cookie (3.0.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_p3p (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 1 | plg_system_sef (3.0.0) 1 | plg_system_redirect (3.0.0) 0 | plg_system_privacyconsent (3.9.0) 0 | plg_system_remember (3.0.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logout (3.0.0) 1 | plg_system_stats (3.5.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_log (3.0.0) 1 | plg_system_sessiongc (3.8.6) 1 | plg_fields_user (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_media (3.7.0) 1 |
3rd Party:: plg_editors_codemirror (5.40.0) 1 | plg_editors_tinymce (4.5.8) 1 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) 1 | beez3 (3.1.0) 1 |
Templates :: ADMIN :: hathor (3.0.0) 1 | isis (1.0) 1 |

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 4:25 am
by xfsgpr
i'm trying to install joomla 3.9 quick start full package.
at the last step the "remove installation folder" buttom not working & the response in network monitor is:
what I normally do is to rename the folder "Installation" to something like: "Installation-Deleted". then either go to the Administrator or to your sdite to see if it works. I never use the button; have never used it at all.

By renaming the folder, you can re-install if something didn't work right or you can then delete it completely if everything is working as expected. that folder contains many sql files for samples and all that which could be used to install sample data if somebody wants to.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 5:02 am
by leolam
On what server are you trying to install this? The server software is fully outdated. We are now running already PHP7.1 and PHP7.2 on Joomla. Many modules of your server are also outdated. Have that server updated! The forthcoming Joomla 4 will require minimum PHP7!

Also why are all your permissions set to '777' ? You set the door wide open for hackers! Joomla default and server default is files = 644 and folders = 755.

Leo 8)

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 6:40 am
by HZolfaghar
leolam wrote:
Mon Nov 19, 2018 5:02 am
On what server are you trying to install this? The server software is fully outdated. We are now running already PHP7.1 and PHP7.2 on Joomla. Many modules of your server are also outdated. Have that server updated! The forthcoming Joomla 4 will require minimum PHP7!

Also why are all your permissions set to '777' ? You set the door wide open for hackers! Joomla default and server default is files = 644 and folders = 755.

Leo 8)
Hi leolam

this is my local server & with one click i can swich to php 7.x but But does not solve the The problem has been announced.
& the permissions is 777 because we are in local and When we want to make it online, we make the permission.
finally, I do not think the two cases have anything to do with my problem. If you have a solution to the problem, please let us know.

Re: "remove installation folder" button not work in joomla 3.9

Posted: Mon Nov 19, 2018 6:44 am
by sozzled
Do you have this problem on your production site, on a real server? Leo's question about what kind of webhost/server you're using are relevant. See also my earlier comment viewtopic.php?f=707&t=967307&p=3548494#p3548439

Re: "remove installation folder" button not work in joomla 3.9

Posted: Mon Nov 19, 2018 7:07 am
by HZolfaghar
sozzled wrote:
Mon Nov 19, 2018 6:44 am
Do you have this problem on your production site, on a real server? Leo's question about what kind of webhost/server you're using are relevant. See also my earlier comment viewtopic.php?f=707&t=967307&p=3548494#p3548439
Hi sozzled
this server is ampps on ubuntu we test on two other ubuntu pc's with xampp servers The problem is there too.
but when test on window with xamp server there are no problem.
& when install on online server centos with directadmin there are no problem.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 7:18 am
by sozzled
So, to summarise: you have a problem—deleting the J! 3.x installation folder—with two test servers based on Ubuntu running PHP 5 and using outdated PHP modules (as Leo observed); you do not have this problem with a Windows-based test server (we don't know what version of PHP you are using there) and you do not have this problem on your live/production server (we don't know anything about the server software you are using there).

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 7:34 am
by HZolfaghar
sozzled wrote:
Mon Nov 19, 2018 7:18 am
So, to summarise: you have a problem—deleting the J! 3.x installation folder—with two test servers based on Ubuntu running PHP 5 and using outdated PHP modules (as Leo observed); you do not have this problem with a Windows-based test server (we don't know what version of PHP you are using there) and you do not have this problem on your live/production server (we don't know anything about the server software you are using there).
Unfortunately, the summary was not correct:
A-
we have not problem with deleting the J! 3.x installation folder !!!
we have problem with deleting the J! 3.9 installation folder !!!
And in the previous posts, explained the cause of the problem a few times!
B-
on three server we test & have problem:
1- ubuntu -xampp - php 5.6
2- ubuntu - xampp - php 5.6
3- ubuntu - ampps - php 5.6 & php 7.2
Are you interested in sending an FPA server that has the php of 7 & we have the problem on that ?
Do Joomla prohibit users from installing Joomla 3.9 on PHP 5 And then it will be announced that there will be an error?
on two server we test & wont have problem:
1- window - xampp - php 5.6 & php 7
2- centos - directadmin - php 5.6 & php 7.2

As a result, I do not think that because of the servers tested on it, there is a problem with the PHP version and its extension

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 7:40 am
by sozzled
I don't have this problem because ... see viewtopic.php?t=925348 8)

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 8:02 am
by HZolfaghar
sozzled wrote:
Mon Nov 19, 2018 7:40 am
I don't have this problem because ... see viewtopic.php?t=925348 8)
Unfortunately, my impression of your posts on this topic as well as the linked post, you want to remove the problem instead of trying to resolve the issue !
You are a professional Joomla user and active in the forum. But I've been working on Joomla sites for eight years, and all the sites and templates that I have designed are on local servers and, of course, Xampp server & ubuntu.
I prefer Instead of removing the problem face. In this specialized forum, the problem I have announced is scientifically resolved.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 10:03 am
by tiosus
i think it's a bug
instead of search for not accept that
please do something to solve it technically

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 5:22 pm
by leolam
tiosus wrote:
Mon Nov 19, 2018 10:03 am
i think it's a bug
instead of search for not accept that
please do something to solve it technically
Yep and NO it is not a bug but it is a server setting and the user (HZolfaghar) is too arrogant to listen to advise from professionals so leave this user with his issue unresolved since people who refuse guidance and think all they know is better than pro's here on the forum and showing lack of knowledge and refusal to listen to tips and solutions have no proper right to receive (my) help ....

Cheers

Leo 8)

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Mon Nov 19, 2018 6:10 pm
by toivo
HZolfaghar wrote:Do Joomla prohibit users from installing Joomla 3.9 on PHP 5
No, but the minimum requirement for Joomla 4 is PHP 7 - ref. https://docs.joomla.org/Potential_backw ... n_Joomla_4

HZolfaghar wrote:In this specialized forum, the problem I have announced is scientifically resolved.
As your initial testing in different configuration showed, and as confirmed by @leolam, the message occurs only in certain server configurations. For example, when I uploaded the Joomla 3.9.0 installation folder to CloudAccess.net (from launch.joomla.org - joomla.com), ran the installation and clicked the button to remove the installation folder, the removal worked normally, without any messages.

Looking at the PHP code involved, you get the same error message if the installation folder has been manually deleted before the remove button is clicked. Next time when this issue occurs to anyone, can the permissions please be checked from the file or folder that the report says is inaccessible.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Tue Nov 20, 2018 8:11 am
by HZolfaghar
toivo wrote:
Mon Nov 19, 2018 6:10 pm
HZolfaghar wrote:Do Joomla prohibit users from installing Joomla 3.9 on PHP 5
No, but the minimum requirement for Joomla 4 is PHP 7 - ref. https://docs.joomla.org/Potential_backw ... n_Joomla_4

HZolfaghar wrote:In this specialized forum, the problem I have announced is scientifically resolved.
As your initial testing in different configuration showed, and as confirmed by @leolam, the message occurs only in certain server configurations. For example, when I uploaded the Joomla 3.9.0 installation folder to CloudAccess.net (from launch.joomla.org - joomla.com), ran the installation and clicked the button to remove the installation folder, the removal worked normally, without any messages.

Looking at the PHP code involved, you get the same error message if the installation folder has been manually deleted before the remove button is clicked. Next time when this issue occurs to anyone, can the permissions please be checked from the file or folder that the report says is inaccessible.
HI
Sorry, you did not read my full description
on three server we test & have problem:
1- ubuntu -xampp - php 5.6
2- ubuntu - xampp - php 5.6
3- ubuntu - ampps - php 5.6 & php 7.2
Are you interested in sending an FPA server that has the php of 7 & we have the problem on that ?
And that this error has been viewed several times so far. And if we test ten times again, we'll see it again. It's not that it happened once.
the permission check in two mode:
1- all files & folders 777.
2- file 644 & folders 755.
but But no different.

I try to understand the cause of this. But you are trying to tell the problem of my server. If I check it out on 3 different servers.
The common point of these servers is their Ubuntu operating system.
Really, your dear answers are strange to me!

Re: "remove installation folder" button not work in joomla 3.9

Posted: Tue Nov 20, 2018 8:43 am
by leolam
Well
And in the previous posts, explained the cause of the problem a few times!
If your 'cause'
After review, I concluded that, the directory /libraries/joomla/filesysyem was removed in joomla 3.9 & when i restore this directory from joomla 3.8 the "remove installation folder" buttom Works fine.
would be fact why can I remove the installation folder on a Joomla 3.9.0 fresh vanilla install without any problems while using the button? (Centos servers with proper configured server modules) No Joomla problem and we have not any other issue on this posted anywhere in Joomla for this release....So this is a localized problem and no need to post anything on the Issue Tracker

Check in php.ini what php-functions have been disabled. One of them is most likely blocking this removal for security reasons or mod_security (if you are running this) might be blocking the action

Leo 8)
button.jpg

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Tue Nov 20, 2018 8:46 am
by Per Yngve Berg
PHP API: apache2handler

That means that php is running as the user 'www-data'. You got owner permission issues if the files where uploaded by amother user.

Use cgi/fgi so php will run as the user that uploaded the files.

Also max_post_size should be larger than the upload size.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Tue Nov 20, 2018 8:50 am
by leolam
Memory limit also seems quite weird "Memory Limit: -2M"

Leo 8)

Re: "remove installation folder" button not work in joomla 3.9

Posted: Tue Nov 20, 2018 9:36 am
by HZolfaghar
leolam wrote:
Tue Nov 20, 2018 8:43 am
Well
And in the previous posts, explained the cause of the problem a few times!
If your 'cause'
After review, I concluded that, the directory /libraries/joomla/filesysyem was removed in joomla 3.9 & when i restore this directory from joomla 3.8 the "remove installation folder" buttom Works fine.
would be fact why can I remove the installation folder on a Joomla 3.9.0 fresh vanilla install without any problems while using the button? (Centos servers with proper configured server modules) No Joomla problem and we have not any other issue on this posted anywhere in Joomla for this release....So this is a localized problem and no need to post anything on the Issue Tracker

Check in php.ini what php-functions have been disabled. One of them is most likely blocking this removal for security reasons or mod_security (if you are running this) might be blocking the action

Leo 8)

button.jpg
Hi dear leolam

Thanks for the time.
But the thing I need to point out is: On this server, all other versions of Joomla have been installed from 2.5 to 3.8.x hundreds of times.
What a major change in this part of Joomla! 3.9 Could be that caused this to happen.
For example, a change in functions and ...

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Tue Nov 20, 2018 9:51 am
by HZolfaghar
leolam wrote:
Tue Nov 20, 2018 8:50 am
Memory limit also seems quite weird "Memory Limit: -2M"

Leo 8)
changed to 1024M but not resolved.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Tue Nov 20, 2018 10:53 am
by HZolfaghar
Hi
1- I can find the problem why "remove installation folder" not work in joomla 3.9.
in new File.php in joomla 3.9 added an new IF too delete function :

Code: Select all

if (!Path::canChmod($file))
			{
				throw new FilesystemException(__METHOD__ . ': Failed deleting inaccessible file ' . $filename);
			}
"canChmod" works is : Checks if a path's permissions can be changed.
And if the answer is negative. Deletion steps are not continued.

I do not know why this Condition is included in version 3.9 of Joomla!
without access to the change of the permissions, this function can also delete the files. As it was done in previous versions.
of course, Joomla's developers have an important reason.

My suggestion is that a more complete and accurate error will be logged, To understand the error, No need to render the source of Joomla!

And on Ubuntu's operating system, because xampp and ampps are installed in system directorys. Changing the permissions requires root access, which is why the problem was encountered.

2- Obviously, Joomla's developers have deliberately or unintentionally done something: the new delete function in Joomla 3.9, which is in a new path, If you encounter an error while deleting. The old delete function will be used if available in the old path.

Re: "remove installation folder" buttom not work in joomla 3.9

Posted: Fri Nov 23, 2018 4:55 pm
by leolam
[ redacted ]Remove installation folder works fine in Joomla 3.9 (besides your specific case we (see my signature) have no incidents reported!) so please accept this and look on your server... [ redacted ]

Leo 8)