ERROR 404 after restoring Topic is solved

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.
Post Reply
trikke60
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 06, 2015 12:33 pm

ERROR 404 after restoring

Post by trikke60 » Sat Nov 14, 2020 9:03 am

Hi,

I restored my website last night, both database and PHP files. the result I got is that the homepage is visible but none of the other pages are working! to make things worse, when creating a new page starting from the homepage, I can see the link on the homepage but also on the new link I get 404.

I let the FPA run and I get B as the result, don't know if this helps.
the result: (All green except these to I marked >>> RED)

PHP API
Server suExec available >>>RED
PHP mbstring available
PHP zip, zlib or bz2 available
PHP mcrypt or sodium available
PHP cURL available
PHP allow_url_fopen available >>>RED
PHP xml or libxml available
PHP Supports MySQL or MySQLi
Known Buggy PHP
Known Buggy Zend
PHP Session Path Writable
Server Tmp Writable
PHP Supports J! 3.9.10 (PHP 7.4.12)
Database Supports J! 3.9.10

anybody some ideas for me?

greetings
Patrick
www.hetgezondehuis.be

gsmela
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Thu Jun 10, 2010 12:38 pm
Contact:

Re: ERROR 404 after restoring

Post by gsmela » Sat Nov 14, 2020 12:23 pm

Post the complete FPA so everyone can see what actually is happening.

trikke60
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 06, 2015 12:33 pm

Re: ERROR 404 after restoring

Post by trikke60 » Sat Nov 14, 2020 12:57 pm

Luckily I found my problem, .htaccess you know the hidden one :D forgot to copy this,
website back functional!

greetings
Patrick

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27539
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: ERROR 404 after restoring

Post by Per Yngve Berg » Sat Nov 14, 2020 4:57 pm

trikke60 wrote:
Sat Nov 14, 2020 9:03 am
PHP allow_url_fopen available >>>RED
Should be enabled in order for Updates to work.

Good that you found the culprit with SEF Rewrite enabled and no .htaccess file.

tribed
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Nov 13, 2020 9:21 am

Re: ERROR 404 after restoring

Post by tribed » Wed Nov 18, 2020 7:38 am

finally i got my solution from this post thanks for sharing this solution it will help those who are facing 404 error on their website really great post


Post Reply

Return to “Installation Joomla! 3.x”