Re: HTTPS no Joomla

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: HTTPS no Joomla

Postby artur_clemente » Fri Mar 17, 2017 9:07 pm

I'm enabling HTTPS on my site (joomla), however it does not work. If you type "https://clubegp.com.br/infolinktestessl.php" it works, if I try to enable HTTPS in the administrator it says "HTTPS was not enabled because it is not available on this server."
Detail in the "https://clubegp.com.br/administrator" works.
Can someone help me?k
Last edited by toivo on Fri Mar 17, 2017 11:23 pm, edited 1 time in total.
Reason: mod note: moved, not related to 3.x Security

pmleconte
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Fri Mar 17, 2017 12:55 pm

Re: Re: HTTPS no Joomla

Postby pmleconte » Sat Mar 18, 2017 10:08 am

Hi,

Where is your SSL certificat ? cloudflare ? internal certificat ?

When you look at your first page, using firebug, it contains "mixed contents".

This means that you have http and https components on this page.

For security reasons, all http requests are disabled, so everything is messed up....

Pascal

artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: HTTPS no Joomla

Postby artur_clemente » Mon Mar 20, 2017 10:58 pm

Hi Pascal,

The SSL certificate is from the infolink provider Let's "Encrypt" and shared.

I understand that when I can activate HTTPS in joomla these pages start to use only https on all pages.

What should I do to resolve this issue?

Clement

artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: Re: HTTPS no Joomla

Postby artur_clemente » Mon Mar 20, 2017 11:01 pm

Hi Pascal,

Thanks

Clemente

artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: Re: HTTPS no Joomla

Postby artur_clemente » Tue Mar 21, 2017 7:54 pm

Hi,

Where is your SSL certificate? Cloudflare Internal certificate.
Yes, it's internal. LET'S Encrytp Shared

When you look at your first page, using firebug, it contains "mixed content".
What's the command for me to see?

This means that you have http and https components on this page.

For security reasons, all http requests are disabled, so everything is confusing ...

What do I have to do to fix it, since I can not activate https by the administrator?

Artur

User avatar
cybersalt
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 116
Joined: Thu Aug 25, 2005 10:36 pm
Location: Victoria, Canada
Contact:

Re: Re: HTTPS no Joomla

Postby cybersalt » Tue Mar 21, 2017 8:30 pm

When I view your page with dev tools in Google Chrome (f12) (screen shot attached), it shows many of the elements on your page are begin server from the http: version of your url.

When I right click on your page and view source, I see "<base href="http://clubegp.com.br/"/>"

You need to set your base href to be "https:" and that should help.

Keep in mind, however, that anywhere you may be using full "http:"urls to call images on your site (if you entered a full url manually or your editor is not using relative urls) need to be changed to "https".
You do not have the required permissions to view the files attached to this post.
Tim Davis
Basic Joomla Tutorials | Cybersalt Consulting and Communications
https://www.cybersalt.com

User avatar
cybersalt
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 116
Joined: Thu Aug 25, 2005 10:36 pm
Location: Victoria, Canada
Contact:

Re: Re: HTTPS no Joomla

Postby cybersalt » Wed Mar 22, 2017 9:08 am

johnpadilla wrote:You need buy ssl and install on your hosting or servers


The screen shot shows he has an ssl certificate installed - it's the <base href> that is incorrect.
Tim Davis
Basic Joomla Tutorials | Cybersalt Consulting and Communications
https://www.cybersalt.com

artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: Re: HTTPS no Joomla

Postby artur_clemente » Wed Mar 22, 2017 3:08 pm

Cybersalt,

I already did
Step 1: configure your configuration.php file

Open your configuration.php file

Find the following line:

Var $ live_site = '';
Replace with:

Var $ live_site = 'https://www.your-domain.com';
Next, open .htaccess file then add the following code to the bottom of the file.

RewriteEngine On
RewriteCond% {HTTPS} OFF
RewriteRule (. *) Https: //% {HTTP_HOST}% {REQUEST_URI}
Step 2: Enable Force SSL in your Joomla site

does not work.

What file do I change to <base href = "http://clubegp.com.br/" />?

User avatar
cybersalt
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 116
Joined: Thu Aug 25, 2005 10:36 pm
Location: Victoria, Canada
Contact:

Re: Re: HTTPS no Joomla

Postby cybersalt » Wed Mar 22, 2017 10:07 pm

All I have ever done to set my site to https is Step 2. I haven't added anything to the htaccess (the force SSL option takes care of it) nor do I even have anything in "livesite" (a carry over from a problem I had years ago with an extension and just never bother setting it now.

Obviously base href is being set elsewhere. Do you use any extensions that manage your urls?
Tim Davis
Basic Joomla Tutorials | Cybersalt Consulting and Communications
https://www.cybersalt.com

artur_clemente
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 17, 2017 6:18 pm

Re: Re: HTTPS no Joomla

Postby artur_clemente » Thu Mar 23, 2017 12:21 pm

What's making me confused is having a new joomla installed and not working. The joomla has nothing, and is zeroed.
I did what you did and the mistake is the same. I can make the admin of this joomla test available somewhere for you to take a look. No problem, it's just testing.


Return to “Administration Joomla! 3.x”

Who is online

Users browsing this forum: Bzz and 10 guests