Failed to start session after moving to server with PHP 7.1 and 7.2 Topic is solved

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Thu Dec 06, 2018 4:50 pm

My site was running on Joomla 9.1 with PHP version 7.0.32 and I getting the message that I should enable PHP 7.1.

When I did I was getting a blank page with the word error.

I contacted my ISP and moved the site to a new server where PHP 7.1 an 7.2 are present.

Now my site will not load I get the following error:

Warning: session_start(): Failed to read session data: user (path: /opt/alt/php72/var/lib/php/session) in /home/hilair/public_html/libraries/joomla/session/handler/native.php on line 260
Error: Failed to start application: Failed to start the session
Regardless of which version of PHP I load.

I had to change the password of the cPanel when I moved to the new server.
Last edited by toivo on Thu Dec 06, 2018 5:55 pm, edited 1 time in total.
Reason: mod note: retitled, moved from 3.x Administration

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36120
Joined: Sat Apr 05, 2008 9:58 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Webdongle » Thu Dec 06, 2018 6:40 pm

How did you move your site ?
If you did it manually did you edit the configuration.php paths and database details ?
viewtopic.php?f=714&t=793531 please
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Thu Dec 06, 2018 8:31 pm

I did not move the site. Paths and data base details are the same.
I checked with phpMyAdmin the database is there.
I checked the configuration.php the only thing I am not sure of is the entry
public $Secret

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6054
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by sozzled » Thu Dec 06, 2018 8:37 pm

https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36120
Joined: Sat Apr 05, 2008 9:58 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Webdongle » Thu Dec 06, 2018 9:53 pm

Larion476 wrote:
Thu Dec 06, 2018 8:31 pm
I did not move the site. ...
But you said
Larion476 wrote:
Thu Dec 06, 2018 4:50 pm
...
I contacted my ISP and moved the site to a new server where PHP 7.1 an 7.2 are present.
...
Please ... which of your two statements is the correct one. Also FOR the UMTEENTH time of asking viewtopic.php?f=714&t=793531 please!!!
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Thu Dec 06, 2018 11:26 pm

Sorry about that.

What I meant is that my whole site was moved from one server to another, but the structure of the folders/files is exactly the same.

Also all the databases were transferred. I can access all of them.

I have several subdomains, the one not using Joomla I can access.

One subdomain,I called sandbox to try stuff, is using Joomla and I have the same problem.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36120
Joined: Sat Apr 05, 2008 9:58 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Webdongle » Thu Dec 06, 2018 11:45 pm

The database Host will be different on the new server will it not? If so then it needs to be edited in the configuration.php file. Also the database user (although the same name) will have had to be created? If so then it might not have the correct Privileges.

Please run viewtopic.php?f=714&t=793531 and post the results here.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Fri Dec 07, 2018 1:45 am

Before all this I took a backup of the site yesterday with Akeeba.

Now I created a new subdomain a new database and a new user and restored the site using the7.2 version of PHP. Apart from a couple of issues with a plugin and a module that are using deprecated command I managed to get back my site.

If I use PHP 7.0 or 7.1 I get the error again.

Questions for you. Can I restore my site to the original location? What would happen to the existing files and tables?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36120
Joined: Sat Apr 05, 2008 9:58 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Webdongle » Fri Dec 07, 2018 12:43 pm

The database is your site ... all the files do is put/get data to/from your database and display them in the browser.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24955
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Per Yngve Berg » Fri Dec 07, 2018 6:40 pm

The error is on the server. The path /opt/alt/php72/var/lib/php/session is not writeable.
Where php saves it's session is set by the save.session.path directive in php.ini

Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Sun Dec 09, 2018 12:20 pm

SOLVED with the help of my ISP.
He figured out that because of tighter security the new MySQL version did not like the user password I was using (too weak) and was creating a random one, which I had no clue what it was.
My solution was to modify the configuration.php file with the user name and password I was using in the new subdomain. I also gave that user access to the original DB. Et voila!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36120
Joined: Sat Apr 05, 2008 9:58 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Webdongle » Sun Dec 09, 2018 5:40 pm

Your Internet Service Provider helped you sort out the Host site ... are you using the free Hosting some ISP's provide?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Larion476
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jun 24, 2008 12:00 pm

Re: Failed to start session after moving to server with PHP 7.1 and 7.2

Post by Larion476 » Sun Dec 09, 2018 6:26 pm

No I am paying for my hosting


Post Reply

Return to “Installation Joomla! 3.x”