Upgraded to php 7.3 and cannot access site.

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
jlearned
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Thu Feb 26, 2009 7:58 pm

Upgraded to php 7.3 and cannot access site.

Post by jlearned » Wed Feb 26, 2020 8:13 pm

I finally upgraded php to 7.3 on a Joomla 3.9.15 site that was stable on php7.0. When I try to access the front site I get the following error: Warning: session_start(): Failed to read session data: user (path: /tmp) in /home2/kayakers/public_html/libraries/joomla/session/handler/native.php on line 260
Error: Failed to start application: Failed to start the session.

I then tried php 7.2 and 7.1 and got the same error and everything went back to normal when I went all the way back to 7.0.

Here is what FPA reported:
Forum Post Assistant (v1.4.9 (lambrusca) : 26th February 2020 wrote:
Last PHP Error(s) Reported :: wrote:[26-Feb-2020 14:03:29 America/Chicago] PHP Warning: session_start(): Failed to read session data: user (path: /tmp) in /home2/kayakers/public_html/libraries/joomla/session/handler/native.php on line 260
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.15-Stable (Amani) 27-January-2020
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (644) | Owner: --protected-- . (uid: /gid: ) | Group: --protected-- (gid: ) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: http://www.kayakersgocoastal.com | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: 2 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.15: Yes | Database Supports J! 3.9.15: Unknown | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 3.10.0-693.11.6.1.ELK.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 377.65 GiB |

PHP Configuration :: Version: 7.3.13 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: error_log; | Last Known Error: 26th February 2020 14:03:29. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Connection Error: : Database Credentials Present? in Configuration...
Detailed Environment :: wrote:PHP Extensions :: Core (7.3.13) | date (7.3.13) | libxml (7.3.13) | openssl (7.3.13) | pcre (7.3.13) | zlib (7.3.13) | filter (7.3.13) | hash (7.3.13) | pcntl (7.3.13) | readline (7.3.13) | Reflection (7.3.13) | SPL (7.3.13) | session (7.3.13) | standard (7.3.13) | cgi-fcgi () | ionCube Loader (10.3.9) | Zend Engine (3.3.13) |
Potential Missing Extensions :: xml | zip | curl | iconv | mbstring | mysqli | pdo_mysql |
Disabled Functions :: dl |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_mailto (3.0.0) ? | com_wrapper (3.0.0) ? |
3rd Party:: WF_POPUPS_WINDOW_TITLE (2.6.31) ? | WF_POPUPS_JCEMEDIABOX_TITLE (2.6.31) ? | WF_AGGREGATOR_VIMEO_TITLE (2.6.31) ? | WF_AGGREGATOR_DAILYMOTION_TITLE (2.6.31) ? | WF_AGGREGATOR_VINE_TITLE (2.6.31) ? | WF_AGGREGATOR_[youtube]_TITLE (2.6.31) ? | WF_LINK_SEARCH_TITLE (2.6.31) ? | WF_LINKS_JOOMLALINKS_TITLE (2.6.31) ? | WF_FILESYSTEM_JOOMLA_TITLE (2.6.31) ? | WF_VISUALCHARS_TITLE (2.6.31) ? | WF_CLIPBOARD_TITLE (2.6.31) ? | WF_FORMATSELECT_TITLE (2.6.31) ? | WF_CLEANUP_TITLE (2.6.31) ? | WF_LINK_TITLE (2.6.31) ? | WF_BROWSER_TITLE (2.6.31) ? | WF_VISUALBLOCKS_TITLE (2.6.31) ? | WF_PRINT_TITLE (2.6.31) ? | WF_INLINEPOPUPS_TITLE (2.6.31) ? | WF_LAYER_TITLE (2.6.31) ? | WF_FULLSCREEN_TITLE (2.6.31) ? | WF_NONBREAKING_TITLE (2.6.31) ? | WF_DIRECTIONALITY_TITLE (2.6.31) ? | WF_LISTS_TITLE (2.6.31) ? | WF_AUTOSAVE_TITLE (2.6.31) ? | WF_SOURCE_TITLE (2.6.31) ? | WF_ARTICLE_TITLE (2.6.31) ? | WF_SPELLCHECKER_TITLE (2.6.31) ? | WF_PREVIEW_TITLE (2.6.31) ? | WF_TEXTCASE_TITLE (2.6.31) ? | WF_IMGMANAGER_TITLE (2.6.31) ? | WF_STYLE_TITLE (2.6.31) ? | WF_FONTSIZESELECT_TITLE (2.6.31) ? | WF_STYLESELECT_TITLE (2.6.31) ? | WF_EMOTIONS_TITLE (2.6.31) ? | WF_CONTEXTMENU_TITLE (2.6.31) ? | WF_SEARCHREPLACE_TITLE (2.6.31) ? | WF_FONTCOLOR_TITLE (2.6.31) ? | WF_MEDIA_TITLE (2.6.31) ? | WF_HR_TITLE (2.6.31) ? | WF_XHTMLXTRAS_TITLE (2.6.31) ? | WF_TABLE_TITLE (2.6.31) ? | WF_KITCHENSINK_TITLE (2.6.31) ? | WF_ANCHOR_TITLE (2.6.31) ? | WF_CHARMAP_TITLE (2.6.31) ? | WF_FONTSELECT_TITLE (2.6.31) ? |

Components :: ADMIN ::
Core :: com_modules (3.0.0) ? | com_joomlaupdate (3.6.2) ? | com_menus (3.0.0) ? | com_banners (3.0.0) ? | com_categories (3.0.0) ? | com_cpanel (3.0.0) ? | com_installer (3.0.0) ? | com_tags (3.1.0) ? | com_languages (3.0.0) ? | com_associations (3.7.0) ? | com_admin (3.0.0) ? | com_newsfeeds (3.0.0) ? | com_redirect (3.0.0) ? | com_media (3.0.0) ? | com_ajax (3.2.0) ? | com_actionlogs (3.9.0) ? | com_content (3.0.0) ? | com_config (3.0.0) ? | com_postinstall (3.2.0) ? | com_search (3.0.0) ? | com_finder (3.0.0) ? | com_login (3.0.0) ? | com_fields (3.7.0) ? | com_checkin (3.0.0) ? | com_users (3.0.0) ? | com_cache (3.0.0) ? | com_messages (3.0.0) ? | com_contenthistory (3.2.0) ? | com_templates (3.0.0) ? | com_plugins (3.0.0) ? | com_privacy (3.9.0) ? |
3rd Party:: com_sitemapgenerator (1.4.0) ? | com_rsform (2.3.8) ? | com_widgetkit (2.9.19) ? | COM_JCE (2.6.31) ? | BaGallery (2.1.0) ? | Akeeba (7.0.2) ? |

Modules :: SITE ::
Core :: mod_finder (3.0.0) ? | mod_wrapper (3.0.0) ? | mod_articles_popular (3.0.0) ? | mod_login (3.0.0) ? | mod_breadcrumbs (3.0.0) ? | mod_footer (3.0.0) ? | mod_articles_category (3.0.0) ? | mod_custom (3.0.0) ? | mod_banners (3.0.0) ? | mod_menu (3.0.0) ? | mod_stats (3.0.0) ? | mod_languages (3.5.0) ? | mod_users_latest (3.0.0) ? | mod_syndicate (3.0.0) ? | mod_search (3.0.0) ? | mod_whosonline (3.0.0) ? | mod_tags_similar (3.1.0) ? | mod_articles_news (3.0.0) ? | mod_articles_categories (3.0.0) ? | mod_articles_latest (3.0.0) ? | mod_random_image (3.0.0) ? | mod_articles_archive (3.0.0) ? | mod_feed (3.0.0) ? | mod_related_items (3.0.0) ? | mod_tags_popular (3.1.0) ? |
3rd Party:: Widgetkit (2.9.19) ? | RSForm! Pro Feedback Module (2.1.0) ? |

Modules :: ADMIN ::
Core :: mod_popular (3.0.0) ? | mod_multilangstatus (3.0.0) ? | mod_login (3.0.0) ? | mod_privacy_dashboard (3.9.0) ? | mod_latestactions (3.9.0) ? | mod_custom (3.0.0) ? | mod_menu (3.0.0) ? | mod_latest (3.0.0) ? | mod_status (3.0.0) ? | mod_logged (3.0.0) ? | mod_version (3.0.0) ? | mod_feed (3.0.0) ? | mod_quickicon (3.0.0) ? | mod_title (3.0.0) ? | mod_submenu (3.0.0) ? | mod_toolbar (3.0.0) ? | mod_sampledata (3.8.0) ? | mod_stats_admin (3.0.0) ? |
3rd Party:: KC Admin QuickIcons (3.2.0) ? |

Libraries ::
Core ::
3rd Party:: file_fof30 (3.5.1) ? | GJFields - a set of additional JFor (1.2.15) ? | uk_UA_gjfields_language_pack (2018-11-07 12) ? | en_GB_gjfields_language_pack (2018-11-07 12) ? | Regular Labs Library (20.2.1812) ? |

Plugins ::
Core :: plg_editors-xtd_image (3.0.0) ? | plg_editors-xtd_module (3.5.0) ? | plg_editors-xtd_pagebreak (3.0.0) ? | plg_editors-xtd_article (3.0.0) ? | plg_editors-xtd_menu (3.7.0) ? | plg_editors-xtd_readmore (3.0.0) ? | plg_editors-xtd_fields (3.7.0) ? | plg_system_cache (3.0.0) ? | plg_system_updatenotification (3.5.0) ? | plg_system_privacyconsent (3.9.0) ? | plg_system_sef (3.0.0) ? | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_logout (3.0.0) ? | plg_system_highlight (3.0.0) ? | plg_system_redirect (3.0.0) ? | plg_system_log (3.0.0) ? | plg_system_languagefilter (3.0.0) ? | plg_system_languagecode (3.0.0) ? | plg_system_remember (3.0.0) ? | plg_system_sessiongc (3.8.6) ? | plg_system_stats (3.5.0) ? | plg_system_fields (3.7.0) ? | plg_system_p3p (3.0.0) ? | plg_system_logrotation (3.9.0) ? | plg_system_debug (3.0.0) ? | plg_user_contactcreator (3.0.0) ? | plg_user_terms (3.9.0) ? | plg_user_joomla (3.0.0) ? | plg_user_profile (3.0.0) ? | plg_search_tags (3.0.0) ? | plg_search_contacts (3.0.0) ? | plg_search_categories (3.0.0) ? | plg_search_newsfeeds (3.0.0) ? | plg_search_content (3.0.0) ? | plg_privacy_consents (3.9.0) ? | plg_privacy_actionlogs (3.9.0) ? | plg_privacy_user (3.9.0) ? | plg_privacy_message (3.9.0) ? | plg_privacy_content (3.9.0) ? | plg_extension_joomla (3.0.0) ? | plg_installer_packageinstaller (3.6.0) ? | PLG_INSTALLER_URLINSTALLER (3.6.0) ? | plg_installer_webinstaller (2.0.1) ? | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) ? | plg_fields_textarea (3.7.0) ? | plg_fields_list (3.7.0) ? | plg_fields_user (3.7.0) ? | plg_fields_imagelist (3.7.0) ? | plg_fields_radio (3.7.0) ? | plg_fields_color (3.7.0) ? | plg_fields_checkboxes (3.7.0) ? | plg_fields_integer (3.7.0) ? | plg_fields_calendar (3.7.0) ? | plg_fields_url (3.7.0) ? | plg_fields_sql (3.7.0) ? | plg_fields_repeatable (3.9.0) ? | plg_fields_usergrouplist (3.7.0) ? | plg_fields_text (3.7.0) ? | plg_fields_media (3.7.0) ? | plg_fields_editor (3.7.0) ? | plg_captcha_recaptcha_invisible (3.8) ? | plg_captcha_recaptcha (3.4.0) ? | plg_finder_tags (3.0.0) ? | plg_finder_contacts (3.0.0) ? | plg_finder_categories (3.0.0) ? | plg_finder_newsfeeds (3.0.0) ? | plg_finder_content (3.0.0) ? | plg_quickicon_phpversioncheck (3.7.0) ? | plg_quickicon_privacycheck (3.9.0) ? | plg_quickicon_extensionupdate (3.0.0) ? | plg_quickicon_joomlaupdate (3.0.0) ? | plg_content_pagenavigation (3.0.0) ? | plg_content_pagebreak (3.0.0) ? | plg_content_vote (3.0.0) ? | plg_content_fields (3.7.0) ? | plg_content_finder (3.0.0) ? | plg_content_emailcloak (3.0.0) ? | plg_content_joomla (3.0.0) ? | plg_content_loadmodule (3.0.0) ? | plg_content_confirmconsent (3.9.0) ? | PLG_ACTIONLOG_JOOMLA (3.9.0) ? | plg_twofactorauth_yubikey (3.2.0) ? | plg_twofactorauth_totp (3.2.0) ? | plg_authentication_ldap (3.0.0) ? | plg_authentication_gmail (3.0.0) ? | plg_authentication_cookie (3.0.0) ? | plg_authentication_joomla (3.0.0) ? |
3rd Party:: Editors-XTD - Widgetkit (2.9.19) ? | plg_editors-xtd_betterpreview (6.2.4) ? | BaGallery - Shortcode (2.0.7) ? | System - Widgetkit ZOO (2.9.19) ? | System - RSForm! Pro reCAPTCHA v2 (2.0.5) ? | System - Widgetkit (2.9.19) ? | PLG_SYSTEM_BACKUPONUPDATE (7.0.2) ? | plg_system_jce (2.6.31) ? | PLG_SYSTEM_AKEEBAUPDATECHECK (7.0.2) ? | System - Widgetkit K2 (2.9.19) ? | System - RSForm! Pro PDF (2.0.4) ? | System - RSForm! Pro (1.52.1) ? | System - RSForm! Pro Delete Submiss (1.0.0) ? | plg_system_regularlabs (20.2.1812) ? | plg_system_betterpreview (6.2.4) ? | BaGallery - System (2.0.7) ? | plg_extension_jce (2.6.31) ? | Installer - YOOtheme (1.0.2) ? | plg_installer_jce (2.6.31) ? | plg_installer_rsform (1.0.0) ? | PLG_INSTALLER_AKEEBABACKUP (7.0.2) ? | plg_fields_mediajce (2.6.31) ? | plg_editors_jce (2.6.31) ? | plg_editors_codemirror (5.40.0) ? | plg_editors_tinymce (4.5.11) ? | plg_quickicon_jce (2.6.31) ? | plg_quickicon_akeebabackup (7.0.2) ? | Content - Widgetkit (2.9.19) ? | plg_content_jce (2.6.31) ? | Content - RSForm! Pro (1.51.1) ? | et_EE_autoreadmore_language_pack (2018-05-06 19) ? | en_GB_autoreadmore_language_pack (2018-05-06 19) ? | es_ES_autoreadmore_language_pack (2018-05-06 19) ? | da_DK_autoreadmore_language_pack (2018-05-06 19) ? | nb_NO_autoreadmore_language_pack (2018-05-06 19) ? | th_TH_autoreadmore_language_pack (2018-05-06 19) ? | GJFields - a set of additional JFor (1.2.14) ? | uk_UA_gjfields_language_pack (2018-04-18 23) ? | en_GB_gjfields_language_pack (2018-04-18 23) ? | ru_RU_autoreadmore_language_pack (2018-05-06 19) ? | fa_IR_autoreadmore_language_pack (2018-05-06 19) ? | it_IT_autoreadmore_language_pack (2018-05-06 19) ? | fr_FR_autoreadmore_language_pack (2018-05-06 19) ? | uk_UA_autoreadmore_language_pack (2018-05-06 19) ? | pt_BR_autoreadmore_language_pack (2018-05-06 19) ? | pl_PL_autoreadmore_language_pack (2018-05-06 19) ? | pt_PT_autoreadmore_language_pack (2018-05-06 19) ? | PLG_CONTENT_AUTOREADMORE_TITLE (4.5.25) ? | PLG_ACTIONLOG_AKEEBABACKUP (7.0.2) ? |
Templates Discovered :: wrote:Templates :: SITE :: yoo_venice (1.0.8) ? | beez3 (3.1.0) ? | protostar (1.0) ? |
Templates :: ADMIN :: isis (1.0) ? | hathor (3.0.0) ? |
Any help would be appreciated. . .

 
User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2133
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Upgraded to php 7.3 and cannot access site.

Post by JAVesey » Wed Feb 26, 2020 8:20 pm

jlearned wrote:
Wed Feb 26, 2020 8:13 pm
Any help would be appreciated. . .
Whilst running PHP7.0, set Session Handler (in Global Configuration) to PHP then try a later PHP version.

Are all your extensions (components, modules, plug-ins and templates), including those that don't use Joomla's Update Notification System in /administrator, up to date and compatible with PHP 7.3? You might have to do so leg-work manually in this regard.

I'm a bit concerned with the "Unknown" entry for "database supports Joomla version" in the FPA output.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.16 and PHP7.4.x

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26611
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Upgraded to php 7.3 and cannot access site.

Post by Per Yngve Berg » Wed Feb 26, 2020 8:31 pm

The 'mysqli' client module is not loaded in php 7.3. You cannot connect to the database.

You should load the other as well.

Potential Missing Extensions :: xml | zip | curl | iconv | mbstring | mysqli

jlearned
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Thu Feb 26, 2009 7:58 pm

Re: Upgraded to php 7.3 and cannot access site.

Post by jlearned » Wed Feb 26, 2020 9:22 pm

I contacted hosting provider and they gave me the run around saying Joomla 3.9.15 is not supported by php 7.3. I then tried explaining that their version of php 7.3 was missing mysqli extension and client module and they said there was nothing they could do.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5515
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Upgraded to php 7.3 and cannot access site.

Post by AMurray » Wed Feb 26, 2020 9:29 pm

I'm quite happily running Joomla 3.9.15 on PHP 7.4.2 so what they say is incorrect (meaning 7.3 will work if properly configured). Time to move hosts I would say.

The same issue would exist for PHP 7.1 and 7.2 as you had the same errors.
Last edited by AMurray on Wed Feb 26, 2020 9:35 pm, edited 1 time in total.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

jlearned
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Thu Feb 26, 2009 7:58 pm

Re: Upgraded to php 7.3 and cannot access site.

Post by jlearned » Wed Feb 26, 2020 9:32 pm

I tried explaining that to this gal and her boss and she says the problem is with Joomla and that they have been turning all clients back to Joomla for support

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12074
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Upgraded to php 7.3 and cannot access site.

Post by toivo » Thu Feb 27, 2020 12:47 am

Write to your host and include the advice from @Per Yngve Berg and @AMurray, based on their experience in many similar upgrades of PHP. Nothing to do with Joomla 3.9.15, everything to do with the configuration of their server.
Toivo Talikka, Global Moderator

jlearned
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Thu Feb 26, 2009 7:58 pm

Re: Upgraded to php 7.3 and cannot access site.

Post by jlearned » Thu Feb 27, 2020 12:51 am

It is odd, I upgraded another site with same version of Joomla to php7.3, same host and all works just fine. This now leads me to believe there is something wrong with this Joomla Installation.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12074
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Upgraded to php 7.3 and cannot access site.

Post by toivo » Thu Feb 27, 2020 1:53 am

Same host but probably a different server with a different configuration. Run the FPA on the site that works fine and post the results here for comparison.

Except for the missing PHP extensions listed after 'Potential Missing Extensions', which are significant, and the value in LiveSite, which is normally blank, your earlier FPA results look normal.

However, check if the .htaccess file in the main Joomla folder is the version installed with Joomla, identical with the file htaccess.txt, or is it something different.
Toivo Talikka, Global Moderator

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26611
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Upgraded to php 7.3 and cannot access site.

Post by Per Yngve Berg » Thu Feb 27, 2020 5:14 am

Doesn't the server run Cpanel?

Select the php version and toggle it to select what php modules to include.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5515
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Upgraded to php 7.3 and cannot access site.

Post by AMurray » Thu Feb 27, 2020 10:28 am

I have a feeling you won't be able to get into PHPMYAdmin either, if the database issue (the mySQLi extension) is a general issue with the database system, not specifically to Joomla.

If you can manage to restore a backup to your local PC, running WAMPServer, see if you can run the site with PHP 7.3.14 or similar - if you can, that seems to support our claims it is the host not Joomla that is the trouble.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

 

Post Reply

Return to “Administration Joomla! 3.x”