Not receiving new user email alerts Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Not receiving new user email alerts

Post by yumasan » Thu Sep 23, 2021 8:31 pm

Our site administration for new user account activation is set to Administrator.
We have 4 administrator accounts and none of them receive emails when a new user has activated their account. Not even the main email account that is associated in the server area of the joomla installation is notified.
What do I need to do to fix this?
Last edited by toivo on Wed Sep 29, 2021 9:13 pm, edited 1 time in total.
Reason: mod note: moved from 3.x Administration

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Thu Sep 23, 2021 8:34 pm

Have you enabled the setting Receive System Emails for each of your site administrator accounts?

Have you enabled the setting Send Mail to Administrators on the Users: Options » User Options tab?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Thu Sep 23, 2021 8:47 pm

Thanks, yes, both of these options are enabled.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40345
Joined: Sat Apr 05, 2008 9:58 pm

Re: Not receiving new user email alerts

Post by Webdongle » Thu Sep 23, 2021 8:50 pm

Is your site email your site address or gmail etc?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Thu Sep 23, 2021 9:00 pm

Webdongle wrote:
Thu Sep 23, 2021 8:50 pm
Is your site email your site address or gmail etc?
Site email.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Thu Sep 23, 2021 9:08 pm

Thanks, @Webdongle: good suggestion. Thanks for the info, @yumasan. One more quick question from me: what happens when you click the Send Test Email button at Global Configuration » Server » Mail Settings ??? Do you receive the test mail?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Thu Sep 23, 2021 9:15 pm

Yep, it works just fine.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Thu Sep 23, 2021 9:17 pm

I don't have any other thoughts at this time. The process works fine for me on my J! 3.10.2 websites. Sorry.

(A bit more background about my own circumstances—related but also a little off-topic: viewtopic.php?f=708&t=986118&p=3629875&#p3629875)
Last edited by sozzled on Thu Sep 23, 2021 9:55 pm, edited 1 time in total.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Thu Sep 23, 2021 9:18 pm

I understand, thanks for trying. I appreciate all the suggestions and help.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Thu Sep 23, 2021 10:10 pm

I'm only saying that I receive these kinds of emails. Approving new accounts is the next step, of course.

Have you and your other site administrators checked your spam folder? Maybe these emails are going there? ???
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Fri Sep 24, 2021 3:11 pm

Thanks, no spam emails. Isn't there a module or plugin that controls emails that might be disabled?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40345
Joined: Sat Apr 05, 2008 9:58 pm

Re: Not receiving new user email alerts

Post by Webdongle » Fri Sep 24, 2021 7:00 pm

What are your email settings in Global config?
Could it be that the site is sending to several admins at the same time and the server only wants one at a time?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Fri Sep 24, 2021 7:08 pm

I'm not sure which settings you are referring to.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Fri Sep 24, 2021 7:13 pm

Whatever is shown on Global Configuration » Server (see https://docs.joomla.org/Help310:Site_Gl ... ion#Server for screenshot; lower right area).

Although I don't know if this information helps because sending test emails works as we noted earlier. There may be a webhosting issue involved, though. :) What could be interesting to know is if the email addresses of the other site administrators are all valid and they work. For example, if one of those addresses rejects incoming mail, that may prevent the other site administrators receiving their incoming mail (but that, too, is grasping at straws). :-\

It may be worth looking at the email processing log. I'll search the forum to find where you can look for that.

yumasan wrote:
Fri Sep 24, 2021 3:11 pm
Isn't there a module or plugin that controls emails that might be disabled?
It can't be a module. I don't know of any plugin that might affect these things (unless you've installed a third-party one?). 8)
Last edited by sozzled on Fri Sep 24, 2021 7:33 pm, edited 4 times in total.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Fri Sep 24, 2021 7:17 pm


User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Fri Sep 24, 2021 7:21 pm

Thanks for the information. OK, so you're using SMTP mail. That shouldn't be a problem (unless you have an overly restrictive webhosting provider who doesn't like people sending mail via a third-party email service) but we already established that sending a test email works, didn't we?

UPDATE: Here's the information about digging into email problems: viewtopic.php?t=963422#p3531233
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Fri Sep 24, 2021 7:26 pm

Yeah, test send worked just fine.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Fri Sep 24, 2021 7:27 pm

See my updated reply sent just now. :)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Fri Sep 24, 2021 7:32 pm

sozzled wrote:
Fri Sep 24, 2021 7:21 pm

UPDATE: Here's the information about digging into email problems: viewtopic.php?t=963422#p3531233
OK, I might try this. I still feel like something is disabled somewhere.
We have a webform we use that sends emails to 3 different people without any issues.

Thanks again.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40345
Joined: Sat Apr 05, 2008 9:58 pm

Re: Not receiving new user email alerts

Post by Webdongle » Fri Sep 24, 2021 8:38 pm

Where did you download the installation package from?

Have you tested with 'New User Account Activation' set 'Self?
Use one of your spare email addresses to test see if the email gets the link.

Also make sure you use Protostar as default Template while testing.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Mon Sep 27, 2021 2:04 pm

Hello @Webdongle, this is a live website that has been live for years. I honestly don't recall how it was installed. I have not tried the self option as we are requiring admins to approve accounts. I will try to test this later. Thanks for the advice.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40345
Joined: Sat Apr 05, 2008 9:58 pm

Re: Not receiving new user email alerts

Post by Webdongle » Mon Sep 27, 2021 3:20 pm

In Global config >>> Server settings ... you may wish to set 'Disable Mass Mail' to yes?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Mon Sep 27, 2021 4:06 pm

I wonder though, we use a mass emailing option for our newsletter, would that affect this program?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40345
Joined: Sat Apr 05, 2008 9:58 pm

Re: Not receiving new user email alerts

Post by Webdongle » Mon Sep 27, 2021 4:20 pm

Testing is the best way to find out. Not 100% sure but methinks that setting is send all at one time or individually not total sent?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Mon Sep 27, 2021 5:03 pm

"Mass mail" has nothing to do with being alerted to (by email) to requests to approve new account registrations, unless docs.joomla.org is completely wrong.

See my earlier unanswered question about looking into the server log: what does the file everything.php show?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Mon Sep 27, 2021 5:58 pm

Thanks @sozzled, I have not turned on the debug option, so the everything.php does not exist.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10883
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not receiving new user email alerts

Post by sozzled » Mon Sep 27, 2021 7:30 pm

What happens when you follow @toivo's instructions in viewtopic.php?t=963422#p3531233 ???
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Mon Sep 27, 2021 8:42 pm

I have not tried it yet. I am not doing this full time. Something I do on the side when I can. Thanks again, I'll look into it further when I can.

yumasan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Wed Jul 29, 2009 3:33 pm
Contact:

Re: Not receiving new user email alerts

Post by yumasan » Wed Sep 29, 2021 6:29 pm

All, thank you for your help. I found that there was a setting in our Community Builder component that was not set correctly. It has similar settings as the User management settings in Joomla! and one setting I had to change was the group the admins were all in. Once I updated this, the emails started coming thru!

Thanks again!


Post Reply

Return to “Extensions for Joomla! 3.x”