Fatal error: Call to a member function get() . . .

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
pjki
Joomla! Guru
Joomla! Guru
Posts: 627
Joined: Sun Feb 14, 2010 9:12 pm
Contact:

Fatal error: Call to a member function get() . . .

Post by pjki » Wed Nov 14, 2012 5:20 am

Fatal error: Call to a member function get() on a non-object in /home/pjkin3/public_html/Joomla3/Joomla_3/plugins/system/jcktypography/jcktypography.php on line 58

I was on my site yesterday and just uploaded an image and installed it on the front page. That's the last I saw of my website.
I just tried viewing it tonight and the above error message is what I see.

Any suggestions what may have happened and how to fix it?
It's Joomla 3

kryps
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Mon Oct 16, 2006 8:19 pm

Re: Fatal error: Call to a member function get() . . .

Post by kryps » Wed Nov 14, 2012 3:34 pm

Looks like an error with the JCK extension you installed. Did you talk to JCK support?

User avatar
pjki
Joomla! Guru
Joomla! Guru
Posts: 627
Joined: Sun Feb 14, 2010 9:12 pm
Contact:

Re: Fatal error: Call to a member function get() . . .

Post by pjki » Sat Nov 17, 2012 4:42 am

No, haven't yet. But maybe I'll just DELETE that for now. It doesn't work anyway when I try and enable it and use it. The site won't use any other editor but TinyMCE. No other editor works on Joomla 3, not even the other one that is offered -- Mirror or Code Mirror or something. That one cannot be used either.

Samot Orbsla
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Dec 11, 2012 10:56 am

Re: Fatal error: Call to a member function get() . . .

Post by Samot Orbsla » Mon Dec 17, 2012 9:20 am

I runned into the same problem. After uninstalling JCK the problem is gone.
Regarding "kryps" question about talking to JCK support - I couldn't find any support option at JCK at all.


Locked

Return to “Administration Joomla! 3.x”