Issue with Login form generating 404

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
ponderworks
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 19, 2007 1:43 am
Contact:

Issue with Login form generating 404

Postby ponderworks » Sun Sep 17, 2017 1:20 am

I am in the process of completing configuration of a new Joomla 3.7 site. I recently noticed that when entering a valid user name and password on the login form of the website, instead of directing the user to the home page (presumably the default page) it generates the following:

-------------------------
Not Found

The requested URL /"website"/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache Server at "website".org Port 443

--------------------------

I've looked at the forum and did a general internet search, tried a couple of things but nothing seems to work. Most of the references I was finding were not for Joomla 3.7 so I wondered if I tripped over something different.

Any ideas would be gratefully accepted!

Thanks, et

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 23553
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Issue with Login form generating 404

Postby Per Yngve Berg » Sun Sep 17, 2017 2:03 am

Can you access your site using https?

ponderworks
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 19, 2007 1:43 am
Contact:

Re: Issue with Login form generating 404

Postby ponderworks » Sun Sep 17, 2017 2:19 pm

Interesting question! No, I just tried it and it returns the same error message.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 23553
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Issue with Login form generating 404

Postby Per Yngve Berg » Sun Sep 17, 2017 6:10 pm

There you have the issue. Login over https is enablef.

ponderworks
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 19, 2007 1:43 am
Contact:

Re: Issue with Login form generating 404

Postby ponderworks » Mon Sep 18, 2017 3:38 am

Many thanks to all of you helping with this! I am making some progress. What is happening as you can see from the 404err attachment is that the system is trying to login using https. However, as you can also see from my server settings the system was not told to force https. I have not yet bought and loaded a security cert and the new site is not yet "live".

If I can find a way to have it login using regular http will that resolve the problem?
You do not have the required permissions to view the files attached to this post.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 23553
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Issue with Login form generating 404

Postby Per Yngve Berg » Mon Sep 18, 2017 7:45 am

Check the settings in the login module.


Return to “Administration Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 11 guests